Chevy Impala Forums - Reply to Topic
Thread: Camshaft Actuator Solenoid (2008 LS 3.5L flex K) Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
08-14-2019 09:41 PM
Adavis So was it just the wires ?
09-27-2013 07:33 PM
Ray2138 So I spliced the wire together and cut the light off with my obdII reader. Everything is ok ill just have to order another plug connector. ALSO if the actuator goes bad it will effect how the tranny shift . I didn't believe if but it does. it gives it that hard stiff snatch into gear as they are changing. I thought my tranny was messed up again so I took it back to the place that rebuilt it. And that's when I found out that it effects it. And I also found out my oil pressure sending unit circuit is bad or the unit it self is bad .
09-27-2013 10:21 AM
kingnutin That would be much easier, and cheaper! I bet that's it.
09-27-2013 05:56 AM
Ray2138 Checking it out the morning. when I unplugged the connector, to check it and the wire is frayed. It was rubbing against the serpentine belt. So I may be just looking at a plug connector .
09-26-2013 10:11 PM
Ray2138
Quote:
Originally Posted by kingnutin View Post
No problem, wish I could help further, but I have not had to replace one of those yet.
It's looks fairly easy like four screws and a plug. Ill let you know how it turns out.
09-26-2013 04:00 PM
kingnutin No problem, wish I could help further, but I have not had to replace one of those yet.
09-26-2013 02:06 PM
Ray2138 I swear man you are a life saver!!!! I look forward to your responses on my questions. I figured out earlier today at work that the piece I was looking at was the cam actuator. I just needed the confirmation. So now it's finding the part and figuring out can I do it myself .
09-26-2013 09:47 AM
kingnutin It has come up a couple times here, but it isn't common. The actuator is located on the front of the block where the camshaft goes in. Directly under the PS pulley.
09-25-2013 04:37 PM
Ray2138
Camshaft Actuator Solenoid (2008 LS 3.5L flex K)

Started my car this morning and out of no where , my CEL came on. I plugged up my OBDII , and it gave me a "P0010" code. Which came to be "Camshaft Position (CMP) actuator solenoid control circuit ". Im not sure exactly where this actuator is located, or how hard it would be to access and change it if possible. I have yet to find anybody else with the same problem yet with theirs. ANY ideas or input would be greatly appreciated.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome