Chevy Impala Forums - Reply to Topic
Chevy Impala 7th Gen Discussion W-Body 2000-2005. Discuss all Chevy Impala 7th Generation Performance and Technical Discussion here.

Thread: HELP! Clunk when taking off from stop Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
10-03-2019 09:38 PM
My 2003 Impala Do they make a shift kit for these?
09-30-2019 08:13 AM
My 2003 Impala Mine seems to do it when taking off from a stop on a hill the most
09-28-2019 01:14 AM
wz7u Yeah, it forces the 1st gear fluid path to be active when you physically put the shift quadrant into low. Once you start off you can ram it up into drive and it should function as normal. Assuming the other shift solenoids are acting fine...
09-27-2019 10:15 PM
My 2003 Impala
Quote:
Originally Posted by wz7u View Post
The reason I posted what I did earlier is because in my '03 with the 3.4, the transmission will shudder/clunk/slip/toggle between go and slip sometimes when starting off in drive. When I pull the selector into 1 at the stop light, it starts out as normal. My self diagnosis was a flaky shift solenoid in the valve body. Which, for what a tranny runs, I'm willing to go semi stick shift till I have a more solid reason to pull the engine/tanny assy out. Which will be very difficult without a lift.

I have noticed this same thing recently in my '03 with the 3.4 a shudder/clunk, it usually happens when stopped on an incline, sometimes does when I step hard on the accelerator from a stop. I was planning on a fluid/filter change anyway since I'm pushing 187k on my car
08-21-2019 05:41 AM
ChevyBoySnow1017 I tried what you said & it shifts fine like you said when I shift it to 1
08-20-2019 10:31 PM
wz7u The reason I posted what I did earlier is because in my '03 with the 3.4, the transmission will shudder/clunk/slip/toggle between go and slip sometimes when starting off in drive. When I pull the selector into 1 at the stop light, it starts out as normal. My self diagnosis was a flaky shift solenoid in the valve body. Which, for what a tranny runs, I'm willing to go semi stick shift till I have a more solid reason to pull the engine/tanny assy out. Which will be very difficult without a lift.
08-16-2019 01:58 PM
Pattrick_Martin2001 Preignition???
08-16-2019 12:26 AM
wz7u Does it do this when starting out in Drive? Have you tried duplicating when starting out in 1?
08-14-2019 11:57 AM
Bill58 Check cradle bolts and bushings.
08-13-2019 09:23 PM
sheila May check axle nut tightness.
08-13-2019 08:56 PM
ChevyBoySnow1017
HELP! Clunk when taking off from stop

Hey guys I have a 2003 Impala Ls 3800 I’ve been working on the car since I got it.the car had a bad transmission when I first bought it I changed the transmission but the car was still clunking when taking off from a stop (it feel like somebody hit me from the rear)if I take off slow it won’t do it ... It’s clunks when accelerating from a stop or turning a low speeds... it’s not all the time tho it’s like it will clunks a couple times then will run fine until I cut car off and start it again... sometimes when I get off work and go home it won’t clunk at all ... now I replaced both axles (I DO need axle Seals), Lower Control Arms, passenger wheel hub, inner & outer tie rods, Engine & Transmission Mounts, Short Dog Bones & poly bushings, MAF & MAP Sensor, Cleaned ThrottleBody, new TPS Sensor, new PCV Valve & It STILL CLUNKS CAN ANYBODY FIGURE OUT WHAT IT MIGHT BE

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome