Chevy Impala Forums - Reply to Topic
Chevy Impala 8th Gen Discussion W-Body 2006-2013 (2014+ Limited). Discuss all Chevy Impala 8th Generation Performance and Technical Discussion here.

Thread: 138k Transmission Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
04-15-2019 09:49 PM
Jay.D It’s my experience when people change transmission fluid and filter and then the transmission fails shortly after. That transmission already had wear problems and the dirty trans fluid was actually keeping the transmission from slipping. I always change trans fluid and filter in every used vehicle I buy and never had a problem. What I also do is only change as much fluid as exits when I drop the pan to change filter. Usually about 4-5 qts with a small block V-8.
I also always add Lucas transmission additive when adding fluid. I have a 93’ GMC k-1500 5.7tbi I’ve owned for 18 years and has 264,xxx miles. It has the original 4L60E that’s never been touched besides a few filters and adding Lucas, It’s still going strong.
04-11-2019 04:33 PM
billyo So, fluid only? Fluid and filter? Prayers?

Chad[/QUOTE]

I am on my 4th impala LTZ
I had a 01 with 260K no issues
05 LTZ 250K intake gasket,wheel hubs the general stuff everybody deals with .
Went two a 2013 LTZ ,Cat converter ,then valve job at 80K ,hubs,brake rotors all the time , at 160K it started Acting as though the tranny was junk only at certain slight load on throttle it shuttered . Drove it for 10K like that and lost confidence, Could figure out what it was ,thought maybe motor but finally best guess was torque converter . Didn't want to start fixing stuff that didn't need fixing. Figured it would go completely. I travel a lot long distance and said screw it and gave it to son and I bought a 2015 Impala loaded 6cyl . Kid still driving 2013 and he has put 15K more on it and its the same. it is the only one i serviced tranny in at 100K . Never again. If fluid is clean just keep driving it.
04-09-2019 10:27 AM
sheila ^+1 Chad. No serviceable filter or pan. Easier than an oil change. I loosen/remove atf cap/dipstick to help vent, without jacking up the car, I slide a drain pan under in front of the lf tire, locate the 11mm drain plug, loosen/remove with a 3/8" dr. ratchet, short extension, 11mm socket, and drain. I install the plug finger tight and tighten with a 1/4" dr. ratchet, short ext. and 11mm socket. You can use deep wells instead of the exts. and short sockets. I then refill with 6 qts. (just like an oil change). Do this when cold (like a spark plug change) due to steel drain plug and aluminum tranny bottom case. Easy peasy, lol.
04-09-2019 09:22 AM
hatzie
Quote:
Originally Posted by ss4chad View Post
Really? Wow, I would have been under that damm thing for hours looking for a pan! Does it not have a filter? Guess not if I can't drop the pan, funny thing though, O'reilly's says they have a filter for that car, weird.

Ok, fluid only and I agree, change it now and again in about another 3000 miles.

Thanks again!

Chad
You can change the pickup strainer if you want to pull the transmission and completely disassemble it.

As others have said. I'd drain what you can using the drain plug, re-fill it with Dexron VI, and do it again with the engine oil change in another 5,000 miles or so. If it doesn't drain nice and clear red do it again in another 5K.

Cut a section out of the rubber transmission oil cooler return line and install a metal 3/8" Magnefine transmission filter. Change this filter every oil change for three changes, then every 2nd oil change... be sure to top it back up with with the half pint or so of Dexron VI you lost with the filter.
Use Fuel Injection Clamps or spring band clamps on the hose not Jubilee Worm clamps.

You can cut the metal filter can open with a big pipe cutter.



04-09-2019 09:03 AM
ss4chad You guys are awesome!

Chad
04-09-2019 08:33 AM
Joes74challenger on my 16 1/2 ton silverado they don't show a listing for a trans fluid change....transfer case fluid would be at 97k miles....on the severe duty section they list trans and transfer case at 40k miles (i'm guessing typo on the standard duty chart?). i'm still kind of looking into whether or not to change it on the 8 speed. seems like even though it's a sealed unit that is a lot of shifting every day in city traffic to last 97k miles without a fluid change at least.
04-09-2019 08:31 AM
12 lt
Quote:
Originally Posted by plano-doug View Post
I was wondering about that. I've not serviced my 2013's transmission yet (at ~40k miles). So I don't have any hands-on with it. But, before I posted, I checked on Autozone, and danged if they don't indicate there is one.

Doug

.
Ummm yeah, some parts stores also list a tps for the throttle body on my 2012 but the part looks nothing at all like anything that would fit anywhere on my car.

Pic @SAAN posted is accurate, there is no pan to drop.

Just drained and refilled the trans fluid in our 2012 again over the weekend and got out about 5.5 qts.
04-09-2019 08:30 AM
Joes74challenger thanks for that pic. i've always wondered how the they looked on the 6 speeds.
04-09-2019 08:12 AM
SAAN
This is for a Traverse, but the Impala will be very similar, its the same 3.6L/6spd FWD auto.
04-09-2019 07:45 AM
plano-doug
Quote:
Originally Posted by 12 lt View Post
The transmission with the 12 and newer lfx engines has no serviceable filter.
I was wondering about that. I've not serviced my 2013's transmission yet (at ~40k miles). So I don't have any hands-on with it. But, before I posted, I checked on Autozone, and danged if they don't indicate there is one.

Doug

.
04-09-2019 07:19 AM
ss4chad
Quote:
Originally Posted by 12 lt View Post
Cannot drop the pan, there is no pan on this transmission to drop. There is a drain bolt that can be reached from the driver side of the car without putting the car on ramps. You will likely get 5-5.5 qts to drain.
Really? Wow, I would have been under that damm thing for hours looking for a pan! Does it not have a filter? Guess not if I can't drop the pan, funny thing though, O'reilly's says they have a filter for that car, weird.

Ok, fluid only and I agree, change it now and again in about another 3000 miles.

Thanks again!

Chad
04-09-2019 07:07 AM
12 lt
Quote:
Originally Posted by ss4chad View Post
The car is a 2013 Impala LTZ. Planned on dropping the pan and replacing the filter and the fluid this weekend, along with a Left Side ABS harness.

Thanks for the reassurance!

Chad
Cannot drop the pan, there is no pan on this transmission to drop. There is a drain bolt that can be reached from the driver side of the car without putting the car on ramps. You will likely get 5-5.5 qts to drain.
04-09-2019 07:05 AM
12 lt Assuming in your saying the fluid is 6 years old, that you are saying the car is a 2013. The transmission with the 12 and newer lfx engines has no serviceable filter. I am not a mechanic, but if it were mine I would drain and change now, and again as soon as you can within the next 3-5000 miles or sooner. When you drain, if possible measure how much old comes out and put the same amount back in with new. Check the fluid after the second change for color and if it is nice and pink then get on to a regular schedule, if not go for another drain and change.
04-09-2019 06:59 AM
ss4chad Thanks Doug!

The car is a 2013 Impala LTZ. Planned on dropping the pan and replacing the filter and the fluid this weekend, along with a Left Side ABS harness.

Thanks for the reassurance!

Chad
04-09-2019 06:39 AM
plano-doug
Quote:
Originally Posted by ss4chad View Post
So, fluid only? Fluid and filter? Prayers?
I think the consensus will be drain and fill (and filter). No flush. I'm not a transmission mechanic - only repeating what I've read - but it seems reasonable. And that's what I've always done on all my vehicles.

It's not clear what model year you have so I'm not sure what transmission is in your car, but the later 6T70's don't have the bad rep that the earlier 4T65E's did. So there's a bit less concern if you have the 6-speed 6T70.

I believe the gasket is re-usable, so, unless it's damaged, you want to keep it rather than use the one that comes in the filter package.

HTH.

Doug

.
This thread has more than 15 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome