Chevy Impala Forums - Reply to Topic
Automotive Discussion General automotive related discussion only.

Thread: windshield wiper water does not work anymore Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
03-07-2019 08:47 AM
lawnenforcement
quick video on how to replace the pump

03-22-2011 11:44 PM
thacarter546 ^thats the most common problem as they dont use hose clamps from the factory.

Alot of times the spray nozzles themselves get clogged up, use a sewing needle to clean the nozzles out.
03-20-2011 10:31 AM
WallyLO when i bought mine, there was a little hose unplugged. i noticed it was spraying on the ground in the garage and plugged it back in
03-20-2011 07:49 AM
tmusquiez http://www.extendedgmwarranty.com/ow...let-Impala.pdf

Page 402. It's in the Underhood Fuse Block. See page 308 for more info.

There's a WSW (Windshield Wiper) and a WPR (Wiper) fuse.

Not too sure which to check, but check both while you're at it.
03-20-2011 07:41 AM
cl_smooth would I need to check the fuses under the hood or the fuses in the inside the car
03-20-2011 01:19 AM
kingnutin Did you check fuses yet? After that if you still haven't found the problem, try testing the washer motor. Most diagnostics have to be done in steps
03-20-2011 01:01 AM
cl_smooth
windshield wiper water does not work anymore

I have a 2007 chevy impala and the water control does not work anymore so when I try to cleam my windows not water comes out. I made sure that the water was full in the engine bay, but not water. Does anyone out there have any clue of what going on with my windshield wipers and the water that does not shot onto my windshield anymore. What is the problem and is it something that I may be able to fix myself

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome