Chevy Impala Forums - Reply to Topic
Chevy Impala 8th Gen Discussion W-Body 2006-2013 (2014+ Limited). Discuss all Chevy Impala 8th Generation Performance and Technical Discussion here.

Thread: Turn signal, trunk release button, electric door locks not working Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
06-28-2019 09:30 AM
mdubyk Did you get your issue resolved?
08-29-2018 05:51 AM
tsophy
Turn signal, trunk release button, electric door locks not working

So I'll try to tell what happened as quickly as possible. I was driving home and noticed my left turn signal was on and I couldn't shut it off, no matter what I did it kept blinking. When I parked my car, I shut the car off and when I opened the door, the radio and interior lights stayed on, which usually turn off when I open the door. I then started my car again and the flasher kept flashing. I then unhooked the battery hoping it would reset the electrical system. After about 5 minutes with the battery unhooked, I hooked it up and restarted the car. The turn signal was off but now it wouldn't work at all and the hazards wouldn't work either. Not only that but my trunk button wouldn't open the trunk and my door lock button didn't work but if I used my key fob both the doors would lock and the trunk would pop open. My windshield wipers work but not the wiper fluid. Everything else seems to work. Does anybody know if there is one thing that could be causing all these electrical problems? My car is a 2006 Chevy Impala LT and I don't want to pay a ton of money when my car isn't worth much at all.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome