Chevy Impala Forums - Reply to Topic
Chevy Impala 9th Gen Discussion Epsilon II 2014+. Discuss all Chevy Impala 9th Generation Performance and Technical Discussion here.

Thread: Bad BCM? Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
03-31-2019 08:45 PM
apguy Our 14' impala was doing the same thing(service side detection, service front camera, ect ) minus the dash cutting out issues. I swapped out both of the blind spot sensors in the rear bumper and the drivers side was all swelled up. The white cover was popped loose from one side because of it. I found 2 sensors that were pulled off a 2016 GMC Terrain.($60 total) They are a slightly different design and thinner in thickness so I need to fab up a spacer to soak up the gap inside the sleeves molded in the bumper but all the messages went away and it seems to be working fine.

It's been about 2 weeks and knock on wood the BCM is still happy even though they were never programmed to the car.



This is a known issue but I'm not taking my car into a dealer to get a few $200 sensors installed in the rear bumper and hope and pray they work through next rain storm or winter season. Another sh*t design by GM that they won't own up to.
03-25-2019 10:47 PM
Jerry1 Wondering if anyone has more information on this issue. My son in law has a 2015 LTZ with this same issue. Out of warranty and the dealer wants $1700 to fix it. Says he needs two modules and a new wire harness. Hoping someone here has fixed this themselves and knows the part numbers. Or, is this not a DIY fix. Son in law said the quote was about 50/50 labor/parts. So, $800+ for the parts. If I have the right parts on line, two modules are $215 each and a harness is $50. The labor to put them in can't be that hard but I suspect that the dealer or a proper technician would have to do some programing.

Any ideas would be appreciated. Also, proper names of the parts or parts numbers would be great to make sure I'm looking at the right parts if for nothing else to try to get a more reasonable quote from the dealer or an independent mechanic.

Thanks.
04-12-2018 01:11 PM
hisstory32 In the late 90s , I took my car in for an oil change and the mechanic spotted cracking on the sidewalls of all my
tires. He recommended not driving over 40 mph and go to a tire dealer of that company. I showed the tire dealer and no
argument, he replaced the tires. I paid for labor.

I filed a report as a safety hazard report with NHTSA about the tires. They called me and asked various questions.
Guy told me if enough complains come in they start investigating.

In March the following year, there was recall of those tires...FIRESTONE
I received cost of what I paid for labor plus they replaced the tires with different tires at no cost.

I recommend those having problems with the blind spot system to file a report with NHTSA as a safety hazard.
04-12-2018 11:09 AM
joeblow3 2014 same problem blind spot detection sensor bad on drivers side...
04-02-2018 09:34 AM
Kevinh333 Definitely should be a "safety" recall, as it has happened so many time to so many car owners that the modules and harness are both on back order with no ETA. If anybody knows where I can access two of the modules near the stated price of $215.00 that the GM wholesales are quoting for each I'd appreciate hearing from you!
03-31-2018 01:43 PM
jtrosky Maybe my post wasn't clear - I'm not saying that it's "OK" if you paid for a feature and it doesn't work right. My point was that I think that at least some people become so reliant on these technologies that they start to rely on them instead of just paying attention. I'm sure they are "nice to have" when they work properly, but it's when they don't work properly (and people are relying on them too much) that I see problems. If the car is too hard to drive safely because of the way it is designed (like c-pillars being too thick) then I consider that a design flaw with the vehicle. You shouldn't have to rely on the car to tell you if it's safe to switch lanes.

Again, just my opinion. You know the saying - everyone has one. :-)

Sent from my TbooK 16 Pro(E5C8) using Tapatalk
03-31-2018 01:10 PM
GM-Fan
Those options don't come for free

Quote:
Originally Posted by jtrosky View Post
In my opinion, (....snip) If you need the car to park for you, brake for you or beep at you if you are ready to collide with the car next to you, then maybe you should be more careful while driving (or not driving at all)! :-)

<end rant>

Don't get me wrong, I like technology, but you are just asking for trouble if people start relying on the car to do the driving more than the driver...

Sent from my TbooK 16 Pro(E5C8) using Tapatalk
The devices for collision, lane departure, back up radar and Blind spot indicators are there as safety devices. Cars equipped with Auto-braking are supposed to do it faster than a human can react.

In the 2014 Impala, the C pillar is thick. You can lose sight of a car in that area. That is why Side detection is important to assist. When my Blind spot indicator failed I almost entered the lane, but barely caught the glimpse of the grill of another car just ahead of the C pillar.

Chevy can sell without those options, but the customer pays for them, they have to work. The options can not kinda work or sometimes work or report false data.

Look at it as buying any product and it being defective. Radio, Hair drying, or whatever. If it doesn't work you want it replaced or your money back. These "safety" products just happen to be affixed to cars that list up to the $40K range. It is a big deal if someone is injured or killed because one of these devices fails to operate as advertised.
03-30-2018 02:20 PM
GM-Fan
Why isn't this a recall? Known Safety Issue

It definitely sounds like a recall problem. I noted to my dealer a couple times I got a front camera warning, random collision alerts with no cars around. Numerous near collisions because the blind spot detector didn't work. Now my passenger BSD is constantly "on" even with the car off and locked. I'm past my warranty now. I am going to have to eat the cost to repair a known issue, dangerous, and defective product.

Further reading of comments sounds like the repairs are just band-aids and the defective system can possibly fail again, causing serious injuries or death.
03-29-2018 01:03 PM
jtrosky In my opinion, cars are starting to get a little *too* advanced with all of these sensors (self-parking, self-braking, etc)... There is just too much that can (and does) fail - and that can (and does) impact the safety of the vehicle when they do fail. I'm OK with ABS and traction control, but anything more than that and I think that you are just asking for trouble. If you need the car to park for you, brake for you or beep at you if you are ready to collide with the car next to you, then maybe you should be more careful while driving (or not driving at all)! :-)

<end rant>

Don't get me wrong, I like technology, but you are just asking for trouble if people start relying on the car to do the driving more than the driver...

Sent from my TbooK 16 Pro(E5C8) using Tapatalk
03-29-2018 12:55 PM
Kevinh333
Part Numbers?

Anybody know what the part numbers are for the modules and the connectors? Are the modules interchangeable left to right?
03-29-2018 12:37 PM
Kevinh333 Ditto Ditto Ditto; 2014 Impala, same issues, same problem, dealer says $1200 to fix it by replacing both modules and connectors and says GM has been paying partial repairs on some vehicles do to the safety issues, outside of warranty; limp mode, won't start, won't stop, wife will not drive the car anymore, afraid of getting stranded on a cold Minnesota night, can't blame her.

GM customer service tells me they will not cover anything as the car is outside of the bumper to bumper warranty, safety issue or no safety issue!? Drove GM for many years until this happened back in the 80's drove Toyota's, Mazda's and Honda's ever since with zero issues repeat ZERO issues until this Impala.

Looks like I will be going back to the foreign brands as this is the 4th time I have had this car go into limp mode or fail to start to some sensor issue or another in less than 4 months.

hat a disaster of a car or is it the brand?
03-28-2018 11:01 PM
Anderoonie What a coincidence that I stumble upon this thread

My '14 LTZ (79k miles) just started exhibiting this same behavior. Began with the driver's side blind spot light going crazy every so often when nothing was there. Now about a week later, the airbag light is on, no climate control power (random times), and I'm usually not able to easily unlock the car using the key fob. There was one start where the instrument cluster was completely dead, but the car was running and I was able to drive. That was alarming, to say the least. There are also several times when all systems display a message saying they need to be serviced. I've got an appointment with the dealer next week. Scared to see how much this is going to cost.

I'll add I've also had an interesting issue where sometimes (rarely) it will have a very rough start and run rough for maybe a minute, all the crazy messages display across the screen saying all the systems have failed, and then moments later after driving it runs fine and all the messages go away, including the check engine light. Not sure if that's related. It's really rare, maybe once every three months. Still love this car though. This is the only major problem I've had, other than a wheel bearing which was covered by my extended warranty. Stay tuned!
03-23-2018 06:50 AM
Adudewicz1
Quote:
Originally Posted by ChevroletCustomerService View Post
Hi juleshaw2077,

We're sorry to learn of the numerous concerns you've experienced with your Impala. We recognize how frustrating these unexpected issues must be, especially given that you're out of warranty. If you decide to have your dealership take a look, please know we'd be happy to offer an extra layer of assistance during the diagnosis and repair process. Feel free to send us a private message or email [email protected]. We'll just need your contact information, VIN, mileage and preferred dealer.

To learn more about GMs privacy policy, please visit https://www.gm.com/privacy-statement.html.

Best,
Lauren E.
Chevrolet Customer Care

I'm having this same issue. See the thread i've started here: https://www.impalaforums.com/audio-vi...-pot-hole.html This is absolutely unsafe. I've been unable to start my car several times and my theft deterrent system and cluster go crazy while i'm driving. Is this issue a recall yet?
03-16-2018 07:43 AM
ponzini1957 E-mailed the general manager at the Chevy dealership on 2/28/18 about my side detection system repair notice going on. He told me to make a service appointment. E-mailed my sales person on 3/1/18 asking if this would be covered under my warranty (purchased this 2015 Impala LTZ June 2017). Never heard back from him so made first appointment possible with service which was 3/5/18 - was told my bumper to bumper expired on 3/2/18! Called GM and left message stating I would have brought it in before then if I had known!!!! Fortunately for me I purchased an extended warranty which covered the issue except I had to pay $100 deductible. I left the dealership yesterday and noticed it was not working and on my way to work today either. The light lit up on my driver's side mirror a couple of times when a car was there but nothing on my dashboard. I called the service department after I got to work and they thought it might not be programmed right so now I have to go back again and be shuttled back and forth to work - what a pain! From what I have read, sounds like I might be having more issues in the future! It definitely sounds like a recall issue to me!
03-07-2018 04:10 PM
pagecranker
me too same problems

I am having all the same problems, took my Impala LTZ in April of 2017 for driver side detection system , dealer repaired under warranty, fix didnt even last a year, both side detection is not working along with park assist and front camera and lane detection, dealer wants $120 just to diagnose problem, ask if previous repair was warranted and was told no, ended with car warranty which ended a month after the fix will see what happens when i bring it in,sounds like this should be a recall problem
This thread has more than 15 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome