2007 Impala 3.5L RPM increase and self-acceleration - Chevy Impala Forums
Mechanical and Electrical Problems Having problems with your Chevy Impala? Discuss it here.

User Tag List

 1Likes
  • 1 Post By Bill58
 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 4 Weeks Ago Thread Starter
Junior Member
 
Jeray's Avatar
 
Join Date: Feb 2016
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
2007 Impala 3.5L RPM increase and self-acceleration

Hi. I'm new to this Forum and I would certainly appreciate your help in this matter. I have a 2007 Impala LT 3.5L (non-Flex), with about 190,000 miles. I have been running a K&N Air filter in it since about 70,000. I an attempt to increase the gas mileage, I cleaned the filter (I do this regularly), clean the MAF sensor using 91% Isopropyl Alchohol (I have never done this previously), and clean the Throttle body with STP Throttle Body cleaner. I did not remove the throttle body from the intake and manually opened and closed the valve. Every since then I have had issues with idle RPM. At first, it was idling between 1500 - 1800 when in park, and quite higher than normal when driving down the road as well. I unplugged the battery for several hours and then performed the Throttle Body re-learn procedure. That helped some, but it was still pretty high. I then removed the throttle body entirely and thoroughly cleaned it. I also removed the Throttle Position Sensor and cleaned it, though it was still very clean inside. I again preformed the re-learn procedure. My Idle in park is normal now (maybe a touch higher that before, about 750 now). When I shift into Drive or Reverse, with my foot on the brake, it stays normal. However, as soon as my speed increases just from rolling forward or backward the RPM jumps up to about 1,100 without me touching the accelerator pedal. If I do nothing but take my foot off the brake, the car will accelerate, on it's own, to about 35-40 MPH. even at 50-60 MPH, I feel like I barely have to touch the gas.

I read afterwards that you are not supposed to manually open and close the Throttle Body Valve. I figure I might have messed up the Throttle position sensor by doing so. I am hoping I did not screw up the Throttle Body itself.

I would greatly appreciate any assistance you might be able to provide in this matter.

Thank you,
Jon

Last edited by Jeray; 4 Weeks Ago at 11:50 PM. Reason: Spelling
Jeray is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 4 Weeks Ago
Senior Member
 
Bill58's Avatar
 
Join Date: Apr 2017
Location: Frederick, MD
Posts: 217
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 52 Post(s)
Thanks: 3
Thanked 25 Times in 25 Posts
Garage
Throttle Body Re-learn (3.5, 3.9 and 5.3 engines)
Per GM SI...
Quote:
- Remove the air cleaner outlet duct.
- Inspect the throttle body bore and the throttle plate for deposits. You will need to open the throttle plate in order to inspect all surfaces. Do not insert any tools into the throttle body bore in order to avoid damage to the throttle valve plate.
- Clean the throttle body bore and the throttle plate using a clean shop towel with GM Top Engine Cleaner or an equivalent product.
- Install the air cleaner outlet duct.
- Perform the Throttle Learn Procedure.


Throttle learn procedure:
Quote:
- Start and idle the engine in PARK for 3 minutes.
- The ECM will start to learn the new idle cells and Desired RPM should start to decrease.
- Ignition OFF for 60 seconds.
- Start and idle the engine in PARK for 3 minutes.
- After the 3 minute run time the engine should be idling normal.
sheila likes this.

Last edited by Bill58; 4 Weeks Ago at 02:23 PM.
Bill58 is online now  
post #3 of (permalink) Old 4 Weeks Ago Thread Starter
Junior Member
 
Jeray's Avatar
 
Join Date: Feb 2016
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
I appreciate that, but as I stated I've already done the TB re-learn (several times in fact).
Jeray is offline  
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome