High beam lights turn on when I signal - Chevy Impala Forums
Mechanical and Electrical Problems Having problems with your Chevy Impala? Discuss it here.

User Tag List

 5Likes
  • 2 Post By 12 lt
  • 1 Post By imamacuser
  • 2 Post By imamacuser
 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 10-10-2019 Thread Starter
Junior Member
 
imamacuser's Avatar
 
Join Date: Oct 2015
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
High beam lights turn on when I signal

High beam lights turn on when I signal on my 2006 Impala 9C1. I have to cycle between the left and right turn signal a few times to get them to turn off.

This issue seems more apparent in cold weather.

Any ideas what the issue is?

2006 Impala LS (9C1)
imamacuser is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 10-10-2019
Senior Member
 
12 lt's Avatar
 
Join Date: Feb 2017
Posts: 1,056
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 240 Post(s)
Thanks: 73
Thanked 85 Times in 80 Posts
Garage
A bad multiswitch would be my first guess. Possible there may be a short across the circuits, but would not seem as likely, then again the police models are notorious for having wiring issues.
plano-doug and sheila like this.

My 6 year constantly asks why. What adults can learn from 5 and 6 year olds, to listen with your ears and mind open. Hard to learn when you don't listen ......
12 lt is offline  
post #3 of (permalink) Old 10-10-2019 Thread Starter
Junior Member
 
imamacuser's Avatar
 
Join Date: Oct 2015
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Yes, they really monkey with the wiring. The high beams weren't even connected when I bought the car, the harness was just hanging loose.

Do I have to remove the steering wheel to replace the multi-function switch?

2006 Impala LS (9C1)
imamacuser is offline  
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 10-10-2019
Senior Member
 
12 lt's Avatar
 
Join Date: Feb 2017
Posts: 1,056
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 240 Post(s)
Thanks: 73
Thanked 85 Times in 80 Posts
Garage
Quote:
Originally Posted by imamacuser View Post
Do I have to remove the steering wheel to replace the multi-function switch?
Would not think so, have not replaced one on an impala, but have replaced others and never had to remove the wheel. Usually a couple screws or bolts under or on the side of the column.

What you say about the high beam harnesses hanging loose, would have me wondering if they had them connected to the emergency lights and somehow tied into the blinkers/hazards too.

My 6 year constantly asks why. What adults can learn from 5 and 6 year olds, to listen with your ears and mind open. Hard to learn when you don't listen ......
12 lt is offline  
post #5 of (permalink) Old 10-10-2019 Thread Starter
Junior Member
 
imamacuser's Avatar
 
Join Date: Oct 2015
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
This issue is a recent development, so a bad multi-function switch would make sense.
sheila likes this.

2006 Impala LS (9C1)
imamacuser is offline  
post #6 of (permalink) Old 4 Weeks Ago
Super Moderator
 
Dwayne J's Avatar
 
Join Date: Jan 2009
Posts: 3,886
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 87 Post(s)
Thanks: 16
Thanked 362 Times in 234 Posts
Check grounds too, sometimes a bad ground can cause electricity to find a ground thru other means.

My dad had a truck that exhibited the under dash interior lights coming on when you stepped on the brake. Was a bad ground and the power was backfeeding thru the circuit to find a ground.

Dwayne
96 Caprice with AI 200cc package
Best et 11.5
Best MPH 116
Just another taxi
Dwayne J is offline  
post #7 of (permalink) Old 4 Weeks Ago Thread Starter
Junior Member
 
imamacuser's Avatar
 
Join Date: Oct 2015
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
I found some multi-function switch reviews that that say replacing the multi-function switch solved the exact issue that I'm dealing with.

I'll start by replacing the multi-function switch and see if that solves the issue.

Thanks everyone.
sheila and 12 lt like this.

2006 Impala LS (9C1)
imamacuser is offline  
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome