2003 Imp. Radiator Fans Not Working consistently - Chevy Impala Forums
Mechanical and Electrical Problems Having problems with your Chevy Impala? Discuss it here.

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 2 Weeks Ago Thread Starter
Junior Member
 
bhayward14's Avatar
 
Join Date: Sep 2019
Location: Missouri, America
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Garage
2003 Imp. Radiator Fans Not Working consistently

So on the wife's '03 Impala, I've swapped the temp. sensor (behind the throttle body) twice. The first one was because I noticed her radiator fans weren't working and her temperature gauge was bouncing between 120 and 220 degrees. The same thing happened with the new one. Just wondering if anybody has also had the same problems, and if so, what you did to fix it.
bhayward14 is offline  
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome