2006 Implal LT 3.9L V6 rough idle - Chevy Impala Forums
Mechanical and Electrical Problems Having problems with your Chevy Impala? Discuss it here.

User Tag List

 2Likes
  • 1 Post By retiredpauly
  • 1 Post By GM?
 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 01-08-2018 Thread Starter
Junior Member
 
rjpeek's Avatar
 
Join Date: Jan 2018
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
2006 Implal LT 3.9L V6 rough idle

I think at idle it's only running on 3 cylinders. It runs rough at idle, remove any one of the front (2, 4, 6) three spark plug wires from the plug does not make it idle worse but removing any one of the back (1, 3, 5) makes it rougher. With the engine off I can remove all three front wires and start the car. I think it has something to do with the Active Fuel Management.
rjpeek is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 01-08-2018
Administrator

 
retiredpauly's Avatar
 
Join Date: Jan 2012
Location: Cochrane Alberta Canada
Posts: 10,837
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 233 Post(s)
Thanks: 1,501
Thanked 2,434 Times in 1,438 Posts
2006 3.9 Does not have AFM. It was added in 07.

Is the money light on in the dash ?

If so what is the code ? P0300, 0302, 0304, 0306 ? Random misfire

Maybe ignition module.
Maybe crank sensor
Maybe cam sensor

You would want to hook a scanner to it before firing the parts cannon at it.

IMO that is

ANd

Welcome to the forum
plano-doug likes this.

Some things are better left unsaid, which I generally realize right after I have said them.
retiredpauly is offline  
post #3 of (permalink) Old 01-08-2018 Thread Starter
Junior Member
 
rjpeek's Avatar
 
Join Date: Jan 2018
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
It had a P0300, I don't think it's the ignition module because I see and hear it sparking when I remove the wire from the plug. How would the crank or cam sensor affect the front cylinders (2, 4, 6)? Are there two cam sensors, one for the back three and one for the front three?
rjpeek is offline  
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 01-08-2018
Administrator

 
retiredpauly's Avatar
 
Join Date: Jan 2012
Location: Cochrane Alberta Canada
Posts: 10,837
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 233 Post(s)
Thanks: 1,501
Thanked 2,434 Times in 1,438 Posts
Have you changed the plugs ?

Random misfires can be caused by many many things. Bad wires,bad plugs, vacuum leaks, stuck egr etc.
Not sure if these guys use wasted spark or not with the IM.
The front 3 cylinders are interesting however.
Do you hear/see the spark at the plugs or at the IM?
Have you removed the plugs and inspected them ?
How many miles on this ?
Could be a FI problem where the front 3 are not getting fuel as well.

When you take the plugs out you may want to check the compression on the front 3. Perhaps one of the VVT actuators took a crap and the valves are either stuck open or so retarded the spark event happens at the wrong time.

Some things are better left unsaid, which I generally realize right after I have said them.
retiredpauly is offline  
post #5 of (permalink) Old 01-09-2018 Thread Starter
Junior Member
 
rjpeek's Avatar
 
Join Date: Jan 2018
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
For the front plugs I hear/see the spark when I remove the wire/boot from the plug, for the back plugs I hear/see the spark when I remove the wire from the ignition module.

Yes I inspected the plugs, five of them had carbon build up on them, thinking it might be burning a lot of oil, while the sixth plug (cylinder #6 ) looked very clean as if someone replaced it for some strange reason. I did replace all of them just to make sure.

Mileage: 140k

I ordered a Fuel Injector Pulse Tester last night so I can test the injectors, I still have to purchase a fuel pressure gauge.

How many Variable Valve Timing (VVT) actuators does this engine have?

Last edited by rjpeek; 01-09-2018 at 02:08 PM.
rjpeek is offline  
post #6 of (permalink) Old 06-29-2019
GM?
Junior Member
 
GM?'s Avatar
 
Join Date: Jun 2019
Location: Cottonwood California
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by retiredpauly View Post
Have you changed the plugs ?

Random misfires can be caused by many many things. Bad wires,bad plugs, vacuum leaks, stuck egr etc.
Not sure if these guys use wasted spark or not with the IM.
The front 3 cylinders are interesting however.
Do you hear/see the spark at the plugs or at the IM?
Have you removed the plugs and inspected them ?
How many miles on this ?
Could be a FI problem where the front 3 are not getting fuel as well.

When you take the plugs out you may want to check the compression on the front 3. Perhaps one of the VVT actuators took a crap and the valves are either stuck open or so retarded the spark event happens at the wrong time.
OK You are not getting what that guy is saying..It is only misfiring at idle..
it has good plugs it has good wires and the car has plenty of power on the freeway and r
oad driving, this misfire only seams to happen at idle. I have a 2007 Impala with one of these AFM motors and it is doing the same thing ..it throws a p0306 #6 cylinder misfire code. When the misfire occurs there is no lifter noise present, if a AFM lifter Was collapsed I would expect to hear it tapping... I assume if the injectors on that bank were starved for fuel I would have drive-ability issues ,this thing has loads of power when you floor it out in the field..
It seams to be getting bad data only at idle... And when you first start it it will purr like a kitten for several seconds until the computer does it's set up thing and then it takes over and causes the Misfire to start. And once in a while it will come to a stop light and not miss at all...Gonna put a compression tester on #6 later today This motor has less than 30,000 on new built motor .. Of course being a GM that does not mean much...
$6,661.00 for the rebuild in 2015.. Ouch! I got this car for $460.00
The original owner after buying this GM car new then proceeded to dump another 15,000 into it in tranny and motor replacement just gave up..
He was just not gonna take that damned thing to the shop ever again..
The giant stack of receipts from the mechanic shop was enough to sway Me to buy the car..
If you or anyone has an idea witch silly sensor is causing this misfire I would love any advice.. Throttle position sensor? If I get an AFM delete unit and plug it in will it start and just suddenly run smoothly... It won't smog in November If I can't get it to play nice and stop throwing itself into a misfire at idle....
GM? is offline  
post #7 of (permalink) Old 2 Weeks Ago
GM?
Junior Member
 
GM?'s Avatar
 
Join Date: Jun 2019
Location: Cottonwood California
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Fix the Misfire at idle Chevy Impala..

Problem solved no wrenching...

OK This might sound crazy but it is worth a try..
Had these issues with My 07 3.9 Impala,,

Rough idle check engine light..

My miss was on #6 .
I did do and see and test a lot of the things you did ..
#6 plug too clean,, Starts up fine then idles down and misses..


Thought it was the AFM system for sure...
Bought an AFM disable device from range technology..
Did not do anything to idle problem..


Tried Dura Lube's "Severe" fuel system cleaner I got originally for cleaning the injectors..
Never used it.. because of the other symptoms you mentioned..
Figured ,what the hell total fuel system cleaner right.. might as well put it in...
It did something!! Don't know what it did or cleaned. But the miss got faint and eventually went away.
Not only that.. The check engine light turned off on it's own...
It's about ten bucks at Walmart..
I do not Know what it cleaned but it magically fixed it.. Maybe fuel pressure increase? Maybe clogged injector port?
I did two bottles in succession because it was so effective...
Car is now quiet and smooth at stop lights and the spark plug in the before missing cylinder is finally looking a bit burnt.. The plug in the bad cylinder was always way too clean before.. I know how You feel.. You need a miracle..
Get Dura Lube's "Severe" fuel system cleaner add half a bottle to 3/4 tank of gas twice.
Or a half a bottle to a half tank twice like I did.. do not over dilute the cleaner..
Then You can just use Berryman b12 chem-tool regularly after that to keep the fuel system clean.

Good luck hope it saves You too.....

Last edited by GM?; 2 Weeks Ago at 01:35 PM. Reason: To add important information.
GM? is offline  
post #8 of (permalink) Old 2 Weeks Ago
GM?
Junior Member
 
GM?'s Avatar
 
Join Date: Jun 2019
Location: Cottonwood California
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Problem solved no wrenching...

OK This might sound crazy but it is worth a try..
Had these issues with My 07 3.9 Impala,,

Rough idle check engine light..

My miss was on #6 .
I did do and see and test a lot of the things you did ..
#6 plug too clean,, Starts up fine then idles down and misses..


Thought it was the AFM system for sure...
Bought an AFM disable device from range technology..
Did not do anything to idle problem..


Tried Dura Lube's "Severe" fuel system cleaner I got originally for cleaning the injectors..
Never used it.. because of the other symptoms you mentioned..
Figured ,what the hell total fuel system cleaner right.. might as well put it in...
It did something!! Don't know what it did or cleaned. But the miss got faint and eventually went away.
Not only that.. The check engine light turned off on it's own...
It's about ten bucks at Walmart..
I do not Know what it cleaned but it magically fixed it.. Maybe fuel pressure increase? Maybe clogged injector port?
I did two bottles in succession because it was so effective...
Car is now quiet and smooth at stop lights and the spark plug in the before missing cylinder is finally looking a bit burnt.. The plug in the bad cylinder was always way too clean before.. I know how You feel.. You need a miracle..
Get Dura Lube's "Severe" fuel system cleaner add half a bottle to 3/4 tank of gas twice.
Or a half a bottle to a half tank twice like I did.. do not over dilute the cleaner..
Then You can just use Berryman b12 chem-tool regularly after that to keep the fuel system clean.

Good luck hope it saves You too.....
plano-doug likes this.
GM? is offline  
Sponsored Links
Advertisement
 
Reply

Related Threads
Thread Thread Starter Forum Replies Last Post
2006 Chevrolet Impala LT 3.9L RSS Bot eBay Cars For Sale: Impala 0 09-18-2018 02:30 PM
New Starter CHEVROLET IMPALA 3.9L V6 2006 2007 2008 2009 2010 06 07 08 09 10 RSS Bot Impala Diecast Toys Cars on eBay 0 04-19-2018 08:10 AM
08 3.9L Rough Idle, Loss of Power uphill No Check Engine swatson7122 8th Gen Drivetrain 8 11-09-2017 07:04 PM
BCP RED 2006 2007 2008 Impala/Monte Carlo 3.5L 3.9L V6 Short Ram Air Intake RSS Bot Impala Diecast Toys Cars on eBay 0 08-24-2017 03:30 PM
BCP RED 2006 2007 2008 Impala/Monte Carlo 3.5L 3.9L V6 Short Ram Air Intake RSS Bot Impala Diecast Toys Cars on eBay 0 07-13-2017 02:10 PM


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome