My Impala.....My problematic love. - Chevy Impala Forums
Introductions & Welcome Forum New to our community? Introduce yourself to everyone here!

User Tag List

 3Likes
  • 1 Post By Camonana
  • 1 Post By Pat Currie
  • 1 Post By RYD SLO
 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 09-16-2019 Thread Starter
Junior Member
 
Camonana's Avatar
 
Join Date: Sep 2019
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
My Impala.....My problematic love.

Hi I drive a 2001 Impala Ls. I'm the 3rd owner of this custom ordered Impala. I am slowly breathing good life back into it regardless of it's mechanical and electrical issues. So glad I found this forum cause I can use all the helpful info I can get in order to fix her up.
tonyc712000 likes this.
Camonana is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 09-16-2019
Senior Member
 
sheila's Avatar
 
Join Date: Sep 2013
Posts: 1,818
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 191 Post(s)
Thanks: 315
Thanked 321 Times in 256 Posts
Welcome!
sheila is offline  
post #3 of (permalink) Old 09-17-2019
Junior Member
 
Alfredo Mujica's Avatar
 
Join Date: Sep 2019
Location: Caracas
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Thanks: 7
Thanked 0 Times in 0 Posts
Garage
Welcome! do you have pictures or could maybe list some problems with it?
Alfredo Mujica is offline  
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 09-17-2019 Thread Starter
Junior Member
 
Camonana's Avatar
 
Join Date: Sep 2019
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
It's a 2001 LS 3.8L with VIN_K. Have replaced both cv axles, all 4 wheel hubs, both sides outter and inner tie rods, ball joints, both front strut assemblies, rack & pinion bellows, both front rotors(and brakes all around) front top motor mounts and tranny mount, fuel pump and fuel level sensor. Im sure I'm missing some minor tune up and regular maintenance but too much normal repair to list. After all that in one weekend I have a clicking in my front driver side area when turning at lower speeds and when backing straight up or straight forward from a stand still. It really sounds like bad/damaged driver side cv joint/axle but it is brand new. Not sure how to figure out if its my steering knuckle bent or if my new cv axle or wheel hub was bad from the stor
Camonana is offline  
post #5 of (permalink) Old 09-17-2019 Thread Starter
Junior Member
 
Camonana's Avatar
 
Join Date: Sep 2019
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Got my driver door window switches and new headlights in today so going to install those and start to figure out other issues she's having which seems to point to bad or failing BCM. Really wondering about the BCM because of all it does on this electrical nightmare car. Not sure if i can do a diy reprogramming on a replacement BCM like I did on another vehicles few years back by turning ignition on before unplugging the bad one leaving key on and plugging in the replacement BCM then immediately starting the car back up. So the info the old BCM fed the cars system with the key on programs into the new BCM once the car is started (never turn key off till you shut the started engine off after it runs for about 10 minutes) unsure if this will work but usually if power is never severed no info in the system is lost so none needs to be reprogrammed in from an external source (dealer/Tech2). Any thoughts?
Camonana is offline  
post #6 of (permalink) Old 09-17-2019 Thread Starter
Junior Member
 
Camonana's Avatar
 
Join Date: Sep 2019
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Well tried to post pics but can't. Keeps telling me the file is to large. I will keep trying.
Camonana is offline  
post #7 of (permalink) Old 09-18-2019
Forum Foto Fanatic

 
tonyc712000's Avatar
 
Join Date: Apr 2011
Location: Connecticut
Posts: 18,375
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 98 Post(s)
Thanks: 6,753
Thanked 1,829 Times in 1,339 Posts
Quote:
Originally Posted by Camonana View Post
Well tried to post pics but can't. Keeps telling me the file is to large. I will keep trying.

if you use a free hosting site like ImGur you can use the settings to size your pics. There are other sites as well....Just post the url to the pic!

Everyone has a photographic memory; some just don't have film.
************************************************** ******************************
2012 Chevy Sonic LTZ--Given to Son
Current ride-
2012 Impala LT



****************************************


tonyc712000 is offline  
post #8 of (permalink) Old 09-18-2019
Member
 
Pat Currie's Avatar
 
Join Date: Aug 2019
Location: Phoenix, AZ
Posts: 63
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
Thanks: 8
Thanked 0 Times in 0 Posts
WOW a lot of work! But it will be your favorite ride in no time! No money wasted on an Impala. BTW welcome aboard.

I use IMGUR and when I click on a pic to enlarge just copy Image address and on your post use the mountain icon & paste link into the field. Also make sure your cursor is in the right place of your post before you paste the pic link for correct placement. After you paste the link, hit OK and the link will show up in the post & when you save the post the pics will be included.

Here's mine:

tonyc712000 likes this.
Pat Currie is offline  
post #9 of (permalink) Old 09-18-2019 Thread Starter
Junior Member
 
Camonana's Avatar
 
Join Date: Sep 2019
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Thanx you all i will look into that on my next day off.
Camonana is offline  
post #10 of (permalink) Old 09-18-2019 Thread Starter
Junior Member
 
Camonana's Avatar
 
Join Date: Sep 2019
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
I figured out the new cv axle is fine but the new wheel hub assembly and new strut coil assembly are both bad. So i will be making two part stores very unhappy unless they give me trouble on replacing them, then I will be make them extremely unhappy for a while. On another note I did find my BCM fuses needed replaced (did it) and the car ran better and my information lights on dashboard straightened up and my ac started blowing again and my traction control warning quite coming on as well as the security and battery light. But 34 hours later some of the same problems started again so time for a new BCM.
Camonana is offline  
post #11 of (permalink) Old 09-18-2019
Senior Member
 
plano-doug's Avatar
 
Join Date: Aug 2009
Location: Plano, Texas
Posts: 2,606
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 380 Post(s)
Thanks: 130
Thanked 374 Times in 349 Posts
Quote:
Originally Posted by Camonana View Post
But 34 hours later some of the same problems started again so time for a new BCM.
Before you replace the BCM, try this: With the battery disconnected, remove and re-insert each BCM connector a few times. This will help clean the pins inside the connectors. Part of your problem my be resistance in the connectors due to galvanic corrosion. This procedure will help reduce it. (This is the procedure specified in the technical service bulletin regarding the SECURITY light.)

HTH.

Doug

.
plano-doug is online now  
post #12 of (permalink) Old 09-18-2019
Go Get It

 
RYD SLO's Avatar
 
Join Date: Aug 2012
Location: MD
Posts: 15,039
Mentioned: 21 Post(s)
Tagged: 0 Thread(s)
Quoted: 102 Post(s)
Thanks: 2,054
Thanked 3,182 Times in 2,462 Posts
Welcome! Some of those issues are common and unrelated to the BCM. Namely, the ABS/TRAC OFF lights are usually due to a bad or broken wire in the speed sensor harnesses going to the front wheel hubs. Dorman sells replacements.

BTW, I have a 2000 LS parts car, still has some decent interior trim and some electronic stuff, let me know if you need anything.

Good luck with the new ride!
plano-doug likes this.

~Jeff
*2001 Impala Ls - 141k
Precision 6262 Turbo, ZZP Z3, Tial wastegate and BOV, CXRacing intercooler, ZZP 3" turbo-back w/ muffler delete, Bosch 42.5# Injectors, Bosch fuel pump, CTS-V Brembos, Stainless lines, BC Racing coilovers, Dorman solid sway bar, BMR trailing arms, SPEC-D LED headlights, LED heads and fogs, Quad tails, C5 reverse lights, All LED interior, LED 6 gauge cluster retrofit, LED puddle lights, LED underglow, Debadged, Painted emblems, Color-matched trim, Wrapped dash & door trim, Kenwood DDX271, Polk Audio dxi6500 components, Polk Audio db690, Hifonics GLX100.4, 2x Polk Audio db1240 in custom box, Hifonics ZRX1800.1D, KMC District, Nitto NT555G2, SS tail covers, SS spoiler, SS Lip, 20% tint, Black mesh grille

*1999 Escalade - 150k
Winter daily on 22s

*2001 Dakota - 99k
Custom painted runaround

*2014 Impala LT Limited - 65k
"Dad's ride"

*1992 Caprice Wagon - Sold @ 195k
RYD SLO is offline  
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome