Clunks when accelerating - Chevy Impala Forums
Introductions & Welcome Forum New to our community? Introduce yourself to everyone here!

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 2 Weeks Ago Thread Starter
Junior Member
 
ChevyBoySnow1017's Avatar
 
Join Date: Jul 2019
Location: Philly
Posts: 26
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Clunks when accelerating

Hey guys I have a 2003 Impala Ls 3800 I’ve been working on the car since I got it. It’s clunks when accelerating from a stop or turning a low speeds... it’s not all the time tho it’s like it will clunks a couple times then will run fine until I cut car off and start it again.... now I replaced both axles (I DO need axle Seals), Lower Control Arms, passenger wheel hub, inner & outer tie rods, Engine & Transmission Mounts, Dog Bones, MAF & MAP Sensor, Cleaned ThrottleBody, TPS Sensor, PCV Valve & It STILL CLUNKS CAN ANYBODY FIGURE OUT WHAT IT MIGHT BE
ChevyBoySnow1017 is online now  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 2 Weeks Ago Thread Starter
Junior Member
 
ChevyBoySnow1017's Avatar
 
Join Date: Jul 2019
Location: Philly
Posts: 26
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
I also have a weird clicking or ticking sound but ONLY WHEN WHEELS MOVE... sound like it’s coming from the front... if I drive slow it moves slow if I drive fast it goes fast I check around the wheels and nothing is outta place or anything that’s noise kills me it doesn’t effect the way the car drives it’s just a noise
ChevyBoySnow1017 is online now  
post #3 of (permalink) Old 2 Weeks Ago
Forum Foto Fanatic

 
tonyc712000's Avatar
 
Join Date: Apr 2011
Location: Connecticut
Posts: 18,279
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 89 Post(s)
Thanks: 6,748
Thanked 1,827 Times in 1,337 Posts
Welcome!

This can be a known issue with the tranny. It could just be modules....



We would like some pics too...

Everyone has a photographic memory; some just don't have film.
************************************************** ******************************
2012 Chevy Sonic LTZ--Given to Son
Current ride-
2012 Impala LT



****************************************


tonyc712000 is offline  
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 1 Week Ago Thread Starter
Junior Member
 
ChevyBoySnow1017's Avatar
 
Join Date: Jul 2019
Location: Philly
Posts: 26
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Which modules should I be looking into because I replaced the tranny as well & it still does it when taking off from stop
ChevyBoySnow1017 is online now  
post #5 of (permalink) Old 1 Week Ago
Forum Foto Fanatic

 
tonyc712000's Avatar
 
Join Date: Apr 2011
Location: Connecticut
Posts: 18,279
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 89 Post(s)
Thanks: 6,748
Thanked 1,827 Times in 1,337 Posts
Quote:
Originally Posted by ChevyBoySnow1017 View Post
Which modules should I be looking into because I replaced the tranny as well & it still does it when taking off from stop

Odd....a new trans? There are modules just inside a side panel that i have heard of. They control shifting. I had a 2000 that did that, but it would not if I took off slowly.
Not sure what it could be if you replaced the trans and it still clunks....

Anyone else?

Everyone has a photographic memory; some just don't have film.
************************************************** ******************************
2012 Chevy Sonic LTZ--Given to Son
Current ride-
2012 Impala LT



****************************************


tonyc712000 is offline  
post #6 of (permalink) Old 1 Week Ago
Forum Foto Fanatic

 
tonyc712000's Avatar
 
Join Date: Apr 2011
Location: Connecticut
Posts: 18,279
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 89 Post(s)
Thanks: 6,748
Thanked 1,827 Times in 1,337 Posts
Quote:
Originally Posted by ChevyBoySnow1017 View Post
Which modules should I be looking into because I replaced the tranny as well & it still does it when taking off from stop


Try posting here, in the 7th Gen forum. You may get a faster response...

https://www.impalaforums.com/chevy-i...en-discussion/

Everyone has a photographic memory; some just don't have film.
************************************************** ******************************
2012 Chevy Sonic LTZ--Given to Son
Current ride-
2012 Impala LT



****************************************


tonyc712000 is offline  
post #7 of (permalink) Old 1 Week Ago
Senior Member
 
sheila's Avatar
 
Join Date: Sep 2013
Posts: 1,592
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 165 Post(s)
Thanks: 311
Thanked 303 Times in 238 Posts
May check axle nut tightness.
sheila is offline  
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome