New Here But Always Been My Go To!! - Chevy Impala Forums
Introductions & Welcome Forum New to our community? Introduce yourself to everyone here!

User Tag List

 3Likes
  • 1 Post By ChevyBoySnow1017
  • 1 Post By ChevyBoySnow1017
  • 1 Post By ChevyBoySnow1017
 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 2 Days Ago Thread Starter
Junior Member
 
ChevyBoySnow1017's Avatar
 
Join Date: Jul 2019
Location: Philly
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
New Here But Always Been My Go To!!

Hey Guys Iím New To The Community But You Guys Always Been My Go to For LITERALLY EVERYTHING If It Wasnt for You Guys My Baby wouldn't Be The Beast That She Is Now, so I always felt like I was apart of the family.....okay where do I start Sheís An 03 Impala Ls Bought Her a year & 7 months ago with 190,500miles for only $600! CLEAN body the only thing that was wrong was it needed a new transmission & had a lil hole In the bumper which I wasnít concerned about...but replace the transmission, catalytic converter(which needed replacing) & the battery with a silver battery from Advance auto no real problems after.. it rev then took off and I couldnít get to the bottom of it so I replaced literally everything, ignition control module, Coils,Spark Plugs & Wires, Maf & Map, Vavle Cover Gasket, TP Sensor & Cleaned Throttle Body, Air Cleaner Sensor, 02 Sensor, Cleaned IAC Sensor, Replace Coolant House, Alternator,PCV valve,wheel speed sensor & new wheel speed harness, inner & outer tie rods, new cv joints & new wheel bearings in the front, every three months I get oil changes, I changed transmission fluid once since I got it replaced but didnít changed it since I fixed pan gasket leak, K&N High Flow Air Filter, K&N High flow Fuel Filter, replaced the front & back rotors with the powerstop drilled rotors...the top engine mounts... probably some more stuff but canít think right now but almost everything to just find out that itís my lower engine mount & Proli Transmission Mount (Ima Change it to just in case)

But I Also Did Some Modifications Too... My Car Is White So I Blacked Out the Grill (I Donít Like The Aftermarket Grills), The badges & the taillights, backup camera, 6x5 & 6x9 Jblís, Pioneer Double Din With Apple CarPlay, Deep Blue LED Swap Throughout the Whole Car including dash & AC controls, Smoked Foglights, Blacked Out Headlights With Clear Corners (Hate The Projectors), Ice White LED Lowbeams, Highbeams & foglights & have ice white switch back corner lights, brand new lexani 245/35 20 Tires With Rims ( WILL TRY TO POST PICS)

Now that you know about the car I do have a few problems I need help figuring out:

Ever since I cleaned the throttle body & replaced the gasket I been hearing this whistle noise when I accelerate..I openEd the hood Checked everywhere ... I can hear it when I do I High rev but when I spray around the areas I heard it from I donít see smoke, no suction or no change in Rpms...everybody say it sounds like a turbo but I know damn well it ainít no turbo lol I like it a lil but I still want it back to normal... any suggestions?

Also before I put 20s on I was hear this rubbing like sound coming from the front I check thereís nothing rubbing.... you only hear it when accelerating... you donít really hear it at low speeds or if your outside of the car and somebody is driving it towards you (I know weird right?) I took it to my mechanic I trust him cause heís the only I let work on my car besides me & he says it Proli my New tires and because of the 20s it rides a lil rough now but Iím like I been hearing this noise before the rims it just got a lil louder with the rims put on so any thoughts of the noise?
ChevyBoySnow1017 is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 2 Days Ago Thread Starter
Junior Member
 
ChevyBoySnow1017's Avatar
 
Join Date: Jul 2019
Location: Philly
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
ChevyBoySnow1017 is offline  
post #3 of (permalink) Old 2 Days Ago Thread Starter
Junior Member
 
ChevyBoySnow1017's Avatar
 
Join Date: Jul 2019
Location: Philly
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
ChevyBoySnow1017 is offline  
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 2 Days Ago
Senior Member
 
04Imp38's Avatar
 
Join Date: Nov 2016
Location: Michigan
Posts: 2,253
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 237 Post(s)
Thanks: 25
Thanked 105 Times in 103 Posts
Garage
Hey snowboy Welcome to the forum, or congrats on the intro post
Beautiful car, absolutely beautiful.
Could the whistling noise just be the intake sucking air normally, or have you done any mods to the intake?
As far as the rubbing noise, do a visual check and see if anything looks rubbed or weird around the front wheel wells.
Keep up the good looks!


~Joe~

04 Impala LS

Engine: ZZP PCM, ZZP Downpipe, Xcelerator Resonator, Dual Xcelerator Mufflers, 4" Stainless tips, 180į t-stat, Shorter Dogbones, Mount Spacers, Optima Red Top Battery
Trans/Drivetrain: TransGo shift kit + preloaded accumulator
Suspension: BC Racing coilovers, Police LCAs, Police Rotors and Pads, Boxed trailing arms, Dorman front solid sway bar
Exterior: LED Headlights, Red LED license plate lights and side markers
Interior:
Blue LED cluster+HVAC+door switches, LED interior
04Imp38 is online now  
post #5 of (permalink) Old 2 Days Ago Thread Starter
Junior Member
 
ChevyBoySnow1017's Avatar
 
Join Date: Jul 2019
Location: Philly
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
ChevyBoySnow1017 is offline  
post #6 of (permalink) Old 2 Days Ago
Senior Member
 
plano-doug's Avatar
 
Join Date: Aug 2009
Location: Plano, Texas
Posts: 2,359
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 334 Post(s)
Thanks: 130
Thanked 344 Times in 320 Posts
Quote:
Originally Posted by ChevyBoySnow1017 View Post
For your pics, wrap the URL's with "[IMG]" and "[/IMG]" to get them to appear in your posts without needing to click on them.

Eg,
HTML Code:
[img]https://www.impalaforums.com/members/179491-chevyboysnow1017-albums5173-my-baby-picture26547-de0f9ecc-db2a-4e47-bc3a-4139dde90814.jpeg[/img]
produces this:


HTH.

BTW, the car looks good

Doug

.

_

If your socket set is all the same brand, you might be a city slicker.

.
plano-doug is online now  
post #7 of (permalink) Old 2 Days Ago Thread Starter
Junior Member
 
ChevyBoySnow1017's Avatar
 
Join Date: Jul 2019
Location: Philly
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
ChevyBoySnow1017 is offline  
post #8 of (permalink) Old 2 Days Ago Thread Starter
Junior Member
 
ChevyBoySnow1017's Avatar
 
Join Date: Jul 2019
Location: Philly
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
No Mods Yet but next week I plan on throwing a JMB fender-well Intake In there if thatís the original whistle then I donít mind it I just know it wasnít there before I cleaned the clogged throttle body
ChevyBoySnow1017 is offline  
post #9 of (permalink) Old 3 Hours Ago
Forum Foto Fanatic

 
tonyc712000's Avatar
 
Join Date: Apr 2011
Location: Connecticut
Posts: 18,231
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 87 Post(s)
Thanks: 6,738
Thanked 1,827 Times in 1,337 Posts
Welcome!

Nice 'Pala!!

Everyone has a photographic memory; some just don't have film.
************************************************** ******************************
2012 Chevy Sonic LTZ--Given to Son
Current ride-
2012 Impala LT



****************************************


tonyc712000 is offline  
post #10 of (permalink) Old 23 Minutes Ago
Member
 
USN24's Avatar
 
Join Date: Feb 2019
Location: Tennessee
Posts: 96
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 25 Post(s)
Thanks: 56
Thanked 12 Times in 12 Posts
Garage
Welcome, sort of.......

Super clean 03 Impala!



Anything worth doing is worth doing right!

Ed
USN24 is online now  
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome