New Owner - Page 3 - Chevy Impala Forums
Introductions & Welcome Forum New to our community? Introduce yourself to everyone here!

User Tag List

 20Likes
Reply
 
LinkBack Thread Tools Display Modes
post #31 of (permalink) Old 04-04-2019
Senior Member
 
kbz1960's Avatar
 
Join Date: Nov 2018
Location: IL
Posts: 320
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 22 Post(s)
Thanks: 35
Thanked 15 Times in 15 Posts
Quote:
Originally Posted by ritalz View Post
Interesting thing happened the other day. The fan for the heat/air would not kick on. Didn't seem to matter what I did with any of the controls. About 10 minutes later the fan popped on and it's been fine since then. Need to research this before warm weather hits. Any ideas?
Maybe loose wire or fuse?
kbz1960 is offline  
Sponsored Links
Advertisement
 
post #32 of (permalink) Old 04-04-2019
Senior Member
 
kbz1960's Avatar
 
Join Date: Nov 2018
Location: IL
Posts: 320
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 22 Post(s)
Thanks: 35
Thanked 15 Times in 15 Posts
Quote:
Originally Posted by ritalz View Post
Bought a remote start kit the other day. It's a FLASHLOGIC model FLRSGM10 on Ebay for $130. It's truly a plug and play unit. Supply the seller with your vehicle info and they flash it and send it your way. Unplug two plugs from under the steering column, plug in the T harness, plug in the unit. Turn the key on and wait for the unit to be recognized and it is installed. The hardest part was getting the plastic cover off the column. Uses the stock remote by pressing the lock button three times and she starts right up. Lots of Chevy install videos on the net. Written instructions are nonexistent.
Nice
kbz1960 is offline  
post #33 of (permalink) Old 04-11-2019
Junior Member
 
14LimitedLT's Avatar
 
Join Date: Apr 2019
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Thanks: 6
Thanked 2 Times in 2 Posts
Quote:
Originally Posted by ritalz View Post
Seeing if I can add a picture or two. Apparently most of my pictures are too large.
LOVE the color of your Impala! My last Impala was also a 12 LS with the column shift.
14LimitedLT is offline  
Sponsored Links
Advertisement
 
post #34 of (permalink) Old 04-12-2019 Thread Starter
Member
 
ritalz's Avatar
 
Join Date: Jan 2019
Location: St Louis, MO
Posts: 30
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Garage
T-stat failed yesterday. Car overheated and bubbled out quite a bit of coolant. Today's project was to get it replaced and talk about a PITA. Housing is below the throttle body and above the transmission. Three bolts and four hoses equal four hours of work to complete the task. Sure glad I had access to a good set of tools.
kbz1960 likes this.
ritalz is offline  
post #35 of (permalink) Old 04-15-2019 Thread Starter
Member
 
ritalz's Avatar
 
Join Date: Jan 2019
Location: St Louis, MO
Posts: 30
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Garage
Quote:
Originally Posted by ritalz View Post
Interesting thing happened the other day. The fan for the heat/air would not kick on. Didn't seem to matter what I did with any of the controls. About 10 minutes later the fan popped on and it's been fine since then. Need to research this before warm weather hits. Any ideas?

Traced this to the blower control resister. Located under the dash forward of the blower. PITA. Blower now works as it should.
tonyc712000, sheila and kbz1960 like this.
ritalz is offline  
Sponsored Links
Advertisement
 
Reply

Related Threads
Thread Thread Starter Forum Replies Last Post
New Impala Owner - 2004 White Base PagingDrSteele Introductions & Welcome Forum 3 05-20-2019 07:53 PM
New owner, first Chevy! TheN00b Introductions & Welcome Forum 4 02-26-2019 06:01 PM
New Impala Owner Jadman Introductions & Welcome Forum 7 09-07-2017 09:15 AM
New member new 04SS owner 04SS817 Introductions & Welcome Forum 6 08-15-2017 07:20 PM
New member intro. New 04SS owner 04SS817 7th Gen Engine Performance 0 08-06-2017 02:24 PM


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome