Possible BCM probelms? - Chevy Impala Forums
Introductions & Welcome Forum New to our community? Introduce yourself to everyone here!

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 03-29-2018 Thread Starter
Junior Member
 
acramer's Avatar
 
Join Date: Mar 2018
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Possible BCM probelms?

Hi everyone, I am new to this forum but am hoping for some help.

Two days ago I got a message on the DIC saying "Service Side Detection System." Driving that day my blind spot detection was not working correctly. Same message came on throughout the day upon startup and randomly during driving. Yesterday the same message appeared, but this time the right passenger mirror indicator light was locked on and the driver mirror indicator light remained off. Last night when I got home, I tried a couple things to do a reset but made no progress. When I turn my car on now I get "Service Front Camera", "Service Park Assist System", and "Service Side Detection System" messages on the DIC.

I am concerned this may be a BCM problem, and am nervous what else might become affected since the BCM basically controls the entire car. I have done some research and no one seems to have a solution to this, but I do not want to take it to the dealer without trying some more things as I am out of my basic warranty. No recalls on it right now either. This is not currently affecting my ability to drive the car safely, but I am concerned other things will start to malfunction. I am hoping this is a simple fix (not banking on it though).

This is a 2015 Impala LTZ with 47k.

Any advice or similar experiences/problems?
acramer is offline  
Sponsored Links
Advertisement
 
Reply

Related Threads
Thread Thread Starter Forum Replies Last Post
Question on reprogramming the BCM Davec2008 Chevy Impala 8th Gen Discussion 6 02-05-2019 10:16 AM
Is my Impala BCM programmed for Fogs? Impala_9c1 Chevy Impala 8th Gen Discussion 1 09-28-2018 09:27 AM
BCM U0140 Lost communication Tonyd2018 Mechanical and Electrical Problems 2 05-09-2018 01:52 PM
Possible BCM Issue? AustinBytnar Autocare and Maintenance 0 04-28-2018 02:36 AM
pre programmed BCM ReavesMO Chevy Impala 7th Gen Discussion 0 01-31-2018 06:27 PM


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome