EVAP check engine light - Chevy Impala Forums
DIY How To's & Write Up's This forum contains some of the best How To's and Write Up's that have been posted by members.

User Tag List

 3Likes
 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 03-07-2019 Thread Starter
Junior Member
 
jlsarver@hotmail.com's Avatar
 
Join Date: Mar 2018
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
EVAP check engine light

2007 Impala LT 3.5 with 304,000 miles. I finally fixed the EVAP check engine light. It has been on for 200,000 miles. I had replaced the vent solenoid, purge canister, 2 gas caps, fuel tank pressure sensor and checked all the hoses and wires I could. I made a hole above the fuel pump in the trunk and looked at the fuel tank pressure sensor wiring. The green signal wire coming from the ECU was broken about 6 inches back from the connector. I spliced it back back together and it has been off for 3 weeks. It still shifts and drives just like it did when new. Hallelujah!
plano-doug, sheila and kbz1960 like this.
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 03-07-2019
Senior Member
 
kbz1960's Avatar
 
Join Date: Nov 2018
Location: IL
Posts: 300
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 19 Post(s)
Thanks: 31
Thanked 14 Times in 14 Posts
Quote:
Originally Posted by [email protected] View Post
2007 Impala LT 3.5 with 304,000 miles. I finally fixed the EVAP check engine light. It has been on for 200,000 miles. I had replaced the vent solenoid, purge canister, 2 gas caps, fuel tank pressure sensor and checked all the hoses and wires I could. I made a hole above the fuel pump in the trunk and looked at the fuel tank pressure sensor wiring. The green signal wire coming from the ECU was broken about 6 inches back from the connector. I spliced it back back together and it has been off for 3 weeks. It still shifts and drives just like it did when new. Hallelujah!
Wow. That's great! Hope mine can do the same.
kbz1960 is online now  
Sponsored Links
Advertisement
 
Reply

Related Threads
Thread Thread Starter Forum Replies Last Post
Car lost power, flashing check engine light jso2378 Chevy Impala 8th Gen Discussion 43 03-17-2019 08:34 PM
Check Gauge light issue. TJ3 Automotive Discussion 2 03-03-2019 12:47 PM
Check engine light won’t erase. stevedakilla Autocare and Maintenance 3 04-23-2018 12:40 PM
08 3.9L Rough Idle, Loss of Power uphill No Check Engine swatson7122 8th Gen Drivetrain 8 11-09-2017 07:04 PM
MaxiScan MS300 Code Reader Check Engine Light Reset Tool CAN OBD2 OBDII RSS Bot Impala Diecast Toys Cars on eBay 0 08-24-2017 08:20 PM


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome