2010 Impala - Shaking/Engine Light - Chevy Impala Forums
Chevy Impala Discussion Discuss all non-technical general Chevy Impala topics here.

User Tag List

 1Likes
  • 1 Post By 1999 White C5 Coupe
 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 05-12-2019 Thread Starter
Junior Member
 
th1223's Avatar
 
Join Date: May 2019
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Question 2010 Impala - Shaking/Engine Light

Hi Everyone,

I recently purchased a 2010 Impala LS. About a week ago, I noticed it began to idle roughly (RPM variation of about +/- 150). Now when I slowly accelerate between 70-90 KM/H, the vehicle shakes, not roughly, but it is definitely noticeable. The mechanic that installed brake rotors when I purchased the vehicle (It sat on the dealer`s lot for about 10 months before it was sold), suggested that I try Seafoam, which I did and worked okay. It was idling gently then, but now, not even 2 days later, it is idling roughly again. The spark plugs are in good shape and the oil was just changed. Does anyone know what this could be or have any advice?

Thank You.

*There is also a high pitch sound in the cabin after the engine is shut off, regardless of how long it runs, this stops as soon as I open the driver door and close it again.
*The 'check airbag' message came up on the DIC yesterday, but shut off a few minutes later
*There is a high pitch sound if I hold the steering wheel to the left.
th1223 is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 05-13-2019
Senior Member
 
1999 White C5 Coupe's Avatar
 
Join Date: Jul 2014
Posts: 1,276
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 187 Post(s)
Thanks: 106
Thanked 221 Times in 198 Posts
Quote:
Originally Posted by th1223 View Post
Hi Everyone,

I recently purchased a 2010 Impala LS. About a week ago, I noticed it began to idle roughly (RPM variation of about +/- 150). Now when I slowly accelerate between 70-90 KM/H, the vehicle shakes, not roughly, but it is definitely noticeable. The mechanic that installed brake rotors when I purchased the vehicle (It sat on the dealer`s lot for about 10 months before it was sold), suggested that I try Seafoam, which I did and worked okay. It was idling gently then, but now, not even 2 days later, it is idling roughly again. The spark plugs are in good shape and the oil was just changed. Does anyone know what this could be or have any advice?

Thank You.

*There is also a high pitch sound in the cabin after the engine is shut off, regardless of how long it runs, this stops as soon as I open the driver door and close it again.
*The 'check airbag' message came up on the DIC yesterday, but shut off a few minutes later
*There is a high pitch sound if I hold the steering wheel to the left.
If the check engine light is flashing, you can damage the catalytic converters quickly due to unturned fuel. Do not drive with a flashing light.

You must have the engine trouble code(s) retrieved via a scan to determine where to begin. You could have multiple issues, or something as simple as a damage spark plug wire or coil.

You will have to have the air bag system scanned with a GM Tech 2 device to retrieve any stored trouble codes. Most generic scanners cannot retrieve the GM air bag codes. GM had issues with the RF passenger presence system calibrations on the 8th generation Impala models and the system may have to be recalibrated.

Check your power steering fluid level.
12 lt likes this.
1999 White C5 Coupe is offline  
Sponsored Links
Advertisement
 
Reply

Related Threads
Thread Thread Starter Forum Replies Last Post
2000 impala tail light covers. 00Impala3.4 Appearance 2 10-18-2017 11:31 AM
Chevy impala 06-13 impala lt/ltz black fog light cover bezels lh + rh set pair RSS Bot Impala Diecast Toys Cars on eBay 0 10-14-2017 04:20 PM
2010 Impala -- Line output converter producing loud signal after key is turned off? Captain McFunk Audio, Video, and Electronics 2 10-07-2017 06:33 AM
2012 3.6L Impala RPM surging stopped at light with AC on flymorenow Chevy Impala Discussion 17 09-26-2017 10:42 AM
2010 Chevy Impala LT/Loud clicking noise Jimarie Chevy Impala 8th Gen Discussion 1 07-16-2017 02:07 PM


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome