2006 Impala, battery icon is lit up and display reads Service battery charging system - Chevy Impala Forums
Chevy Impala Discussion Discuss all non-technical general Chevy Impala topics here.

User Tag List

 3Likes
  • 3 Post By joe77
 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 05-08-2019 Thread Starter
Junior Member
 
joe77's Avatar
 
Join Date: May 2019
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
2006 Impala, battery icon is lit up and display reads Service battery charging system

Hello everyone,

I have tried looking up the error online and could not find anything. I have replaced the battery. I took it to autozone to be tested and the said the alternator, battery, and starter are good. I replaced the alternator just in case, and nothing changed. I have reset the computer by leaving the battery disconnected for an extended amount of time. Does anyone have any idea of how to go about resolving this issue?

Update: It turns out there was a wire that was not plugged in close to where the positive cable connects to the terminals. The battery icon and message did not disappear right away. It took a couple of hours. I had assumed that plug was from a modded sound system from the previous owner and previously did not notice the loose wire.

Thank you!
joe77 is offline  
The Following User Says Thank You to joe77 For This Useful Post:
kbz1960 (05-08-2019)
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 05-08-2019
Senior Member
 
kbz1960's Avatar
 
Join Date: Nov 2018
Location: IL
Posts: 248
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 16 Post(s)
Thanks: 28
Thanked 11 Times in 11 Posts
Thanks for the update.
kbz1960 is online now  
post #3 of (permalink) Old 05-08-2019
Senior Member
 
Joes74challenger's Avatar
 
Join Date: Apr 2016
Location: Fort Wayne
Posts: 1,266
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 245 Post(s)
Thanks: 30
Thanked 121 Times in 117 Posts
Garage
congrats on resolving the issue. thanks for letting us know what you found! stick around and post in the member introductions with pics of your Impala.
Joes74challenger is offline  
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome