2007 Impala SS Service battery charging system light - Chevy Impala Forums
Chevy Impala Discussion Discuss all non-technical general Chevy Impala topics here.

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 07-04-2018 Thread Starter
Junior Member
 
07impalaSS07's Avatar
 
Join Date: Jul 2018
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation 2007 Impala SS Service battery charging system light

I obtained an 07 Impala SS with a couple of issues. So far all the issues have been fixed except for one. The charging system. At this point I am completely lost and any help would be greatly appreciated. When I got the car the alternator did not charge at all, so i replaced it. It kind of fixed the problem. The battery light would go on and off. Funny thing is, when the battery light would come on, i'd give the car a little bit of gas and it would go away for a couple minutes then return. Also, sitting at a stop light the light would come on then go away on it's own after 5 seconds or so. I replaced the alternator a second time hoping that was my issue. It was not. It still charges at about 13.5 volts. Battery holds a charge just fine. Has no trouble starting at all. Today I replaced battery current sensor, hoping it was that. Again, it was not. I do not know where to go now from here.
07impalaSS07 is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 07-04-2018
Super Moderator
 
jtrosky's Avatar
 
Join Date: Jun 2013
Location: West Grove, PA
Posts: 12,431
Mentioned: 76 Post(s)
Tagged: 0 Thread(s)
Quoted: 932 Post(s)
Thanks: 992
Thanked 2,307 Times in 1,803 Posts
Garage
If you've replaced the alternator and battery, the only thing left is the wiring. I'm guessing that you already checked it, but it sure seems like there has to be a wiring issue somewhere.

Sent from my ASUS Chromebook Flip C302 using Tapatalk
jtrosky is offline  
post #3 of (permalink) Old 07-05-2018 Thread Starter
Junior Member
 
07impalaSS07's Avatar
 
Join Date: Jul 2018
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
I did quickly check wiring for anything obvious. All i found was a red wire hanging out that looks like it use to be a sub wire. I assume wire integrity is good because the battery is being charged.
07impalaSS07 is offline  
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 09-12-2018
Junior Member
 
86zboss's Avatar
 
Join Date: Sep 2018
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Make sure everything is properly grounded and no damaged, exposed or corroded wires.

Check the voltage of battery while running and if everything checks out its probably you battery current sensor.

GL
86zboss is offline  
Sponsored Links
Advertisement
 
Reply

Related Threads
Thread Thread Starter Forum Replies Last Post
Buick Lucerne Super FE4 Struts on Impala SS and other suspension mods. hatzie 8th Gen Suspension 8 06-12-2019 08:19 AM
2006 Impala, battery icon is lit up and display reads Service battery charging system joe77 Chevy Impala Discussion 2 05-08-2019 09:06 AM
1964 Impala SS Parts Lots of little Parts Charles K Private For Sale Classifieds 0 03-21-2019 03:17 PM
2007 Impala SS Trouble Changing Gears Tame Impala Mechanical and Electrical Problems 7 02-21-2019 05:40 PM
6 Year Review of a 143,000 Mile 2008 Chevrolet Impala SS SuperSportNick 2006-2013 Impala Reviews 0 01-27-2019 12:27 PM


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome