Auto Heated seats - Chevy Impala Forums
Chevy Impala 9th Gen Discussion Epsilon II 2014+. Discuss all Chevy Impala 9th Generation Performance and Technical Discussion here.

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 3 Weeks Ago Thread Starter
Junior Member
 
Potato's Avatar
 
Join Date: Nov 2019
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Auto Heated seats

Hey, just wondering how the auto heated seats work, i've been remote starting my 2018 impala LT with dual zone climate control in sub 0 weather (below 32 f). I was hoping someone would know; every time i got into my car the heated seat lights were out and they didnt seem very warm? is that normal?

Also unrelated when i have the climate system in auto is it normal the a/c light is always on i assume the a/c doesn't run non stop?

Thanks for the help
Potato is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 3 Weeks Ago
Super Moderator
 
Dwayne J's Avatar
 
Join Date: Jan 2009
Posts: 3,899
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 88 Post(s)
Thanks: 16
Thanked 362 Times in 234 Posts
AC runs in cold weather to dehumidify the air.

Dwayne
96 Caprice with AI 200cc package
Best et 11.5
Best MPH 116
Just another taxi
Dwayne J is offline  
post #3 of (permalink) Old 3 Weeks Ago Thread Starter
Junior Member
 
Potato's Avatar
 
Join Date: Nov 2019
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by Dwayne J View Post
AC runs in cold weather to dehumidify the air.
Yep, just to answer the question if anyone else has it. The light stays on constantly when in auto but the a/c will run as needed. The light for the heated seats doesn't turn on but the heated seats do work when remote started, i don't know if it runs at full power but it does heat up.
Potato is offline  
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 3 Weeks Ago
Senior Member
 
1999 White C5 Coupe's Avatar
 
Join Date: Jul 2014
Posts: 1,418
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 220 Post(s)
Thanks: 109
Thanked 237 Times in 211 Posts
Quote:
Originally Posted by Potato View Post
Hey, just wondering how the auto heated seats work, i've been remote starting my 2018 impala LT with dual zone climate control in sub 0 weather (below 32 f). I was hoping someone would know; every time i got into my car the heated seat lights were out and they didnt seem very warm? is that normal?

Also unrelated when i have the climate system in auto is it normal the a/c light is always on i assume the a/c doesn't run non stop?

Thanks for the help


Did you read your vehicle owner’s manual?

I have a 2014 Impala 2LTZ with the heated & cooled front seats. The feature to turn on the heated seats can be set via the settings in the touchscreen menu.

When the heated seats are activated via the remote start, the two console heated seat switch lights do not illuminate. When you push the start button, the heated seat feature is turned off - then must be manually turned on by pushing the switch on the console for the heated feature.
1999 White C5 Coupe is offline  
post #5 of (permalink) Old 3 Weeks Ago Thread Starter
Junior Member
 
Potato's Avatar
 
Join Date: Nov 2019
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by 1999 White C5 Coupe View Post
Did you read your vehicle owner’s manual?

I have a 2014 Impala 2LTZ with the heated & cooled front seats. The feature to turn on the heated seats can be set via the settings in the touchscreen menu.

When the heated seats are activated via the remote start, the two console heated seat switch lights do not illuminate. When you push the start button, the heated seat feature is turned off - then must be manually turned on by pushing the switch on the console for the heated feature.
No i'm an idiot and sat in my car in the freezing cold after remote starting it to see if they warmed up.
Potato is offline  
post #6 of (permalink) Old 3 Weeks Ago
Senior Member
 
1999 White C5 Coupe's Avatar
 
Join Date: Jul 2014
Posts: 1,418
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 220 Post(s)
Thanks: 109
Thanked 237 Times in 211 Posts
Quote:
Originally Posted by Potato View Post
No i'm an idiot and sat in my car in the freezing cold after remote starting it to see if they warmed up.

I’m glad you said it.

It is not unusual for people to join this forum and post a question, which is answered in the vehicle owner’s manual.

In addition to asking if you read your manual, I posted information on how the heated front seat function operates on my Impala LTZ with the remote start feature (which should be very similar to your vehicle), and how to operate the heated seats once you enter the car and unlock the ignition system.

You’re welcome.
1999 White C5 Coupe is offline  
post #7 of (permalink) Old 2 Weeks Ago
Senior Member
 
luckydriver's Avatar
 
Join Date: Mar 2014
Location: SE PA
Posts: 874
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 87 Post(s)
Thanks: 5
Thanked 24 Times in 22 Posts
the AC light on is maddening for newbies to the car and i question to this day, the operation of this heating system. just hope your actuators dont play with your mind like they do with me. sometimes ill be in the car and after a while the temp swings one way or the other. but it generally works ok so i'm just used to fidding with the knob.silly me when i set a temp i expect the same temp of air consistently out of the vent.

one thing i cannot emphasize enough is change your cabin filter. i started a few threads on here asking about AC problems and turns out that my filter was so clogged, i wasnt getting the cold air. and no one here thought to even suggest that to me. so the smallest things can make a difference. now i freeze in the summer. not a bad thing.

dont expect much from the cooled seats. i still have sweaty back sometimes in summer. i think you gotta have air coming out the lower vents for this to work correctly

2 RSA for sale. 7/32 good tread. berks county PA

188K on 2014 Blue Ray Metallic 2LTZ with 19s and nav. sadly new trans at 140K. Used to own 1995 DCM SS with only 260K!
luckydriver is offline  
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome