2007 Impala LT, fog lights stuck on - Chevy Impala Forums
Chevy Impala 9th Gen Discussion Epsilon II 2014+. Discuss all Chevy Impala 9th Generation Performance and Technical Discussion here.

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 3 Weeks Ago Thread Starter
Junior Member
 
Ahnt's Avatar
 
Join Date: Aug 2019
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
2007 Impala LT, fog lights stuck on

I came out to my car a few weeks ago and noticed the fog lights where on. I started the car, hit the button to turn them off and they where still on. Even turning the high beams on, fogs still on.



I ended up pulling the fuse. A few days later I put the fuse back in, and the lights operate normal. No issues at all. A few days after that, same issue.



I've done the pull the fuse, put the fuse back in a few times now and sometimes its good for a few days, other times only a few hours.



The fuse is good obviously, the lights are good, everything else works so I'm kinda stumped. I asked about a fog light relay (possibly stuck?) at O'reillys and they showed me a picture of it, but I cannot find anything close to that in / on or around the fuse panels in the car, or under the hood.



Anyone ever have this issue?
Ahnt is offline  
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome