Ac not blowing cold - Chevy Impala Forums
Chevy Impala 9th Gen Discussion Epsilon II 2014+. Discuss all Chevy Impala 9th Generation Performance and Technical Discussion here.

User Tag List

 12Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 04-21-2019 Thread Starter
Member
 
Pete Christ's Avatar
 
Join Date: Oct 2018
Location: NE Iowa
Posts: 53
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 15 Post(s)
Thanks: 3
Thanked 0 Times in 0 Posts
Ac not blowing cold

So a week ago it blew cold air now today it didnít, no matter what temp it was set at.

Any ideas what I need to check or reset?

Also does anyone have any suggestions for cabin air filters have a slight musty smell every now and then.


Sent from my iPad using Tapatalk
Pete Christ is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 04-21-2019
Senior Member
 
sheila's Avatar
 
Join Date: Sep 2013
Posts: 1,640
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 171 Post(s)
Thanks: 311
Thanked 308 Times in 243 Posts
Pete, I personally just use the least expensive pollen filter available at Rockauto online and change it out annually, but they're available with activated charcoal and Arm & Hammer baking soda. May check to see if the a/c compressor is engaging, blend door actuators working and hi/lo a/c pressures.
12 lt and sidemouse like this.
sheila is offline  
post #3 of (permalink) Old 04-22-2019 Thread Starter
Member
 
Pete Christ's Avatar
 
Join Date: Oct 2018
Location: NE Iowa
Posts: 53
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 15 Post(s)
Thanks: 3
Thanked 0 Times in 0 Posts
How do I check the blend doors?


Sent from my iPad using Tapatalk
Pete Christ is offline  
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 04-22-2019
Senior Member
 
sheila's Avatar
 
Join Date: Sep 2013
Posts: 1,640
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 171 Post(s)
Thanks: 311
Thanked 308 Times in 243 Posts
Any clicking/thumping in the dash? Are all hvac settings working properly? Would need a set of a/c manifold gauges to read the hi/lo pressures.
sheila is offline  
post #5 of (permalink) Old 04-22-2019 Thread Starter
Member
 
Pete Christ's Avatar
 
Join Date: Oct 2018
Location: NE Iowa
Posts: 53
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 15 Post(s)
Thanks: 3
Thanked 0 Times in 0 Posts
No sounds perfect n dash. Controls work fine. Just not really cold air coming out


Sent from my iPhone using Tapatalk
Pete Christ is offline  
post #6 of (permalink) Old 04-23-2019
Senior Member
 
sheila's Avatar
 
Join Date: Sep 2013
Posts: 1,640
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 171 Post(s)
Thanks: 311
Thanked 308 Times in 243 Posts
Is the compressor engaging when commanded?
12 lt and sidemouse like this.
sheila is offline  
post #7 of (permalink) Old 04-23-2019
Senior Member
 
12 lt's Avatar
 
Join Date: Feb 2017
Posts: 1,022
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 232 Post(s)
Thanks: 71
Thanked 85 Times in 80 Posts
Garage
Usually use the fram filters from walmart for cabin air, when they have them in stock.

Kick the ac on like sheila mentioned and be sure the compressor engages. Being you had cold air last week, would guess it is probably not low on refrigerant, but still possible it might be. Should be an ac fuse somewhere, probably under the hood, would check and be sure it is not blown.
sidemouse likes this.

My 6 year constantly asks why. What adults can learn from 5 and 6 year olds, to listen with your ears and mind open. Hard to learn when you don't listen ......
12 lt is offline  
post #8 of (permalink) Old 04-24-2019 Thread Starter
Member
 
Pete Christ's Avatar
 
Join Date: Oct 2018
Location: NE Iowa
Posts: 53
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 15 Post(s)
Thanks: 3
Thanked 0 Times in 0 Posts
OK taking three hour trip and itís 64į out temperature set at 70 on auto.. Seems like the air conditioner is running on at least medium trying to keep it cold. Air is t supper cold, havenít checked compressor


Sent from my iPhone using Tapatalk
Pete Christ is offline  
post #9 of (permalink) Old 04-25-2019 Thread Starter
Member
 
Pete Christ's Avatar
 
Join Date: Oct 2018
Location: NE Iowa
Posts: 53
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 15 Post(s)
Thanks: 3
Thanked 0 Times in 0 Posts
Itís really weird how its acting all of a sudden it was blowing super cold. Like the door switched and let all the cold in. anyone know how to recalibrate that door blender on a newer impala? Possibly that is getting stuck?


Sent from my iPad using Tapatalk
Pete Christ is offline  
post #10 of (permalink) Old 04-25-2019
Senior Member
 
sheila's Avatar
 
Join Date: Sep 2013
Posts: 1,640
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 171 Post(s)
Thanks: 311
Thanked 308 Times in 243 Posts
What year? Engine? On my '12/'13/'16 Limited you can pull the red 10amp "Display" fuse underhood to reset the mode (vent) actuator. Others say to remove the negative battery cable for a few minutes.
plano-doug and 12 lt like this.
sheila is offline  
post #11 of (permalink) Old 04-25-2019 Thread Starter
Member
 
Pete Christ's Avatar
 
Join Date: Oct 2018
Location: NE Iowa
Posts: 53
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 15 Post(s)
Thanks: 3
Thanked 0 Times in 0 Posts
2014 new body style LTZ V6


Sent from my iPhone using Tapatalk
Pete Christ is offline  
post #12 of (permalink) Old 04-25-2019 Thread Starter
Member
 
Pete Christ's Avatar
 
Join Date: Oct 2018
Location: NE Iowa
Posts: 53
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 15 Post(s)
Thanks: 3
Thanked 0 Times in 0 Posts
How would I know if the ac compressor kicks in? Today it ran for an hour not getting cold then randomly it got cold made a stop turned car off then back on and it wasnít cold again. I am at a loss on whatís going on? When it did kick in it was really cold!


Sent from my iPhone using Tapatalk
Pete Christ is offline  
post #13 of (permalink) Old 04-25-2019
Junior Member
 
Lea14ltzv6's Avatar
 
Join Date: Jun 2015
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
I have the same car not sure it seems to be something with these cars sometimes mine is really cold other times it’s not cold at all! Has anyone else ever reached inside their bumper when washing the car? I’m not sure where the air comes into the car but I know mine had handfuls of dirt and rocks and other things piled up inside of the bumper there was white flies and everything from the dirt. Also I read you can buy some kind of cleaner foam for the ac coolers because supposedly if you don’t have a certain mode turned on your car the blower mode which dealership asked to do it bacteria grows on the coils from running the air conditioner so then when you turn it on again it blows stinky smells through the car. Mine stinks like sour stinky gym socks, it’s so nasty! What blower mode does is 15 minutes or so after you turn the car off if you leave the AC on when you turn the car off it automatically turns air on and runs it through the vents I guess to dry off the coils but like I said the dealership had to turn it on for me and I’m not sure if it’s turned on in your car.
Lea14ltzv6 is offline  
post #14 of (permalink) Old 04-25-2019 Thread Starter
Member
 
Pete Christ's Avatar
 
Join Date: Oct 2018
Location: NE Iowa
Posts: 53
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 15 Post(s)
Thanks: 3
Thanked 0 Times in 0 Posts
Ac not blowing cold

I just did a little service on the car tonight to try and get things in order. Drained and put in new transmission fluid and tried the blender reset. Had the negative off for about 5-10 minutes then put back on. Just pressed the start button let sit for a minute, then turned on for 5 minute idle. When it was idling it blew antifreeze out, i paniced and shut off. Turned car back on let idle for a few and it blew again. 3rd time it worked just fine no issues. So I did press the A/C button and could hear the compressor start then i had cold air.

Other thing I did was change out the cabin filter it had some twigs and seemed dirty hopefully it will help with some of my musty smell.

We will see what tomorrow brings!!!!


Sent from my iPad using Tapatalk
Pete Christ is offline  
post #15 of (permalink) Old 04-25-2019
Junior Member
 
Lea14ltzv6's Avatar
 
Join Date: Jun 2015
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Good luck with yours, mine did it last summer with the sometimes cold and other times not, I just hope it doesn’t do it again it’s so random but that’s been the way the car has been ever since I bought it, plus I get horrible gas mileage only 14 mpg in town 😞
Lea14ltzv6 is offline  
Sponsored Links
Advertisement
 
Reply

Related Threads
Thread Thread Starter Forum Replies Last Post
2015 impala LS blowing cold air help please! dlowe1415 Chevy Impala 9th Gen Discussion 4 01-05-2019 06:12 AM
So AC Problems - when it is needed most RShea Chevy Impala 8th Gen Discussion 0 09-14-2018 11:23 AM
AC blowing warm air dcooper323 Chevy Impala 8th Gen Discussion 21 12-08-2017 03:55 PM
A/C sometimes does not blow cold LGarcia Chevy Impala 7th Gen Discussion 3 10-02-2017 08:48 AM
AC not too cold rob1437ert Chevy Impala 8th Gen Discussion 5 07-24-2017 04:35 PM


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome