Chevy Impala Forums

Chevy Impala Forums (https://www.impalaforums.com/forum.php)
-   Chevy Impala 9th Gen Discussion (https://www.impalaforums.com/chevy-impala-9th-gen-discussion/)
-   -   Ac not blowing cold (https://www.impalaforums.com/chevy-impala-9th-gen-discussion/1864501-ac-not-blowing-cold.html)

Pete Christ 04-21-2019 04:20 PM

Ac not blowing cold
 
So a week ago it blew cold air now today it didnít, no matter what temp it was set at.

Any ideas what I need to check or reset?

Also does anyone have any suggestions for cabin air filters have a slight musty smell every now and then.


Sent from my iPad using Tapatalk

sheila 04-21-2019 07:52 PM

Pete, I personally just use the least expensive pollen filter available at Rockauto online and change it out annually, but they're available with activated charcoal and Arm & Hammer baking soda. May check to see if the a/c compressor is engaging, blend door actuators working and hi/lo a/c pressures.

Pete Christ 04-22-2019 06:34 PM

How do I check the blend doors?


Sent from my iPad using Tapatalk

sheila 04-22-2019 07:08 PM

Any clicking/thumping in the dash? Are all hvac settings working properly? Would need a set of a/c manifold gauges to read the hi/lo pressures.

Pete Christ 04-22-2019 07:13 PM

No sounds perfect n dash. Controls work fine. Just not really cold air coming out


Sent from my iPhone using Tapatalk

sheila 04-23-2019 02:25 PM

Is the compressor engaging when commanded?

12 lt 04-23-2019 02:57 PM

Usually use the fram filters from walmart for cabin air, when they have them in stock.

Kick the ac on like sheila mentioned and be sure the compressor engages. Being you had cold air last week, would guess it is probably not low on refrigerant, but still possible it might be. Should be an ac fuse somewhere, probably under the hood, would check and be sure it is not blown.

Pete Christ 04-24-2019 02:35 PM

OK taking three hour trip and itís 64į out temperature set at 70 on auto.. Seems like the air conditioner is running on at least medium trying to keep it cold. Air is t supper cold, havenít checked compressor


Sent from my iPhone using Tapatalk

Pete Christ 04-25-2019 07:13 AM

Itís really weird how its acting all of a sudden it was blowing super cold. Like the door switched and let all the cold in. anyone know how to recalibrate that door blender on a newer impala? Possibly that is getting stuck?


Sent from my iPad using Tapatalk

sheila 04-25-2019 08:15 AM

What year? Engine? On my '12/'13/'16 Limited you can pull the red 10amp "Display" fuse underhood to reset the mode (vent) actuator. Others say to remove the negative battery cable for a few minutes.

Pete Christ 04-25-2019 08:20 AM

2014 new body style LTZ V6


Sent from my iPhone using Tapatalk

Pete Christ 04-25-2019 07:48 PM

How would I know if the ac compressor kicks in? Today it ran for an hour not getting cold then randomly it got cold made a stop turned car off then back on and it wasnít cold again. I am at a loss on whatís going on? When it did kick in it was really cold!


Sent from my iPhone using Tapatalk

Lea14ltzv6 04-25-2019 08:02 PM

I have the same car not sure it seems to be something with these cars sometimes mine is really cold other times it’s not cold at all! Has anyone else ever reached inside their bumper when washing the car? I’m not sure where the air comes into the car but I know mine had handfuls of dirt and rocks and other things piled up inside of the bumper there was white flies and everything from the dirt. Also I read you can buy some kind of cleaner foam for the ac coolers because supposedly if you don’t have a certain mode turned on your car the blower mode which dealership asked to do it bacteria grows on the coils from running the air conditioner so then when you turn it on again it blows stinky smells through the car. Mine stinks like sour stinky gym socks, it’s so nasty! What blower mode does is 15 minutes or so after you turn the car off if you leave the AC on when you turn the car off it automatically turns air on and runs it through the vents I guess to dry off the coils but like I said the dealership had to turn it on for me and I’m not sure if it’s turned on in your car.

Pete Christ 04-25-2019 08:10 PM

Ac not blowing cold
 
I just did a little service on the car tonight to try and get things in order. Drained and put in new transmission fluid and tried the blender reset. Had the negative off for about 5-10 minutes then put back on. Just pressed the start button let sit for a minute, then turned on for 5 minute idle. When it was idling it blew antifreeze out, i paniced and shut off. Turned car back on let idle for a few and it blew again. 3rd time it worked just fine no issues. So I did press the A/C button and could hear the compressor start then i had cold air.

Other thing I did was change out the cabin filter it had some twigs and seemed dirty hopefully it will help with some of my musty smell.

We will see what tomorrow brings!!!!


Sent from my iPad using Tapatalk

Lea14ltzv6 04-25-2019 08:18 PM

Good luck with yours, mine did it last summer with the sometimes cold and other times not, I just hope it doesn’t do it again it’s so random but that’s been the way the car has been ever since I bought it, plus I get horrible gas mileage only 14 mpg in town 😞


All times are GMT -7. The time now is 08:19 PM.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
This site is not affiliated nor endorsed by General Motors Corp. Chevy Impala and related trademarks are the property of General Motors Corp.

 
For the best viewing experience please update your browser to Google Chrome