Lost A/C - bad ECM?! - Chevy Impala Forums
Chevy Impala 8th Gen Discussion W-Body 2006-2013 (2014+ Limited). Discuss all Chevy Impala 8th Generation Performance and Technical Discussion here.

User Tag List

 10Likes
  • 2 Post By Sammy
  • 2 Post By John Craker
  • 2 Post By 12 lt
  • 2 Post By sheila
  • 2 Post By hatzie
 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 08-04-2019 Thread Starter
Junior Member
 
John Craker's Avatar
 
Join Date: Feb 2019
Location: Southern Alberta
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Thanks: 0
Thanked 2 Times in 2 Posts
Garage
Unhappy Lost A/C - bad ECM?!

'06 5.3L (E40 ECM of course).

Just wondering if this has happened to anyone else.

Scan tool reads 0psi on the high pressure sensor. Manifold gauge hanging there reads about 45psi. Changed the sensor with a spare, no change. Has +5 and ground at the connector. Confirmed continuity from the sensor connector, right back to pin 26 on the ECM. Saw lots of mouse nests and piss near/under/around the ECM, so pulled it and took it apart (FYI - don't do this!) to make sure nothing got inside. Still has a good connection right to the PCB.

I'm down to.... replace the ECM!! :O

I've ordered another - see how it works I guess.
John Craker is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 08-04-2019
Junior Member
 
Sammy's Avatar
 
Join Date: Oct 2013
Location: Virginia Beach Virginia
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Garage
My 06 3.9 had intermittent AC not working aways back.

Turns out it was the ambient air sensor at the hood latch. My wife just happened to notice the outside air temp display on the dash was 22 degrees when it was actually 90 some degrees out. Replaced the sensor for five bucks and all is well.
plano-doug and Tesla like this.
Sammy is offline  
post #3 of (permalink) Old 08-04-2019
Senior Member
 
hatzie's Avatar
 
Join Date: Nov 2009
Location: Baker River Valley, NH
Posts: 958
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 157 Post(s)
Thanks: 83
Thanked 150 Times in 132 Posts
Are you sure sure sure the wires and terminals from and to the ECM are not damaged by the mouse urine?

2009 Impala SS
"Speed never killed anyone. Suddenly becoming stationary... that's what gets you." Jeremy Clarkson
hatzie is offline  
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 08-05-2019 Thread Starter
Junior Member
 
John Craker's Avatar
 
Join Date: Feb 2019
Location: Southern Alberta
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Thanks: 0
Thanked 2 Times in 2 Posts
Garage
Quote:
Originally Posted by hatzie View Post
Are you sure sure sure the wires and terminals from and to the ECM are not damaged by the mouse urine?
Unfortunately, yes. Checked from the connector, right to the backside of the ECM on it's PCB.
John Craker is offline  
post #5 of (permalink) Old 08-05-2019
Senior Member
 
hatzie's Avatar
 
Join Date: Nov 2009
Location: Baker River Valley, NH
Posts: 958
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 157 Post(s)
Thanks: 83
Thanked 150 Times in 132 Posts
Quote:
Originally Posted by John Craker View Post
Unfortunately, yes. Checked from the connector, right to the backside of the ECM on it's PCB.
The compressor connector to the terminals on the ECM... I hope

2009 Impala SS
"Speed never killed anyone. Suddenly becoming stationary... that's what gets you." Jeremy Clarkson
hatzie is offline  
post #6 of (permalink) Old 09-09-2019 Thread Starter
Junior Member
 
John Craker's Avatar
 
Join Date: Feb 2019
Location: Southern Alberta
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Thanks: 0
Thanked 2 Times in 2 Posts
Garage
Forgot to follow up on this....

New ECM, finally got my PC to talk to one of my interfaces that would talk to the car through TIS2000 (that was a 2 week battle unto itself). Reflashed new/used ECM.

Still didn't work. Rechecked sensor, rechecked all wiring.
Pulled schrader valve to make sure it wasn't clogged. Recharged AC.
Hooked Tech2 up (had been using a few of my other diag tools before). Seems that IT KNOWS of a DTC that the other ones didn't!
Cleared code - AC works.
And of course, all the days I was without it, it was in the high 20's (C). Now it works, we're supposed to have a high of.... 12.
plano-doug and sheila like this.
John Craker is offline  
post #7 of (permalink) Old 09-09-2019
Senior Member
 
sheila's Avatar
 
Join Date: Sep 2013
Posts: 1,791
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 190 Post(s)
Thanks: 315
Thanked 321 Times in 256 Posts
What was the code?
sheila is offline  
post #8 of (permalink) Old 09-09-2019
Senior Member
 
12 lt's Avatar
 
Join Date: Feb 2017
Posts: 1,056
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 240 Post(s)
Thanks: 73
Thanked 85 Times in 80 Posts
Garage
Not with the impala, but have had issues with the pcm(powertrain control module) on our 08 durango that has caused all kinds of issues, including the ac not working and the dash/gauges acting crazy. Computer glitches can cause all kinds of intermittent problems and throw codes that have you tracking down a problem that is not the true issue. We had been having an mds(active fuel management) issue with our durango as well that I am almost certain is related to faulty pcm. Moisture seems to bring on strange erratic behavior from the pcm with our situation.

As to the mice damage, have had plenty of issues with damage from those rotten things. Recently had a 2 wire connector to a relay for our honda 4 wheeler that was chewed and shorted. Spent too much time tracing down that problem. I hate mice.
hatzie and sheila like this.

My 6 year constantly asks why. What adults can learn from 5 and 6 year olds, to listen with your ears and mind open. Hard to learn when you don't listen ......
12 lt is offline  
post #9 of (permalink) Old 09-09-2019
Senior Member
 
sheila's Avatar
 
Join Date: Sep 2013
Posts: 1,791
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 190 Post(s)
Thanks: 315
Thanked 321 Times in 256 Posts
^+1. I hate meeses to pieces. Kill 'em all, lol!
hatzie and kbz1960 like this.
sheila is offline  
post #10 of (permalink) Old 09-10-2019
Senior Member
 
hatzie's Avatar
 
Join Date: Nov 2009
Location: Baker River Valley, NH
Posts: 958
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 157 Post(s)
Thanks: 83
Thanked 150 Times in 132 Posts
I add peppermint oil to the soap injector for rinsing things in the engine bay down. The rodents seem to find other places to be.

El Gato helps as well...
plano-doug and sheila like this.

2009 Impala SS
"Speed never killed anyone. Suddenly becoming stationary... that's what gets you." Jeremy Clarkson
hatzie is offline  
post #11 of (permalink) Old 09-30-2019
Junior Member
 
RobertDarwin's Avatar
 
Join Date: Sep 2019
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
hire an ac repair expert to repair issue.
RobertDarwin is offline  
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome