2008 3.5 smoke test of evap system - Chevy Impala Forums
Chevy Impala 8th Gen Discussion W-Body 2006-2013 (2014+ Limited). Discuss all Chevy Impala 8th Generation Performance and Technical Discussion here.

User Tag List

 3Likes
  • 1 Post By hatzie
  • 2 Post By hatzie
 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 05-30-2019 Thread Starter
Member
 
Davec2008's Avatar
 
Join Date: Nov 2018
Location: Southwick MA
Posts: 39
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Thanks: 4
Thanked 1 Time in 1 Post
Garage
2008 3.5 smoke test of evap system

Hi everyone,
I'm having a problem with a code 0442, small evap leak. I already replaced the gas cap, and tested the evap purge valve solenoid on top of the engine and the vent valve solenoid by the gas filler with my power probe, both of the solenoids seem to work properly. So I was looking to do a smoke test, but cannot find the Schrader valve on the evap line to hook my smoke machine hose to. My 2004 had a valve right on the line near the throttle body, but I can't locate it on this car. Does anyone know if they eliminated the Schrader valve on this year? Can I just disconnect the hose from the purge valve and blow smoke in that?


thanks
Dave

Just picked up a 2008 Impala LT after my 2004 Monte Carlo SS died.
Davec2008 is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 06-01-2019
Senior Member
 
hatzie's Avatar
 
Join Date: Nov 2009
Location: Baker River Valley, NH
Posts: 921
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 149 Post(s)
Thanks: 80
Thanked 146 Times in 128 Posts
GM likely eliminated the Schrader valve.

Have you checked the tank pressure sensor function with a scan tool?
Davec2008 likes this.

2009 Impala SS
"Speed never killed anyone. Suddenly becoming stationary... that's what gets you." Jeremy Clarkson
hatzie is offline  
post #3 of (permalink) Old 06-01-2019 Thread Starter
Member
 
Davec2008's Avatar
 
Join Date: Nov 2018
Location: Southwick MA
Posts: 39
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Thanks: 4
Thanked 1 Time in 1 Post
Garage
Haven't even heard of the tank pressure sensor when researching the small leak. I have a simple code reader, not sure if I can check the tank pressure sensor with it....
Of course they eliminated it in 2008, along with the anti-lock brakes. wish I had researched the 2008 and remembered it was the bankruptcy year and they really cheapened things that year...
Dave

Just picked up a 2008 Impala LT after my 2004 Monte Carlo SS died.
Davec2008 is offline  
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 06-07-2019
Member
 
sidemouse's Avatar
 
Join Date: Feb 2019
Posts: 76
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 14 Post(s)
Thanks: 8
Thanked 6 Times in 6 Posts
Quote:
Originally Posted by Davec2008 View Post
Hi everyone,
I'm having a problem with a code 0442, small evap leak. I already replaced the gas cap, and tested the evap purge valve solenoid on top of the engine and the vent valve solenoid by the gas filler with my power probe, both of the solenoids seem to work properly. So I was looking to do a smoke test, but cannot find the Schrader valve on the evap line to hook my smoke machine hose to. My 2004 had a valve right on the line near the throttle body, but I can't locate it on this car. Does anyone know if they eliminated the Schrader valve on this year? Can I just disconnect the hose from the purge valve and blow smoke in that?


thanks
Dave
EVAP Canister Purge Valve– The most common culprit with the P0442 trouble code and the Chevy Impala is going to be the vapor canister purge valve. When it goes bad, it typically causes issues with the vehicle’s idle speed. This is especially true right after you fuel up

Are we speaking of the same thing here?
If so, clear the codes again and disconnect the battery for 1/2 hour or even overnight.

Fuel Vapor Hose– A leak in the fuel vapor hose that leads from the fuel tank to the intake will definitely throw P0442 in your Impala.

Fuel Tank Pressure Sensor– If the fuel tank pressure sensor has gone bad it can cause all sorts of problems, including the P0442 code.

2010 the evap canister within drivers rear quarter panel fixed one evap error code

https://www.impalaforums.com/chevy-i...162-p0442.html
sidemouse is offline  
post #5 of (permalink) Old 06-08-2019
Senior Member
 
hatzie's Avatar
 
Join Date: Nov 2009
Location: Baker River Valley, NH
Posts: 921
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 149 Post(s)
Thanks: 80
Thanked 146 Times in 128 Posts
You can throw parts at it hoping something will work or you can diagnose it.

You don't necessarily need a smoke machine but you do need a bi-directional scan tool.

Most of the threads I've seen on EVAP codes leap to the conclusion that the filler cap is bad and if that's not bad then "replace the purge valve" then "It's the vent valve" ...

I don't just throw parts at problems praying I guessed right. I troubleshoot.
Hail Mary Shotgun repairs are way too expensive.

I did this on my 2005 Silverado but the technique is the same...

I plugged in my Knock Off Tech 2 and ran some EVAP tests.
-Both Purge and Vent solenoids made substantial clicks when I commanded them on and off. This put them on the back burner. Not definitely good but not obviously bad either.
-When I closed the vent and opened the purge valve 20% with the engine running I heard a sucking noise from the filler door and the tank pressure sensor noted ZERO change... Dead Steady at 6.6in Hg. <---That dead steady pressure reading, way above .2" Hg, should've been a clue that it wasn't just the dead gas cap seal...
Okey Dokey. Off to O'Riley for a Stant filler cap to replace the knackered cap on the fill pipe.
New filler cap installed. Cleared the DTC codes with Torque. No sucking noise when running an EVAP test so I fixed it... Right?
NOPE... The MIL re-illuminated on the way home. WTF is going on here?

OK... Peeling the Onion...

-Tech 2 still shows 6.6in Hg no matter what the state of the EVAP valves. No sucking noise from the filler neck anymore so the cap really was worn out. I can now make the engine stumble from vacuum being pulled on the tank with the purge open and vent closed... The pressure sensor is still reading rock steady at 6.6in Hg. <--- Doooh!!

-Change the EVAP fuel tank pressure sensor with a brand new GM sensor from the dealer in Wells River... I don't trust China made cheapo parts to last in-service and this sensor is in a really seriously unpleasant location so I paid for an OEM part.

Yes the pressure sensor fixed it.
It's not necessarily your problem... You need to troubleshoot and find out what broke...

BTW you can run the EVAP test on 10% duty cycle and listen with a stethoscope for vacuum leaks without a smoke machine.
You can check the purge valve for leaks by unplugging the hose and electrical connection. It shouldn't have any vacuum at the hose connection with the engine running and the valve unplugged.
plano-doug and sheila like this.

2009 Impala SS
"Speed never killed anyone. Suddenly becoming stationary... that's what gets you." Jeremy Clarkson

Last edited by hatzie; 06-08-2019 at 02:37 PM.
hatzie is offline  
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome