2014 Impala limited Instrument cluster issues - Chevy Impala Forums
Chevy Impala 8th Gen Discussion W-Body 2006-2013 (2014+ Limited). Discuss all Chevy Impala 8th Generation Performance and Technical Discussion here.

User Tag List

Reply
 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 08-16-2017 Thread Starter
Junior Member
 
MattDHardy's Avatar
 
Join Date: Aug 2017
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Garage
2014 Impala limited Instrument cluster issues

So since about March we have been going back and forth with the dealership trying to get them to find out what the cause for our issue is.

What is happening is we'll be driving down the road and all gauges will drop. Usually we get other errors like the air bags, traction control, tire system, and reduced power. When we have these episodes the car does not have blinkers or the emergence flashers. When this happens the tire light will stay on till the car is restarted. I have also noticed that the automatic lights are not working like they should and the dash lights are dimmer than usual. Also sometimes blinkers just don't work. The airbag light will flash randomly, odometer display will randomly say "Bluetooth" and nothing else. Sometimes the Onstar Remote fail along with the power locks on the car remoter or on the door....

In the video and picture below, you can see an example of an episode. You'll also notice that the dash light go to the actual brightness set when it has the episode.

Anyone have this problem before or know what could be the cause? They have already replaced the instrument cluster and battery cables. Now telling us the can't fix it unless it happens while on a machine and they say it doesn't happen for them.

Video: https://goo.gl/photos/8ePgAXoR2Dv7U9uE8
Picture: https://goo.gl/photos/UintApbVTgEg7E4f8
MattDHardy is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 08-16-2017
Super Moderator
 
jtrosky's Avatar
 
Join Date: Jun 2013
Location: West Grove, PA
Posts: 12,403
Mentioned: 74 Post(s)
Tagged: 0 Thread(s)
Quoted: 930 Post(s)
Thanks: 992
Thanked 2,305 Times in 1,801 Posts
Garage
Moved to proper forum.

Sent from my Hi10 pro using Tapatalk
jtrosky is offline  
post #3 of (permalink) Old 08-19-2017
Senior Member
 
Bart77's Avatar
 
Join Date: Sep 2012
Location: New Garus, Wisconsin
Posts: 611
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 37 Post(s)
Thanks: 22
Thanked 199 Times in 147 Posts
I've seen something like that before on a Buick Enclave. Took a while to find, even with communication codes in several modules, but a GM high speed lan wire to the transmission was shorting against the catalytic converter intermittently. Your vehicle may have a similar issue. Hopefully there are some trouble codes in the controllers and a tsb to help find the issue.

Sent from my KFGIWI using Tapatalk
Bart77 is offline  
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 08-19-2017
Senior Member
 
Carbide's Avatar
 
Join Date: Dec 2014
Posts: 575
Mentioned: 15 Post(s)
Tagged: 0 Thread(s)
Quoted: 161 Post(s)
Thanks: 30
Thanked 72 Times in 69 Posts
Garage
So, you're turning the wheel and the problem then stops, is this how it comes and goes sometimes, while turning the steering wheel?

It doesn't seem to be a coincidence of you turning the wheel while showing the problem and the problem stops.
Carbide is offline  
post #5 of (permalink) Old 01-11-2018
Junior Member
 
Cousindan73's Avatar
 
Join Date: Jan 2018
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Did you ever find out the problem with the dash?
Cousindan73 is offline  
post #6 of (permalink) Old 01-11-2018
Junior Member
 
Cousindan73's Avatar
 
Join Date: Jan 2018
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
My wifeís car is doing the exact same thing.
Cousindan73 is offline  
post #7 of (permalink) Old 01-19-2018
Junior Member
 
hriley03's Avatar
 
Join Date: Jan 2018
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Did you ever find out the problem? My car just did this last night for the first time.
hriley03 is offline  
post #8 of (permalink) Old 02-21-2018
Junior Member
 
redneckcadilac88's Avatar
 
Join Date: Dec 2017
Location: Ontario Canada
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 3
Thanked 0 Times in 0 Posts
My 2014 Impala just started doing this as well. Any luck finding the cause?
redneckcadilac88 is offline  
post #9 of (permalink) Old 07-04-2018 Thread Starter
Junior Member
 
MattDHardy's Avatar
 
Join Date: Aug 2017
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Garage
The dealership chased the issue for as long as they said they could. GM decided this electrical issues could not be fixed and told us not to bring the car back for the electrical issues. So we’re stuck with a car still under the extended warranty with electrical issues... Yeah this will be the last GM product we own.
MattDHardy is offline  
post #10 of (permalink) Old 07-04-2018
Super Moderator
 
jtrosky's Avatar
 
Join Date: Jun 2013
Location: West Grove, PA
Posts: 12,403
Mentioned: 74 Post(s)
Tagged: 0 Thread(s)
Quoted: 930 Post(s)
Thanks: 992
Thanked 2,305 Times in 1,801 Posts
Garage
So wait - GM just refused to fix an issue that is covered under the extended warranty?? If that is the case, it's lawsuit time... That is unacceptable.

Sent from my ASUS Chromebook Flip C302 using Tapatalk
jtrosky is offline  
post #11 of (permalink) Old 07-04-2018 Thread Starter
Junior Member
 
MattDHardy's Avatar
 
Join Date: Aug 2017
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Garage
Yep. GM said they had done everything they can and if they ever discover a fix they’re supposed to contact us. Otherwise come get your car and return the loaner.
MattDHardy is offline  
post #12 of (permalink) Old 07-04-2018
Super Moderator
 
jtrosky's Avatar
 
Join Date: Jun 2013
Location: West Grove, PA
Posts: 12,403
Mentioned: 74 Post(s)
Tagged: 0 Thread(s)
Quoted: 930 Post(s)
Thanks: 992
Thanked 2,305 Times in 1,801 Posts
Garage
Was the car wrecked or rebuilt title or anything like that? And was it GM that refused to fix it or the dealership that refused to fix it?

Personally, I'd take it to another dealership - that is just not right....

Also - was it a GM extended warranty or a 3rd party extended warranty?

Sent from my ASUS Chromebook Flip C302 using Tapatalk
jtrosky is offline  
post #13 of (permalink) Old 07-04-2018 Thread Starter
Junior Member
 
MattDHardy's Avatar
 
Join Date: Aug 2017
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Garage
Car has no accident history and it was GM’s decision to not fix it under the GM extended warranty. GM also told us not to bring it to another dealership for the issue because the work will not be approved.
MattDHardy is offline  
post #14 of (permalink) Old 07-04-2018
Super Moderator
 
jtrosky's Avatar
 
Join Date: Jun 2013
Location: West Grove, PA
Posts: 12,403
Mentioned: 74 Post(s)
Tagged: 0 Thread(s)
Quoted: 930 Post(s)
Thanks: 992
Thanked 2,305 Times in 1,801 Posts
Garage
Wow - that makes no sense whatsoever. At the very least, I would file a complaint with GM, but I think I would take them to court over this one too - although, that may not make sense financially (not sure what it would cost to do that).

I feel for you though - I know that I'd be pissed for sure...

Sent from my ASUS Chromebook Flip C302 using Tapatalk
jtrosky is offline  
post #15 of (permalink) Old 07-04-2018 Thread Starter
Junior Member
 
MattDHardy's Avatar
 
Join Date: Aug 2017
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Garage
We’ve filed a complaint with GM and they didn’t care. It doesn’t make finical sense for us to sue them either. But hey, we now see how GM values their loyal customers... Thats the last GM product you will see in our driveway.
MattDHardy is offline  
Sponsored Links
Advertisement
 
Reply

Related Threads
Thread Thread Starter Forum Replies Last Post
Engine Air Filter 2012 2013 CHEVY IMPALA LS LT LTZ 2014 2015 2016 IMPALA LIMITED RSS Bot Impala Diecast Toys Cars on eBay 0 01-23-2018 02:50 PM
2014 Impala LTZ GPS / Navigation Issues lurpygeek Chevy Impala 9th Gen Discussion 2 12-04-2017 02:37 PM
Engine Air Filter 2012 2013 CHEVY IMPALA LS LT LTZ 2014 2015 2016 IMPALA LIMITED RSS Bot Impala Diecast Toys Cars on eBay 0 11-29-2017 06:10 AM
2014 Impala Limited MAF mating electrical plug its420erik Mechanical and Electrical Problems 3 11-07-2017 07:58 AM
x1 FRAM CA11227 Air Filter 2012 2013 CHEVY IMPALA 2014 2015 2016 IMPALA LIMITED RSS Bot Impala Diecast Toys Cars on eBay 0 09-28-2017 11:51 PM


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome