2006 impala ss odometer error and steering wheel play - Chevy Impala Forums
Chevy Impala 8th Gen Discussion W-Body 2006-2013 (2014+ Limited). Discuss all Chevy Impala 8th Generation Performance and Technical Discussion here.

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 07-22-2017 Thread Starter
Junior Member
 
scinto92's Avatar
 
Join Date: Jul 2017
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
2006 impala ss odometer error and steering wheel play

I recently purchased a 06 impala ss and while replacing a bad alternator I disconnected the battery. When the job was done and battery reconnected the odometer reads error. Anybody had the same problem and know the fix?

Also there is a good amount of steering wheel play, maybe like 3 inches or so. When I had tires put on the car I had an alignment done and asked them to check front end parts and they said it was good. somebody is telling me its the rack and pinion, but its expensive and want to make sure that's the problem before spending the money.
scinto92 is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 07-24-2017
Senior Member
 
WickedGoat's Avatar
 
Join Date: Oct 2016
Location: Lebanon, MO
Posts: 594
Mentioned: 8 Post(s)
Tagged: 0 Thread(s)
Quoted: 139 Post(s)
Thanks: 31
Thanked 87 Times in 79 Posts
Garage
Not sure what you can do about the odometer/cluster issue. As far as the front end and steering wheel play, you can check the front end out yourself and see what is going on. The shop that did the alignment should have checked the front end out and not did the alignment of any parts were worn. Too much wheel free play could be a worn steering rack, but you need to check out the tie rods, strut mounts and steering shafts to make sure all is good before condemning the rack. Any noise coming from it or weird steering feel?

2014 Chevy Impala LTZ Limited
- My daily driver... 5% Window Tint, Rosen GM1210 Stereo, Polk Audio Components and 6x9s, Pioneer, Kenwood amps and sub, Addco Rear Sway Bar, ZZP Strut Tower Braces, LED fogs and low beams, back up and interior lighting, SS dash, stereo and shifter trim.
2004 Pontiac GTO
- Garage queen from day 1... bought brand new 12/31/04... Quick Silver Metallic/Black/6 speed... too much to list
2004 GMC Yukon SLT
- Wife's DD... bone freakin stock
WickedGoat is offline  
post #3 of (permalink) Old 08-02-2017
Senior Member
 
Bart77's Avatar
 
Join Date: Sep 2012
Location: New Garus, Wisconsin
Posts: 611
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 37 Post(s)
Thanks: 22
Thanked 199 Times in 147 Posts
The odometer will display 'error' if an internal IPC memory failure is detected.*The only fix that I'm aware of is to replace the IPC. A temporary fix may be to disconnect the battery for several minutes and reconnect and hope that the test that is run when the battery is reconnected passes.

Sent from my KFGIWI using Tapatalk
Bart77 is offline  
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome