air con problem - Chevy Impala Forums
Chevy Impala 7th Gen Discussion W-Body 2000-2005. Discuss all Chevy Impala 7th Generation Performance and Technical Discussion here.

User Tag List

 1Likes
  • 1 Post By kingnutin
 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 06-12-2013 Thread Starter
Member
 
countryrunner's Avatar
 
Join Date: Feb 2012
Posts: 51
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
air con problem

hey guys i am having some problems with the air conditioning with my 03 impala LS. the passenger side will blow cold but the driver side won't. and it does have the dual climate control system. so i am thinking maybe one of the flaps is not working right to let the air through to the driver side? what do you guys think
countryrunner is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 06-13-2013
Mr. Handy
 
g25racer's Avatar
 
Join Date: Apr 2012
Location: Michigan
Posts: 6,289
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Thanks: 534
Thanked 851 Times in 680 Posts
Could be a vacuum leak. The flapper doors/a/c vents work on vacuum and not actuators like newer cars. Could be a low vacuum. Vacuum line runs around the passenger side (front) shock tower. Inspect the whole line. That or start tearing apart the dash.

Wouldn't be a bad idea to inspect or replace the cabin air filter as well. It's located under the passenger side windshield wiper. Very easy to access and replace.




2001 Impala LS
TransGO Shift kit
Spectre Cone Filter
Thunderbolt Spun Cat
ZZP Alternator Power Cable
Wagner Thermoquiet Pads
KYB Strut Plus (Rr)
L67 Pass Eng Mount
Tinted tail lights
Painted Trim
Dipped Rims and emblems
Led plate, full interior, trunk, and console
Black interior accents (handles and switch panels)
JBL GTO 6.5" and 6x9"
Sony MEX-GS600BT
Hifonics Hifi 1500 (KnuKoncepts 4ga)
Rockford P3 @ 500rms
"Apply Dielectric Grease or I kick some arse"
g25racer is offline  
post #3 of (permalink) Old 06-19-2013 Thread Starter
Member
 
countryrunner's Avatar
 
Join Date: Feb 2012
Posts: 51
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
thanks for the info i will check that out. but today i was playing around with the air con and i noticed that the driver side got colder when i switch the air intake from outside air to circulate air. i think the air got colder because of the increased air flow. and one last question it seems to me that when i got the system on full blast even before i had this problem it seemed that it was not pushing out enough air out of the system. but the blower motor seems like it is working just fine.
countryrunner is offline  
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 06-19-2013
Mr. Handy
 
g25racer's Avatar
 
Join Date: Apr 2012
Location: Michigan
Posts: 6,289
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Thanks: 534
Thanked 851 Times in 680 Posts
Like said before: Inspect/Replace the cabin air filter. Common cause of not enough airflow





2001 Impala LS
TransGO Shift kit
Spectre Cone Filter
Thunderbolt Spun Cat
ZZP Alternator Power Cable
Wagner Thermoquiet Pads
KYB Strut Plus (Rr)
L67 Pass Eng Mount
Tinted tail lights
Painted Trim
Dipped Rims and emblems
Led plate, full interior, trunk, and console
Black interior accents (handles and switch panels)
JBL GTO 6.5" and 6x9"
Sony MEX-GS600BT
Hifonics Hifi 1500 (KnuKoncepts 4ga)
Rockford P3 @ 500rms
"Apply Dielectric Grease or I kick some arse"
g25racer is offline  
post #5 of (permalink) Old 06-21-2013 Thread Starter
Member
 
countryrunner's Avatar
 
Join Date: Feb 2012
Posts: 51
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
well just got done checking the cabin air filter and it looks good to me no stuff on it at all so i am guessing its a vacuum line now or maybe the duel climate control is not working right
countryrunner is offline  
post #6 of (permalink) Old 06-21-2013
Junior Member
 
fastcat's Avatar
 
Join Date: Jun 2013
Posts: 22
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
It could be one of 2 things. Either the freon level is low or the actuator motor is stuck. The blend doors aren't ran off a vacuum, they are opened and closed electronically by the actuator. Grab a hammer and and open your drivers door, look under the dash, on the right of the gas pedal, on the center console you will see a black sensor that is very hard to get to , with I think 3 small bolts in it. Tap that a few times with the hammer and slide your drivers side climate co.troll switch up and down. That should get it back working. Oh yea, have the car started.

When I got my car the heat on the drivers side blew cold but hot on the passenger side. I did the procedure above and my heat worked correctly, and now that its hot my Ac works.

Also the reason the air gets colder when you hit the button is becuase it closes the vent door so no outside air is coming inside your car from outside. So you aren't using the cabin filter anymore when u hit that button. Its just recycling the air that's already in your car. So if the Ac is on the air will be colder, if the heat is on the heat will be hotter.

Last edited by fastcat; 06-21-2013 at 09:55 AM.
fastcat is offline  
post #7 of (permalink) Old 06-21-2013
8th Gen Antagonist
 
kingnutin's Avatar
 
Join Date: Mar 2009
Location: Vancouver , WA
Posts: 13,660
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Thanks: 517
Thanked 1,235 Times in 806 Posts
The 7th gens use vacuum, 8th gens went electric. That's why you have never heard of a 7th gen having the clicking dash issue.
sheila likes this.

1978 Caprice Classic Landau
350 2-bolt, stock 4bbl
Stock rebuilt TH350
Edelbrock performer cam + intake
Dual 2 1/2" Flowmaster exhuast (waiting to be installed)
Edelbrock IAS Classic shocks
95 9C1 3.08 posi
4 wheel disc brakes!
16x8 American Racing Baja's with 225/60/16 Pirelli P4's

kingnutin is offline  
post #8 of (permalink) Old 07-19-2019
Banned
 
Normalin's Avatar
 
Join Date: Feb 2019
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Most likely if you have a leak from the air conditioner then you have a crack in the radiator and under pressure freon flows out.You are lucky if you just need to change the air filter or clean all the air ducts. You can do it yourself or contact an ordinary air conditioning servicing company such as this which is engaged in the repair and support of all types of air conditioners and has many years of expirince and profesional experts in this field .
Normalin is offline  
Sponsored Links
Advertisement
 
Reply

Related Threads
Thread Thread Starter Forum Replies Last Post
Cold Air Induction won't fix the problem txlegacypaco Chevy Impala 8th Gen Discussion 10 10-18-2018 11:14 AM
2004 Impala LS 3.8L suddenly sucking in air Brenden1138 Chevy Impala 7th Gen Discussion 2 11-15-2017 03:17 PM
A/C Stops blowing air after a while coacice Chevy Impala 7th Gen Discussion 3 11-11-2017 10:33 AM
air conditioner stops working impala_al Chevy Impala 8th Gen Discussion 15 07-25-2017 08:13 AM


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome