What is this? - Chevy Impala Forums
Chevy Impala 7th Gen Discussion W-Body 2000-2005. Discuss all Chevy Impala 7th Generation Performance and Technical Discussion here.

User Tag List

 3Likes
  • 2 Post By My 2003 Impala
  • 1 Post By J_Mohler
 
LinkBack Thread Tools
Old 2 Weeks Ago Thread Starter
Junior Member
 
My 2003 Impala's Avatar
 
Join Date: Jul 2019
Posts: 27
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 15 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
What is this?

Was checking the coolant level in my '03, and this whitish/creme colored deposit was on the underside of the radiator cap. a small amount was on the inside of the filler neck, but coolant looked clean. Radiator cap is barely a few weeks old. Do I have something to worry about here?
Attached Images
 
My 2003 Impala is offline  
Sponsored Links
Advertisement
 
Old 2 Weeks Ago
Senior Member
 
1999 White C5 Coupe's Avatar
 
Join Date: Jul 2014
Posts: 1,418
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 220 Post(s)
Thanks: 109
Thanked 237 Times in 211 Posts
Quote:
Originally Posted by My 2003 Impala View Post
Was checking the coolant level in my '03, and this whitish/creme colored deposit was on the underside of the radiator cap. a small amount was on the inside of the filler neck, but coolant looked clean. Radiator cap is barely a few weeks old. Do I have something to worry about here?


Someone could have added something to the cooling system (stop leak)?

Short trips in cold weather without a fully warmed engine can cause deposits like this to form as shown.
1999 White C5 Coupe is offline  
Old 2 Weeks Ago Thread Starter
Junior Member
 
My 2003 Impala's Avatar
 
Join Date: Jul 2019
Posts: 27
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 15 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
I see no evidence of any stop leak, radiator and coolant tank levels have stayed at normal levels since I have had the car. When I take it out , it's always driven till the car is up to operating temp. I guess I'll just wipe it off and just keep an eye on it
My 2003 Impala is offline  
Sponsored Links
Advertisement
 
Old 2 Weeks Ago
Junior Member
 
wz7u's Avatar
 
Join Date: Jun 2018
Location: Rural NW Oregon, in the corner by the river
Posts: 29
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
To me, it looks like it could be oil in the condensate on the radiator cap. If so, you can flush a bit of it out of the COOL radiator by filling the neck with hose water and float it out. My guess there is a gooey, aw ****, residue needing wiped out.

Does the underside of the engine oil fill cap or even the dipstick have any of that milky goo? Peek in the coolant overflow tank while shining a light into it and what does it look like? Oil in your coolant isn't to be ignored.



The only other thing I can think of is Dex-Cool going over to the dark side or maybe some green coolant got topped off into the orange. Good radiator caps are essential with Dex-Cool too. Either way, don't let this thing get ahead of you. Es no bueno.

'03 3.4 with lots of miles, 230k+
wz7u is offline  
Old 2 Weeks Ago
Junior Member
 
J_Mohler's Avatar
 
Join Date: Jul 2018
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Only one real way to find out what's going on...drain, flush, and refill that bad boy and see if the gunk comes back. I've seen similar build up in other cars caused simply by being old fluid that was way overdue for a change. Also I've seen it from people that didn't know they are supposed to use distilled water if they used the concentrate antifreeze. Using tap water all that white chalky mineral deposit stuff that builds up around the faucet now turns into a glob in the car
plano-doug likes this.
J_Mohler is offline  
Old 2 Weeks Ago
Senior Member
 
mdubyk's Avatar
 
Join Date: Feb 2018
Location: Atlanta, GA
Posts: 110
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 28 Post(s)
Thanks: 2
Thanked 9 Times in 9 Posts
Garage
Quote:
Originally Posted by My 2003 Impala View Post
Was checking the coolant level in my '03, and this whitish/creme colored deposit was on the underside of the radiator cap. a small amount was on the inside of the filler neck, but coolant looked clean. Radiator cap is barely a few weeks old. Do I have something to worry about here?
How many miles do you have and how long have you owned the car?
It could be all that you need is a thorough system flush.

Last edited by mdubyk; 2 Weeks Ago at 04:37 PM.
mdubyk is offline  
Sponsored Links
Advertisement
 
 


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Thread Tools



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome