Power steering noise - Chevy Impala Forums
Chevy Impala 7th Gen Discussion W-Body 2000-2005. Discuss all Chevy Impala 7th Generation Performance and Technical Discussion here.

User Tag List

 1Likes
  • 1 Post By 1999 White C5 Coupe
 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 3 Weeks Ago Thread Starter
Junior Member
 
My 2003 Impala's Avatar
 
Join Date: Jul 2019
Posts: 27
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 15 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Power steering noise

Have noticed a whine when I turn the wheels on my '03, when outside temperature is below 32 degrees. Fluid level is full at proper level, have not had to add any fluid since I bought the car back in July. Once I have driven maybe 10 minutes the noise goes away. What could be causing this?
My 2003 Impala is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 3 Weeks Ago
Senior Member
 
sheila's Avatar
 
Join Date: Sep 2013
Posts: 1,855
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 193 Post(s)
Thanks: 315
Thanked 326 Times in 261 Posts
Air in the system needing bled? Any bubbles in the reservoir? Leaks?
sheila is offline  
post #3 of (permalink) Old 3 Weeks Ago Thread Starter
Junior Member
 
My 2003 Impala's Avatar
 
Join Date: Jul 2019
Posts: 27
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 15 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by sheila View Post
Air in the system needing bled? Any bubbles in the reservoir? Leaks?

No leaks. Can't be air in the system as it's never needed fluid added (Fluid is at correct level) since I bought it 5 months ago. Never made any noise till the recent cold mornings
My 2003 Impala is offline  
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 3 Weeks Ago
Senior Member
 
1999 White C5 Coupe's Avatar
 
Join Date: Jul 2014
Posts: 1,418
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 220 Post(s)
Thanks: 109
Thanked 237 Times in 211 Posts
Quote:
Originally Posted by My 2003 Impala View Post
No leaks. Can't be air in the system as it's never needed fluid added (Fluid is at correct level) since I bought it 5 months ago. Never made any noise till the recent cold mornings

It is possible that the prior owner(s) used an incorrect power steering fluid in the system.

You could do several partial fluid changes, using a rubber turkey baster with a hose attachment - to syphon the fluid out out of the pump.

If you have the 3.8 V-6, the p/s pump is down low and the cap is often covered with dirt. Make sure you clean the cap and reservoir neck well before removing the cap.

Ensure that you use the correct fluid specified in your vehicle owner’s manual. Good luck.
skenney likes this.
1999 White C5 Coupe is offline  
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome