Throttle seems to be stuck open - Chevy Impala Forums
Chevy Impala 7th Gen Discussion W-Body 2000-2005. Discuss all Chevy Impala 7th Generation Performance and Technical Discussion here.

User Tag List

 6Likes
  • 3 Post By Bill58
  • 1 Post By 1999 White C5 Coupe
  • 1 Post By 12 lt
  • 1 Post By jardows
 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 03-05-2019 Thread Starter
Junior Member
 
jardows's Avatar
 
Join Date: Jun 2015
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Garage
Throttle seems to be stuck open

Been having an issue lately with my 3.8 LS running high RPM's at idle. Without me touching the gas, the car takes off on its own when I let off the brake. I'm thinking that the throttle is stuck open a bit, but it's going to be this weekend before I get a chance to look at it. Any advise on what to look for, or what else it could be before I get my hands dirty?
jardows is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 03-05-2019
Senior Member
 
Bill58's Avatar
 
Join Date: Apr 2017
Location: Frederick, MD
Posts: 196
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 44 Post(s)
Thanks: 3
Thanked 22 Times in 22 Posts
Garage
I would clean inside the throttle body with cleaner and a tooth brush, clean all carbon from the butterfly area. If it still idles high clean the IAC valve.
Bill58 is offline  
post #3 of (permalink) Old 03-05-2019
Senior Member
 
1999 White C5 Coupe's Avatar
 
Join Date: Jul 2014
Posts: 1,281
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 188 Post(s)
Thanks: 106
Thanked 221 Times in 198 Posts
Quote:
Originally Posted by jardows View Post
Been having an issue lately with my 3.8 LS running high RPM's at idle. Without me touching the gas, the car takes off on its own when I let off the brake. I'm thinking that the throttle is stuck open a bit, but it's going to be this weekend before I get a chance to look at it. Any advise on what to look for, or what else it could be before I get my hands dirty?

In addition to the excellent advice in post #2 , replace the PCV valve, 2 o-rings, and black plastic fitting (ACDelco sells an inexpensive kit, don’t just replace the PCV valve). Use caution and patience when removing the black plastic fitting, and transferring the MAP sensor from the old fitting to the new fitting.
plano-doug likes this.
1999 White C5 Coupe is offline  
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 03-05-2019
Senior Member
 
12 lt's Avatar
 
Join Date: Feb 2017
Posts: 982
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 223 Post(s)
Thanks: 68
Thanked 83 Times in 78 Posts
Garage
Before replacing anything I would check the throttle cable at the throttle body and be sure it is not sticking or hanging. Have seen that happen in late 90's model chevy trucks. Have also seen the throttle cable kinked slightly which causes higher idle.
kbz1960 likes this.

My 6 year constantly asks why. What adults can learn from 5 and 6 year olds, to listen with your ears and mind open. Hard to learn when you don't listen ......
12 lt is offline  
post #5 of (permalink) Old 2 Weeks Ago Thread Starter
Junior Member
 
jardows's Avatar
 
Join Date: Jun 2015
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Garage
So just an update, the issue seemed to go away on it's own. I went ahead and changed the PCV valve and associated parts with the AC Delco kit. After a few months without an issue, it happened again the other day, but hasn't happened since. Once I get some time and it quits raining, I'll look into it some more. Thanks for the tips!
jardows is offline  
post #6 of (permalink) Old 2 Weeks Ago
Senior Member
 
1999 White C5 Coupe's Avatar
 
Join Date: Jul 2014
Posts: 1,281
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 188 Post(s)
Thanks: 106
Thanked 221 Times in 198 Posts
Quote:
Originally Posted by jardows View Post
So just an update, the issue seemed to go away on it's own. I went ahead and changed the PCV valve and associated parts with the AC Delco kit. After a few months without an issue, it happened again the other day, but hasn't happened since. Once I get some time and it quits raining, I'll look into it some more. Thanks for the tips!

If you haven’t cleaned the inside of the throttle body bore, and the butterfly valve edge, that may be your problem.

Oily, sticky “gunk” builds-up on the bore and the edge of the butterfly valve, and can cause the valve to stick and not return to the idle position (when the gas pedal is released). It can cause a low or rough idle also, and stalling at speed when the gas pedal is released.

A quick look inside the bore should give you an answer. It should be silver and shiny.
1999 White C5 Coupe is offline  
Sponsored Links
Advertisement
 
Reply

Related Threads
Thread Thread Starter Forum Replies Last Post
07 LS completely dead with key stuck in ignition- Please Help! kumiko26 Chevy Impala 9th Gen Discussion 1 4 Days Ago 08:58 PM
Fuel guage stuck on full Tmachor Restoration Forum 3 05-17-2019 08:01 PM
L26 pellinium to 2000+ Northstar throttle Hunter68 Automotive Discussion 0 08-03-2018 04:47 PM
2007 Impala 3.5 no start, key stuck, stuck in park, [email protected] Automotive Discussion 4 04-04-2018 05:07 PM
Driving Without A Thermostat (Or With A Fail-Safe That's Stuck Open) hg3300 Chevy Impala 7th Gen Discussion 15 12-25-2017 07:13 AM


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome