02 Impala barely moves - Chevy Impala Forums
Chevy Impala 6th Gen Discussion B-Body 1994, 1995, 1996. Discuss all Chevy Impala 6th Generation Performance and Technical Discussion here.

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 12-19-2017 Thread Starter
Junior Member
 
smriddlert's Avatar
 
Join Date: Oct 2017
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
02 Impala barely moves

Purchased an 02 impala that was sitting for about 5 years. After getting it running again (runs well) it barely moves forward or backwards. I'm suspecting a bad trans, however I would love feedback from others more knowledgeable. I come from an auto background, but needless to say, there's a reason why there are specific mechanics who service transmissions. (I don't know anything about them!) check engine light comes on for some type of gear mismatch code if I remember correctly. Can simply sitting cause a trans to go bad? I CAN get it to move and drive and even shift gears once I get it moving, but getting it moving requires revving the crap out of it and eventually it will lurch forward and start moving. Any ideas on how to bring it back if possible?
smriddlert is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 12-20-2017
Senior Member
 
reubenswinks's Avatar
 
Join Date: Nov 2014
Location: Grand Haven, MI
Posts: 365
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 94 Post(s)
Thanks: 32
Thanked 50 Times in 48 Posts
I would drop the pan and change the filter. Maybe the filter got clogged somehow from sitting for so long. Sounds like you aren't getting the line pressure you need. Thats what I would try first.
reubenswinks is offline  
Sponsored Links
Advertisement
 
Reply

Related Threads
Thread Thread Starter Forum Replies Last Post
02 Impala odd noise jtc95 Chevy Impala 7th Gen Discussion 4 03-03-2019 05:10 AM
Help troubleshooting overheating on 02 impala Spencer Salow Autocare and Maintenance 2 08-10-2018 05:35 PM
'02 Impala 3.4L, 211.6k : Annoying Window Motor Assembly Problem Colt Hero Chevy Impala 7th Gen Discussion 1 05-09-2018 09:57 AM
02 Impala neglected and abused cmartinHFD Chevy Impala 7th Gen Discussion 2 04-14-2018 11:01 AM
02 Impala Centric Hub Rings? 02ImpalaZay Wheels and Tires 1 08-08-2017 11:53 AM


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome