one long 91 caprice nightmare. - Page 2 - Chevy Impala Forums
Chevy Caprice General and Technical discussion for the Chevy Caprice (1965-1996), which shares the B-Body platform with the Chevy Impala.

User Tag List

Reply
 
LinkBack Thread Tools Display Modes
post #16 of (permalink) Old 09-01-2011
Banned
 
1969 Impala's Avatar
 
Join Date: Oct 2010
Posts: 574
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 4 Times in 3 Posts
Hillbillly shop? roflmao Good luck, you're going to need it!
1969 Impala is offline  
Sponsored Links
Advertisement
 
post #17 of (permalink) Old 09-01-2011 Thread Starter
Member
 
1991chevybetty's Avatar
 
Join Date: Apr 2011
Location: Dallas,TX
Posts: 80
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
I'll take it to the boys from deliverance. Good times.

1991chevybetty is offline  
post #18 of (permalink) Old 09-01-2011
8th Gen Antagonist
 
kingnutin's Avatar
 
Join Date: Mar 2009
Location: Vancouver , WA
Posts: 13,660
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Thanks: 517
Thanked 1,235 Times in 806 Posts
Then it would never get fixed, Burt Reynolds would show up and shoot one of them with an arrow, then slap you in the face for not having watched every one of his movies.

1978 Caprice Classic Landau
350 2-bolt, stock 4bbl
Stock rebuilt TH350
Edelbrock performer cam + intake
Dual 2 1/2" Flowmaster exhuast (waiting to be installed)
Edelbrock IAS Classic shocks
95 9C1 3.08 posi
4 wheel disc brakes!
16x8 American Racing Baja's with 225/60/16 Pirelli P4's

kingnutin is offline  
Sponsored Links
Advertisement
 
post #19 of (permalink) Old 09-01-2011 Thread Starter
Member
 
1991chevybetty's Avatar
 
Join Date: Apr 2011
Location: Dallas,TX
Posts: 80
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Ouch. haha. What a bastard
1991chevybetty is offline  
post #20 of (permalink) Old 09-03-2011 Thread Starter
Member
 
1991chevybetty's Avatar
 
Join Date: Apr 2011
Location: Dallas,TX
Posts: 80
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
I took my alternator out to test at the parts store and it failed. I have a 5.7 ex-police car. On the stores website the only alternator that said police was 120 amp and non-police were all 100 or 105 amp, but the employee said it doesn't matter.

Whats the differance? Does it matter? How many Amps do i need?
1991chevybetty is offline  
post #21 of (permalink) Old 09-03-2011
Banned
 
1969 Impala's Avatar
 
Join Date: Oct 2010
Posts: 574
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 4 Times in 3 Posts
Why did you take out the alternator? That isn't necessary.

If the alternator type didn't matter, they wouldn't list two different alternators.

Why did the alternator supposedly fail? What's supposedly wrong with it?

At the rate that you're going, before long you'll have replaced every single part on the car!
1969 Impala is offline  
post #22 of (permalink) Old 09-04-2011 Thread Starter
Member
 
1991chevybetty's Avatar
 
Join Date: Apr 2011
Location: Dallas,TX
Posts: 80
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
It's necessary for me, i don't drive it cause it's not inspected and gotten too many tickets for that, plus it waste alot of fuel to get it going.

I kinda thought something was wrong with it because my car will start up like a normal car and doesn't die after it has been charged. But after that first start it gets difficult again. Also alternator light is on and gauge fluctuates whenever i use blinkers or headlights. i was thinking the regulator.

I dont know why it failed but it didn't pass
1991chevybetty is offline  
post #23 of (permalink) Old 09-04-2011
1st Year of the 5th Generation

 
77Impala's Avatar
 
Join Date: Nov 2007
Location: North TX
Posts: 7,059
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 16 Post(s)
Thanks: 448
Thanked 440 Times in 281 Posts
Since you don't have the police light bar, siren, radios, and flashing strobes you don't really need the higher amp alternator. You can use the standard one.

Since you live in a emission testing county your car can fail just because the Check Engine lamp is on. Which in this case is possible from the alternator not working. Hope that is all your problem is.


1977 Chevrolet Impala Sedan
1989 GMC C1500 Sierra ECSB
77Impala is offline  
post #24 of (permalink) Old 09-04-2011 Thread Starter
Member
 
1991chevybetty's Avatar
 
Join Date: Apr 2011
Location: Dallas,TX
Posts: 80
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Alright thank you.

The 120 amp police alternator and the 100 amp one are the same price both with a lifetime warranty. Which one should i get? Any perfomance difference? Will too many amps fry anything?
1991chevybetty is offline  
post #25 of (permalink) Old 09-04-2011
1st Year of the 5th Generation

 
77Impala's Avatar
 
Join Date: Nov 2007
Location: North TX
Posts: 7,059
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 16 Post(s)
Thanks: 448
Thanked 440 Times in 281 Posts
No the higher amp won't fry anything. If installing a high amp stereo and or multiple dvd displays then go with the higher amp alternator.


1977 Chevrolet Impala Sedan
1989 GMC C1500 Sierra ECSB
77Impala is offline  
post #26 of (permalink) Old 09-05-2011
Junior Member
 
blizzy21's Avatar
 
Join Date: Sep 2011
Location: nyc/nj
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
hey can someone tell me why when i start up my car it idles at 1000rpm, and after a short while it turns off!! but it happens every once in awhile .. I changed my alternator. still does it....
blizzy21 is offline  
post #27 of (permalink) Old 09-05-2011 Thread Starter
Member
 
1991chevybetty's Avatar
 
Join Date: Apr 2011
Location: Dallas,TX
Posts: 80
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by blizzy21 View Post
hey can someone tell me why when i start up my car it idles at 1000rpm, and after a short while it turns off!! but it happens every once in awhile .. I changed my alternator. still does it....
I had the same damn problem exept mine idles at 2000 rpm, it's not fixed all the way now but i can get mine to run eventually now by pumping the gas a little while. Did you have any trouble codes? At first i thought mine was a vacuum leak, but it wasnt it. After i changed my fuel pump and retainer i could get it to idle after the engine was warmed up by pumping the gas pedal to keep the engine alive. Also check the fuel filter.
1991chevybetty is offline  
post #28 of (permalink) Old 09-05-2011
Senior Member
 
Gregg-O's Avatar
 
Join Date: Mar 2008
Location: Phoenix
Posts: 2,102
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 84 Times in 59 Posts
Quote:
Originally Posted by blizzy21 View Post
hey can someone tell me why when i start up my car it idles at 1000rpm, and after a short while it turns off!! but it happens every once in awhile .. I changed my alternator. still does it....
What in the world made you think the alt had anything to do with it running like that?

The other thing's could be any number of thing's, how many miles on the car? Has it been taken care of? New fuel filter? ICM's can start to crap out when they get hot. High ldle could be dirty TB, sticky throttle blades, sticky/bad IAC valve, sticky throttle cable, shitty MAF........
Gregg-O is offline  
post #29 of (permalink) Old 09-05-2011 Thread Starter
Member
 
1991chevybetty's Avatar
 
Join Date: Apr 2011
Location: Dallas,TX
Posts: 80
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Hey hey hey... let's get back to my car problems.
1991chevybetty is offline  
post #30 of (permalink) Old 09-06-2011
Banned
 
1969 Impala's Avatar
 
Join Date: Oct 2010
Posts: 574
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 4 Times in 3 Posts
Quote:
Originally Posted by 1991chevybetty View Post
Alright thank you.

The 120 amp police alternator and the 100 amp one are the same price both with a lifetime warranty. Which one should i get? Any perfomance difference? Will too many amps fry anything?
A lifetime warranty many times means cheap, made in China, "quality". Beware!

An alternator will only charge at the rate that is needed. If the battery were almost totally drained, then whatever the maximum charge rate of the alternator, (like 120 or 100 amp), will kick in. If the battery is nearly fully charged, it may only charge at 25 amps.
1969 Impala is offline  
Sponsored Links
Advertisement
 
Reply

Related Threads
Thread Thread Starter Forum Replies Last Post
Caprice impala ss roadmaster 91 92 93 94 95 96 window regulator guides clips RSS Bot Impala Diecast Toys Cars on eBay 0 09-04-2018 10:30 PM
91 96 caprice classic hood ornament emblem lt1 5.7 350 tri y 9c1 RSS Bot Impala Diecast Toys Cars on eBay 0 08-19-2018 03:23 PM
Depo 91 92 93 94-96 chevy impala & caprice smoke rear tail light covers frames RSS Bot Impala Diecast Toys Cars on eBay 0 12-11-2017 09:10 PM
91 92 93 94 95 1996 Impala SS Caprice Front Door Panel Courtesy Light Lens L/R RSS Bot Impala Diecast Toys Cars on eBay 0 08-27-2017 06:40 PM
91 92 93 94 95 96 Chevy Impala SS Caprice Power Window Master Seat Switches L/R RSS Bot Impala Diecast Toys Cars on eBay 0 08-23-2017 03:00 AM


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome