Electric Fan Problem - Chevy Impala Forums
Chevy Caprice General and Technical discussion for the Chevy Caprice (1965-1996), which shares the B-Body platform with the Chevy Impala.

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 07-13-2011 Thread Starter
Member
 
1995CapriceClassic's Avatar
 
Join Date: Jul 2011
Posts: 31
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Electric Fan Problem

I have a 1995 Caprice with the 4.3 L99 V8. I seem to have a problem with the electric fans. Whenever they do come on, the Check Engine Light comes on as well. But, recently I had the car start to overheat, and the E-Fans didn't come on. What could be wrong? Any suggestions to fix the problem.
1995CapriceClassic is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 07-14-2011
Senior Member
 
MrBuick (Magnum)'s Avatar
 
Join Date: Apr 2009
Location: Benton Harbor, MI
Posts: 997
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Sounds like the sending unit in the water pump is bad. Replace it. The gauge on the dash uses the one on the passengers side head. The PCM/fans are controlled by the one in the water pump. If it goes into limp mode, and fails to get a reading from that sensor, it will kick the fans on, and the CEL.

~Cory Magner "My name is Cory, and I'm an addict."


95 DCM Buick RMS 14.21 @ 91.79 "Jesus" Blown Engine at 85k
95 DCM Buick RMS 13.52 @ 99.33 "The Doctor" Blown Engine at 180k
96 DGGM Buick RMW. 263k, still on the factory tranny.

And 5 other LT1 powered land yachts Is there Rehab for this Sh*t?
MrBuick (Magnum) is offline  
post #3 of (permalink) Old 07-15-2011 Thread Starter
Member
 
1995CapriceClassic's Avatar
 
Join Date: Jul 2011
Posts: 31
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by MrBuick (Magnum) View Post
Sounds like the sending unit in the water pump is bad. Replace it. The gauge on the dash uses the one on the passengers side head. The PCM/fans are controlled by the one in the water pump. If it goes into limp mode, and fails to get a reading from that sensor, it will kick the fans on, and the CEL.
Thank you so much! Replacing that sensor did the trick! Much easier than having a mechanic charge 100 dollars/hour to diagnose and fix the problem.
1995CapriceClassic is offline  
Sponsored Links
Advertisement
 
Reply

Related Threads
Thread Thread Starter Forum Replies Last Post
2015 LTZ AC Problem jrnipps Introductions & Welcome Forum 3 05-19-2018 06:38 PM
Shifting problem sinjin Autocare and Maintenance 3 03-05-2018 12:47 PM
HVAC Cruise problem tjharring Chevy Impala 7th Gen Discussion 2 09-23-2017 05:53 PM
Car 12V 16.5A Electric Turbine Turbo Charger Air Intake Fan Bold Line Solid RSS Bot Impala Diecast Toys Cars on eBay 0 08-23-2017 08:20 AM


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome