Long cranking issue when cold - Chevy Impala Forums
Chevy Caprice General and Technical discussion for the Chevy Caprice (1965-1996), which shares the B-Body platform with the Chevy Impala.

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 01-07-2016 Thread Starter
Member
 
1995CapriceClassic's Avatar
 
Join Date: Jul 2011
Posts: 31
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Long cranking issue when cold

Hey guys, so... I put a new ignition control module, and coil in my 95' L99 yesterday. And this morning, and when I first fired the car after I put it back together, it took forever to start. Starter just keeps turning like there is no spark. It does eventually start after about 3 cycles of the key, and it has no issue when the car is warmed up. I put a new opti, water pump, plugs and wires in about 6 months ago.

And on a kind of unrelated note, after I put the ICM and coil in, my ABS light is on, and my windshield wipers don't work. So, I don't know what the heck I did wrong here. Any help is appreciated! Thanks!
1995CapriceClassic is offline  
Sponsored Links
Advertisement
 
Reply

Related Threads
Thread Thread Starter Forum Replies Last Post
96 SS Cold Start Issue Peteroros Chevy Impala Discussion 7 01-05-2019 10:17 AM
05 3.4 long crank when cold? Litezoner Chevy Impala 7th Gen Discussion 4 07-24-2018 07:26 AM


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome