Random Stall - Chevy Impala Forums
Buick Roadmaster General and Technical discussion for the B-Body Buick Roadmaster (1991-1996) and Oldsmobile Custom Cruiser (1991-1992).

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 05-06-2009 Thread Starter
Senior Member
 
96ssbbb's Avatar
 
Join Date: May 2008
Location: Florida
Posts: 284
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Random Stall

Car- 1996 Rodemaster
Mileage 160k
Maintenance – Unknown / with the exception to new hoses, water pump, belt. {resent purchase}

Problem- Car dies without warning, just completely shuts off. Wait a few minutes {1-20} and it starts right back up. No CEL or obvious problems when driving, No visible problems under the hood. Idle is smooth and the car has been running flawlessly since I bought it a few weeks ago.
I’m thinking fuel pump, but I’ve never had an Opti just crap out on me either. I’ve asked about a fuel pressure gauge at AutoZone and O’rilleys nearby, none in stock. All this pisses me off because I have all the tools and spare parts to fix ANYTHING on this bucket at my home, 650 miles away But I’m not, so repairs will have to be made in a Hotel parking lot; they’re not going to be happy about this.

So place you’re bet, what’s your best guess?
96ssbbb is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 05-07-2009
Senior Member
 
POPIMPIN CUSTOMS I.N.C's Avatar
 
Join Date: Nov 2008
Location: COLORFUL COLORADO
Posts: 1,556
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by RoadMonster View Post
My guess: Ignition Module.
^ well since he knows his roadies!!!!!^^^ but my second guess would def be a fuel pump we know how shitty they are after 100000, ive replaced 3 so far on 91 thru 95 chevy cars/ suv my suburban

4 B BODIES
2 SOLD CAPRICES
1995 9C1 UNDERCOVER CAR WHITE ON IMPALA SS'S muff delete/ hollowed cats / I.N.C. REP TILL I DIE
1991 CAPRICE CLASSIC 350 160,000 CUSTOM 20'S STOCK 2 TONE
1991 caprice 305 payed $600 sold 4 $1200
1965 OLDSMOBILE STARFIRE 425 BIG BLOCK 375+- HORSES SMASHES ON FORDS
POPIMPIN CUSTOMS I.N.C is offline  
post #3 of (permalink) Old 05-07-2009 Thread Starter
Senior Member
 
96ssbbb's Avatar
 
Join Date: May 2008
Location: Florida
Posts: 284
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Thanks for the help guys, looks like I’ll be taking my work truck home so I’ll be sure and pack an Ignition Module, it’s also been suggested I try the MAF. I did clean the MAF, it was dirty as hell but no luck. But I’ll bring another one back with me anyway just in case.
96ssbbb is offline  
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 05-07-2009
Senior Member
 
POPIMPIN CUSTOMS I.N.C's Avatar
 
Join Date: Nov 2008
Location: COLORFUL COLORADO
Posts: 1,556
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
a fuel pumps 65 dollars and takes like an hour if u have tools and arent an idiot

4 B BODIES
2 SOLD CAPRICES
1995 9C1 UNDERCOVER CAR WHITE ON IMPALA SS'S muff delete/ hollowed cats / I.N.C. REP TILL I DIE
1991 CAPRICE CLASSIC 350 160,000 CUSTOM 20'S STOCK 2 TONE
1991 caprice 305 payed $600 sold 4 $1200
1965 OLDSMOBILE STARFIRE 425 BIG BLOCK 375+- HORSES SMASHES ON FORDS
POPIMPIN CUSTOMS I.N.C is offline  
post #5 of (permalink) Old 05-26-2009 Thread Starter
Senior Member
 
96ssbbb's Avatar
 
Join Date: May 2008
Location: Florida
Posts: 284
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Update:

Checked fuel pressure it seems to be fine, not an idiot but thanks poptart

To date I’ve replaced the coil and the ICM no luck same condition as posted above, previous owner insists the opti is new GM opti, and I have no reason to not to believe him. So, I have a new coil new ICM and a good opti, but I still have the same random stalling condition, any other ideas?

I’m borderline ready to install a new opti just to make sure for my damn myself, but I would like to eliminate other suspects first first.

Last edited by 96ssbbb; 05-26-2009 at 09:51 PM.
96ssbbb is offline  
post #6 of (permalink) Old 05-27-2009
Senior Member
 
Gregg-O's Avatar
 
Join Date: Mar 2008
Location: Phoenix
Posts: 2,102
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 84 Times in 59 Posts
Mmmmmm opti vent harness clogged, ozone buildup after running, car stalls. Just a guess. Remember...NEW doesn't always = GOOD.

Hey , That's a new (& cheap) opti.

How do you know the fuel pressure is good? Did you put a gauge on it? I picked up a pressure test kit at Harbor Freight for $35, I couldn't get one at AZ or Checker without ordering it either.
Gregg-O is offline  
post #7 of (permalink) Old 05-27-2009 Thread Starter
Senior Member
 
96ssbbb's Avatar
 
Join Date: May 2008
Location: Florida
Posts: 284
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Well I haven’t ever had one clog up so I don’t know the affects of a clogged opti harness, but I have a known good spare so I'll give it a try.
When I went home to Florida I brought back my fuel pressure gauge and a ton of spare parts.
96ssbbb is offline  
post #8 of (permalink) Old 05-27-2009
Senior Member
 
POPIMPIN CUSTOMS I.N.C's Avatar
 
Join Date: Nov 2008
Location: COLORFUL COLORADO
Posts: 1,556
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
[QUOTE=96ssbbb;266987]Update:

Checked fuel pressure it seems to be fine, not an idiot but thanks poptart

QUOTE]

I wasnt saying ur an idiot its jsut that some people wont do there own mechanic works specially on something as easy as a 30 min fuel pump job!!!!!:eek:

4 B BODIES
2 SOLD CAPRICES
1995 9C1 UNDERCOVER CAR WHITE ON IMPALA SS'S muff delete/ hollowed cats / I.N.C. REP TILL I DIE
1991 CAPRICE CLASSIC 350 160,000 CUSTOM 20'S STOCK 2 TONE
1991 caprice 305 payed $600 sold 4 $1200
1965 OLDSMOBILE STARFIRE 425 BIG BLOCK 375+- HORSES SMASHES ON FORDS
POPIMPIN CUSTOMS I.N.C is offline  
post #9 of (permalink) Old 05-02-2010
Junior Member
 
Jeremy Chorney's Avatar
 
Join Date: May 2010
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Help! New User so I hope I'm not violating protocol here. I have the IDENTICAL problem with my 1995 LT1 Z28. New MSD Opti 6 months ago. Still has original coil, Ignition Control Module and Fuel Pump. Car has only 50K miles on it. I already had the grounds checked out. Before I go and replace the coil and ICM, what was the problem with your car??? Thanks so much - I appreciate your response!
Jeremy Chorney is offline  
post #10 of (permalink) Old 05-02-2010
Super Moderator
 
Dwayne J's Avatar
 
Join Date: Jan 2009
Posts: 3,899
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 88 Post(s)
Thanks: 16
Thanked 362 Times in 234 Posts
The MSD opti is GARBAGE would be high on my list of suspects.
Before buying anything I would try swapping a functional stock one on. If the old one was replaced because of poor running as opposed to a optical pickup code put the MSD cap and rotor on the stock opti and you WILL be better off than you are with the fancy billet base.

Most of the guys who bought that thing have ended up switching back to stock.

I know that is not what you want to hear after spending $500 on it but if you start blindly replacing parts assuming it is good because it is "performance" and new you will spend a lot more.

Not every one of them has gone bad, but enough that it should be a strong suspect and should NOT be purchased.

I know people claim the stockers are bad but if they were one would not survive on my car, which happens to have a completely stock opti at the moment

Dwayne
96 Caprice with AI 200cc package
Best et 11.5
Best MPH 116
Just another taxi
Dwayne J is offline  
post #11 of (permalink) Old 05-02-2010
Junior Member
 
Jeremy Chorney's Avatar
 
Join Date: May 2010
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
My original Opti was toast - rust causing arcing, etc... I used a factory replacement distributor, only cap and rotor was MSD. Car ran perfect since until now... actually it still does run perfect - when its not stalling!
Jeremy Chorney is offline  
post #12 of (permalink) Old 05-03-2010
Super Moderator
 
Dwayne J's Avatar
 
Join Date: Jan 2009
Posts: 3,899
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 88 Post(s)
Thanks: 16
Thanked 362 Times in 234 Posts
Does it idle low and then stall or just cut out???

I had an IAC die and it would idle real low sometimes and die.

There are other good ideas posted further up.

Dwayne
96 Caprice with AI 200cc package
Best et 11.5
Best MPH 116
Just another taxi
Dwayne J is offline  
post #13 of (permalink) Old 05-03-2010
Junior Member
 
Jeremy Chorney's Avatar
 
Join Date: May 2010
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Quits at idle, under load, steady speed. You name it. Absolutely no rhyme or reason. Only common thread appears to be that it happens after reaching operating temp (car never overheats)
Jeremy Chorney is offline  
post #14 of (permalink) Old 05-04-2010 Thread Starter
Senior Member
 
96ssbbb's Avatar
 
Join Date: May 2008
Location: Florida
Posts: 284
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Guess I should have updated this thread.

My problem ended up being the Opti. Even though the previous owner had the Opti changed by his trusted mechanic who claimed to have used a GM unit (and charged accordingly). But when I removed the Opti it was a cheap knock off, and being in a bind at the time I also replaced it with another knock off Opti. But it failed with in a month. So after an expensive learning curve with Optis I concluded the best option is just to get a new GM AC Delco unit and be done with it. I found the best price at Summit.
96ssbbb is offline  
post #15 of (permalink) Old 05-06-2010
Junior Member
 
Jeremy Chorney's Avatar
 
Join Date: May 2010
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Rats... I was hoping for a cheap and easy fix... The Opti I put in has less than 5K on it. Thanks for the update. I literally took the car to the Dealership this morning...
Jeremy Chorney is offline  
Sponsored Links
Advertisement
 
Reply

Related Threads
Thread Thread Starter Forum Replies Last Post
Random knocking or tapping noise coming from rear end Fi_bassimpala Chevy Impala 8th Gen Discussion 3 03-26-2019 04:59 PM
Random power steering fluid loss Heavy Chevy Impala 8th Gen Discussion 2 01-28-2019 07:47 AM
6pcs Car Auto Windshield Cables Holder Wires Clip Sticky Desk Accessories Random RSS Bot Impala Diecast Toys Cars on eBay 0 08-20-2018 02:50 PM
Car stall no engine codes loveerin88 Autocare and Maintenance 1 06-07-2018 05:18 AM
Random High Idle 05Impala3.4 Mechanical and Electrical Problems 4 10-11-2017 10:08 AM


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome