Simple Question Thread - Page 45 - Chevy Impala Forums
Automotive Discussion General automotive related discussion only.

User Tag List

 9Likes
Reply
 
LinkBack Thread Tools Display Modes
Junior Member
 
Valenzano's Avatar
 
Join Date: Jul 2017
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
What's the best manual out there for a novice starting from scratch on getting a 1968 Impala back up and running? I know Helm is supposed to be the way to go, but from what I can tell, they didn't start on Impalas until 1972.
Valenzano is offline  
Sponsored Links
Advertisement
 
Senior Member
 
TeeRev's Avatar
 
Join Date: Nov 2016
Location: Indiana
Posts: 592
Mentioned: 9 Post(s)
Tagged: 0 Thread(s)
Quoted: 124 Post(s)
Thanks: 15
Thanked 75 Times in 69 Posts
Garage
Quote:
Originally Posted by Valenzano View Post
What's the best manual out there for a novice starting from scratch on getting a 1968 Impala back up and running? I know Helm is supposed to be the way to go, but from what I can tell, they didn't start on Impalas until 1972.
These might help.

1968 CHEVROLET IMPALA 7.0L 427cid V8 Repair Manual | RockAuto

Chilton makes one as well (they make good manuals) but I can't find one for the 68 Impala. You might have better luck.

Hope this helps!


08 Impala LTZ


Rosen DS-GM1010-P11
Rosen DP-1088
Blackvue DR-470 2-Ch w/ PMP & GPS
Ultragauge MX 1.3
Dynomax 3" tips
Chevrolet Performance STBs + DR custom brackets
30% Llumar tint
Techno Steel interior trim / leather shifter
SS grille
Reverse light / full interior / instrument cluster LED retrofit
LED headlights / fog lights
Stant locking gas cap
WeatherTech front liners / window deflectors
GM molded splash guards
McGard locks
Firestone Firehawk Wide Oval UHP
TeeRev is offline  
Senior Member
 
TeeRev's Avatar
 
Join Date: Nov 2016
Location: Indiana
Posts: 592
Mentioned: 9 Post(s)
Tagged: 0 Thread(s)
Quoted: 124 Post(s)
Thanks: 15
Thanked 75 Times in 69 Posts
Garage
Question, it was about 15F this morning and I tried to remote start my car. It didn't want to start. Tried it again, same thing. The lights flashed, I heard the starter try to go, but it didn't start.

Got in to my car and it started just fine. It may have hesitated half a second due to the cold, but otherwise started just fine. Drove to work, turned the car off, got out and tried the remote start again. It worked just fine. The remote starter has been working like a charm this past week, and the last time I used it was actually last night.

Does anybody have any idea what's going on? 15F isn't too stupidly cold for the car I don't think.

Note: I've suspected that a cell in my battery is *starting* to die, but I do not know why that would cause the remote start to fail when a key start worked just fine. Going off of the battery idea, the headlights were on when I used the key (approach lighting), whereas they were off when I tried the remote start. Shouldn't the headlights being on have even further reduced available voltage for the starter?

Thanks in advance!


EDIT: I moved the question to its own thread in the 8th Gen forums. Thanks!


08 Impala LTZ


Rosen DS-GM1010-P11
Rosen DP-1088
Blackvue DR-470 2-Ch w/ PMP & GPS
Ultragauge MX 1.3
Dynomax 3" tips
Chevrolet Performance STBs + DR custom brackets
30% Llumar tint
Techno Steel interior trim / leather shifter
SS grille
Reverse light / full interior / instrument cluster LED retrofit
LED headlights / fog lights
Stant locking gas cap
WeatherTech front liners / window deflectors
GM molded splash guards
McGard locks
Firestone Firehawk Wide Oval UHP

Last edited by TeeRev; 12-08-2017 at 08:19 AM.
TeeRev is offline  
Sponsored Links
Advertisement
 
Senior Member
 
Joes74challenger's Avatar
 
Join Date: Apr 2016
Location: Fort Wayne
Posts: 1,299
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 253 Post(s)
Thanks: 30
Thanked 122 Times in 118 Posts
Garage
have the battery checked. i've noticed when the battery is getting weak it will do what you described.
Joes74challenger is offline  
The Following 2 Users Say Thank You to Joes74challenger For This Useful Post:
TeeRev (12-08-2017)
Sponsored Links
Advertisement
 
Reply

  LinkBacks (?)
LinkBack to this Thread: https://www.impalaforums.com/automotive-discussion/295997-simple-question-thread.html
Posted By For Type Date
Automotive Discussion - Chevy Impala Forums : 2011 Impala Forum This thread Refback 01-12-2012 10:34 AM

Related Threads
Thread Thread Starter Forum Replies Last Post
Question about the Key fobs on the 9th gen Impala FAWAZ87 Chevy Impala 9th Gen Discussion 9 05-04-2019 07:58 AM
The Wiring Diagrams Thread battleship7 Mechanical and Electrical Problems 10 12-07-2018 08:28 AM
Car is Leaking Question DJ_Vasquezz 8th Gen Engine Performance 4 01-23-2018 11:50 PM
Not Receiving eMail Notifications of Thread Replies JerseyHarold Impala Forum Site Issue Forum 1 11-13-2017 07:46 AM
Simple Question Thread mikein4life Chevy Impala 9th Gen Discussion 8 11-01-2017 10:08 AM


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome