I have a 1997 cadillac deville, when I accelerate it bogs down and acts like... - Chevy Impala Forums
Automotive Discussion General automotive related discussion only.

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 09-02-2007
Railr0ader
Guest
 
Railr0ader's Avatar
 
Posts: n/a
Mentioned: Post(s)
Tagged: Thread(s)
Quoted: Post(s)
I have a 1997 cadillac deville, when I accelerate it bogs down and acts like...

...it wants to backfire. wrong gas? I used mid grade gas and was wondering if that might be the problem. I just purchased the deville and love it other than that.
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome