2014 LS Odometer inop - Chevy Impala Forums
Automotive Discussion General automotive related discussion only.

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 06-08-2019 Thread Starter
Junior Member
 
BlueImpala's Avatar
 
Join Date: Jun 2019
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
2014 LS Odometer inop

Today on my wife’s car the digital Speedo went dark, the odometer reads zero. The swing gage speedo and remainder of cluster are functional. No drive concern? trans shifts normal. Any ideas?
BlueImpala is offline  
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome