Fuel issues - Chevy Impala Forums
Automotive Discussion General automotive related discussion only.

User Tag List

 5Likes
  • 3 Post By plano-doug
  • 1 Post By plano-doug
  • 1 Post By Joes74challenger
 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 04-26-2019 Thread Starter
Junior Member
 
Shotta1313's Avatar
 
Join Date: Apr 2019
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Fuel issues

Hey guys i have a 2018 impala premiere. I felt like I was getting terrible mileage with the car. Had it for about a month. Bought it used with 28,000 miles.
It didnt really click until I seen another impala and they guy let me look inside his to confirm. Guy is averaging 24 mpg. Has like 120,000 miles on his impala. It was a 2016. His fuel remaining gauge reads 450 when completely full of fuel.

He's my problem. When I fill up my fuel remaining has only peaked at 316 remaining miles. I average 12 mpg in the city. Tires are inflated properly, new air filter, and i dont run e85.

I took the car to a shop next door and they hooked up a snap-on computer to it. He said my alcohol level is reading 76%. I had him reset everything and update the computer in my car. It feels slightly better but not really getting much of a difference in mileage.
When I check online the mileage/miles remaining should be way better than it currently is. Hell this this is getting less miles per tank than my 2013 mazda3 was, and this has an 18 gallon tank. Does anyone have a clue on this matter? If i fill all the way up i feel like i should be getting 400-500 miles not 200(which is what i got on my last fill up) thanks for any help.
Shotta1313 is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 04-26-2019
Senior Member
 
12 lt's Avatar
 
Join Date: Feb 2017
Posts: 1,014
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 232 Post(s)
Thanks: 70
Thanked 85 Times in 80 Posts
Garage
My guess would be the car idled a lot or was in heavy stop and slow traffic by the prior owner and as such the overall mpg is showing low. When you say city driving, how much sitting? Think the miles to empty will go up as the mileage improves, IF you are doing less sitting in traffic. We get average 25.6 or so on our 2012, and it has 162 thousand miles on it. That is with mixed driving, some sitting at school drop offs and an average speed of around 41 mph.

Get out on the highway and cruise about 75 and see what you instant economy reads out. Should be close to 30.

My 6 year constantly asks why. What adults can learn from 5 and 6 year olds, to listen with your ears and mind open. Hard to learn when you don't listen ......
12 lt is offline  
post #3 of (permalink) Old 04-26-2019 Thread Starter
Junior Member
 
Shotta1313's Avatar
 
Join Date: Apr 2019
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
This is with everything reset currently. I've been doing my own personal observations as well. Have put maybe 10 full tanks of gas in this car. I dont let the car idle really at all, and as far as city driving, well....just around the city lol. Grocery store etc.
Shotta1313 is offline  
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 04-26-2019 Thread Starter
Junior Member
 
Shotta1313's Avatar
 
Join Date: Apr 2019
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Also with a few hours highway maintaining a good speed of 65 I ended up averaging 24 mpg. Just think it's weird im getting such low mpg city. Sometimes its 9mpg, and i mean overall not the current mpg gauge.
Shotta1313 is offline  
post #5 of (permalink) Old 04-26-2019
Junior Member
 
Lea14ltzv6's Avatar
 
Join Date: Jun 2015
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
I have a 2014 ltz new body with same exact problems, I never show over 319 tell empty plus no matter how empty my tank is the most I’ve ever been able to get pumped in is 14 gallons, I usually end up getting about 220 per tank. I’ve never had a dash light come on nor a code, I can’t seem to get any dealerships to do anything about it because they always say there’s no lights or codes. I have 30,000 miles on my car I bought it with 400 miles on it and it’s been the same the hole time. I’ve drove loaner impalas same motor, they get normal gas mileage, I’ve changed my filters good inflated tires same issues. right now I’m getting 14.4 mpg, on the freeway it depends but I’ve got as good as 39mpg but that was a long 300 mile freeway trip when we tried taking the car back to the original dealership we bought it from. They said the same thing all the others said and sent us home. Normally if I do use the freeway some I get 16 combined but that’s on a good day. Have you noticed any resistance in the way the car drive like when you push the gas it feels like it won’t go? Mines gotten better but now I’m pretty sure my cats are going out, I’d assume due to the incorrect fuel mixture. Im outta warranty due to time owned the car but it was at the dealership, several as a matter of fact, over 20 times, to witch none ever took me seriously enough to try and look into my problems. I’ve even been kicked outta one and can’t go back, like I like having to take my car in and be treated like I’m making it up. I’m sorry your not alone if I ever find anything out I’ll be sure to post please do the same. I did have the car scanned and one thing that I found odd was outta the six fuel injectors two where about 4 points higher then the other 4. I don’t know exactly what that means if anything but good luck.
Lea14ltzv6 is offline  
post #6 of (permalink) Old 04-27-2019 Thread Starter
Junior Member
 
Shotta1313's Avatar
 
Join Date: Apr 2019
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Yeah I'll let you know if i find anything out. Kinda becoming frustrating.
Shotta1313 is offline  
post #7 of (permalink) Old 04-27-2019 Thread Starter
Junior Member
 
Shotta1313's Avatar
 
Join Date: Apr 2019
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Bump
Shotta1313 is offline  
post #8 of (permalink) Old 04-28-2019
Junior Member
 
mattcanz321's Avatar
 
Join Date: Apr 2019
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
impala

hey i got a 2012 impala when i bought mine same thing i use penzoil oil and put new ac delco plugs in and ran amsoil pi fuel additive and did the trifecta tune my average mpg in the summer is 28mpg
mattcanz321 is offline  
post #9 of (permalink) Old 06-23-2019
Junior Member
 
Rockyd57..'s Avatar
 
Join Date: Jun 2019
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Have a 2011 and bring it in to walmart for oil changes,when they check the air filter and put it back in they put it in wrong so my gas mileage went from good to bad,and after checking what was wrong I looked at filter and saw it wasn't in right way,changed it around,now I get great gas mileage again...friggen now a days places get idiots working...
Rockyd57.. is offline  
post #10 of (permalink) Old 06-23-2019
Senior Member
 
plano-doug's Avatar
 
Join Date: Aug 2009
Location: Plano, Texas
Posts: 2,435
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 353 Post(s)
Thanks: 130
Thanked 357 Times in 333 Posts
Quote:
Originally Posted by Rockyd57.. View Post
...friggen now a days places get idiots working...
That's part of the problem. And part of it is the design of the box. There's hardly enough clearance to assemble that thing correctly, and if you do it wrong, and try to pull it together using the latches, you might just break them off and make things worse.

We've forgotten how to keep things simple

One wing nut ↓




Doug


.

_

If your socket set is all the same brand, you might be a city slicker.

.
plano-doug is offline  
post #11 of (permalink) Old 06-24-2019
Junior Member
 
Arkie's Avatar
 
Join Date: Mar 2019
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by Rockyd57.. View Post
Have a 2011 and bring it in to walmart for oil changes,when they check the air filter and put it back in they put it in wrong so my gas mileage went from good to bad,and after checking what was wrong I looked at filter and saw it wasn't in right way,changed it around,now I get great gas mileage again...friggen now a days places get idiots working...
How in the world did they have the filter installed?? I'm thinking that might be my problem as mine went from 27-28 mpg to 23-25 mpg.
Arkie is offline  
post #12 of (permalink) Old 06-25-2019
Senior Member
 
plano-doug's Avatar
 
Join Date: Aug 2009
Location: Plano, Texas
Posts: 2,435
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 353 Post(s)
Thanks: 130
Thanked 357 Times in 333 Posts
Quote:
Originally Posted by Arkie View Post
How in the world did they have the filter installed?? I'm thinking that might be my problem as mine went from 27-28 mpg to 23-25 mpg.
Here's a video for the gen9 Impala. It's a totally different setup than the gen8 I was thinking of, but it looks equally prone to being assembled wrong resulting in air leaks.

Doug

https://www.carcarekiosk.com/video/2...engine/replace


.
sheila likes this.

_

If your socket set is all the same brand, you might be a city slicker.

.
plano-doug is offline  
post #13 of (permalink) Old 06-26-2019
Senior Member
 
Joes74challenger's Avatar
 
Join Date: Apr 2016
Location: Fort Wayne
Posts: 1,289
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 251 Post(s)
Thanks: 30
Thanked 122 Times in 118 Posts
Garage
Quote:
Originally Posted by plano-doug View Post
Here's a video for the gen9 Impala. It's a totally different setup than the gen8 I was thinking of, but it looks equally prone to being assembled wrong resulting in air leaks.

Doug

https://www.carcarekiosk.com/video/2...engine/replace


.
yeah the gen 8s shape was just close enough to get it confused easily, you had to pay close attention. another point i didn't see mentioned was where are you getting your fuel? from a top tier station or a non-top tier. maybe run a few tanks from a top tier and see what happens.throw some fuel injector cleaner in there as well to see if it is plugged up already (seems awfully early but if the previous owner was getting his fuel from some dirty fuel tanks it might have some gunk in the tank?).
plano-doug likes this.
Joes74challenger is offline  
Sponsored Links
Advertisement
 
Reply

Related Threads
Thread Thread Starter Forum Replies Last Post
P0172 Fuel Rich moviesnmore Autocare and Maintenance 3 05-20-2019 08:38 AM
Jumping/Bypassing Fuel Pump Relay on 2013 LS 2013LS Chevy Impala 8th Gen Discussion 1 04-23-2019 06:23 AM
Car wont start, fuel pump replaced, filter just replaced... tonydaman04 Chevy Impala 7th Gen Discussion 10 10-13-2018 05:12 PM
Flex Fuel Issues jc69ful 8th Gen Engine Performance 2 03-30-2018 02:35 PM
2012 Impala LTZ Fuel Pump Failure SAAN Chevy Impala 8th Gen Discussion 9 02-13-2018 11:31 AM


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome