2003 Impala High Beam Out - Chevy Impala Forums
Autocare and Maintenance Auto detailing, care, and maintenance.

User Tag List

 1Likes
  • 1 Post By 1999 White C5 Coupe
 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 09-30-2019 Thread Starter
Junior Member
 
Hgreen's Avatar
 
Join Date: Sep 2019
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
2003 Impala High Beam Out

I am having an issue with my turn signals, they work but are dim. My message center says High Beam Out but my lights are working. Help!
Hgreen is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 09-30-2019
Senior Member
 
1999 White C5 Coupe's Avatar
 
Join Date: Jul 2014
Posts: 1,401
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 218 Post(s)
Thanks: 109
Thanked 237 Times in 211 Posts
Quote:
Originally Posted by Hgreen View Post
I am having an issue with my turn signals, they work but are dim. My message center says High Beam Out but my lights are working. Help!

Dim bulb performance usually indicates a bad ground, or a corroded socket.

Remove the turn signal bulbs and examine the inside of the sockets. If not too corroded, you can clean them with electrical contacts cleaner (and clean the base of the bulbs). Reinstall with a small amount of dielectric grease (available for about $1 in many auto parts’ stores in “ketchup pack” style packs).

Following the wiring harness that from the headlamp capsule. Usually the left and right are separate, and plug into a front, cross car wiring harness. Remove the electrical connectors and examine them - clean as above. You may have remove some items, or follow the wiring harness path with a mirror.

Remove the high beam bulb and examine the socket. Clean as above.
plano-doug likes this.
1999 White C5 Coupe is online now  
post #3 of (permalink) Old 10-05-2019
Junior Member
 
wz7u's Avatar
 
Join Date: Jun 2018
Location: Rural NW Oregon, in the corner by the river
Posts: 28
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
Have you installed aftermarket LED headlight bulbs by chance?

I did and am having the High Beam Out issue as well. I'm told I need to buy some sort of intermediary box to cure the problem. I'm considering simply converting back to standard bulbs to alleviate the problem.

'03 3.4 with lots of miles, 230k+
wz7u is offline  
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome