2000 impala service vehicle soon - Page 2 - Chevy Impala Forums
Autocare and Maintenance Auto detailing, care, and maintenance.

User Tag List

 2Likes
Reply
 
LinkBack Thread Tools Display Modes
post #16 of (permalink) Old 4 Days Ago Thread Starter
Junior Member
 
Ladyeolus's Avatar
 
Join Date: Aug 2019
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Thanks: 0
Thanked 2 Times in 2 Posts
Quote:
Originally Posted by Pattrick_Martin2001 View Post
Quote:
Originally Posted by Ladyeolus View Post
I took it to the mechanic. He said the coolant sensor i bought was bad....it was bought a new one.
Light is out.
But the service vehicle light is still on i could not get a emmissions test i had to much gas in car.
I was told it's okay to use it.
The whole deal cost me 80$. For now
Check your fuses. Especially the ones dealing with lighting. I know it sounds weird but I had a fuse go out in my car that caused one headlight to be dimmer than the other and it made my service vehicle soon light come on.
Will do
Ladyeolus is offline  
Sponsored Links
Advertisement
 
post #17 of (permalink) Old 3 Days Ago Thread Starter
Junior Member
 
Ladyeolus's Avatar
 
Join Date: Aug 2019
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Thanks: 0
Thanked 2 Times in 2 Posts
I needed transmission fluid but that still didn't Make my servise soon light go out.
Ladyeolus is offline  
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome