Engine Misfiring - Chevy Impala Forums
Autocare and Maintenance Auto detailing, care, and maintenance.

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 06-10-2018 Thread Starter
Junior Member
 
Taylor Wilson's Avatar
 
Join Date: Jun 2018
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Hey, guys. First off, new here. Hope this is the right place for this. I've got a 2007 Impala LTZ with a 3.9L engine. 153,000 miles.

Alright, I'll dive on into the issues:

Engine idling rough
Acceleration Hesitation and when it comes on, car SLOWLY accelerates
Rough shifting
"Service Traction Control" light AND message ON
Check engine lights blinks (sometimes will stay on)
Engine will lose most of it's power when going up a hill
Engine codes: 2 codes and both read P0300 (random misfire)

As of earlier, on my way to buy a new throttle body, the charging system light popped on. On the way home, the vehicle went into power save mode.

Now, things I've done and replaced:

Sparkplugs
Sparkplug wires
Ignition coil
Throttle body
Royal purple and Seafoam into the gas tank (the injector cleaner)
MAF sensor cleaned

I have no idea what else to do. I need my car running ASAP. It was in perfect running condition a week ago. Then the T/C light came on, followed by the engine light. All out of the blue.

Any ideas on my next move?

(Feel free to ask any questions that might help determine the issue)
Taylor Wilson is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 06-11-2018
Senior Member
 
12 lt's Avatar
 
Join Date: Feb 2017
Posts: 999
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 228 Post(s)
Thanks: 70
Thanked 85 Times in 80 Posts
Garage
Random misfire, would be a good idea imo to check for spark at each plug if possible. Ignition coils or coil packs and the icm if your model has one would be things I would check.

My 6 year constantly asks why. What adults can learn from 5 and 6 year olds, to listen with your ears and mind open. Hard to learn when you don't listen ......
12 lt is offline  
Sponsored Links
Advertisement
 
Reply

Related Threads
Thread Thread Starter Forum Replies Last Post
2008 impala LT 3.9l engine tick and cuts out under acceleration Brandondh Chevy Impala 8th Gen Discussion 7 04-17-2019 03:15 PM
2012 engine replacement Jaestes Automotive Discussion 6 02-20-2019 05:51 AM
Tapping sound in engine. Could use some help insomnia Chevy Impala Discussion 5 01-24-2019 11:03 AM
Engine unable to align with frame while replacing engine mount James06 Chevy Impala 8th Gen Discussion 5 12-24-2018 02:06 PM
Please help with engine noise 2012 LT 3.6 Jeffk426 Chevy Impala 8th Gen Discussion 5 05-01-2018 02:21 AM


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome