Aftermarker Radio - Chevy Impala Forums
Audio, Video, and Electronics All audio, video, alarms, and all other electronics.

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 06-07-2014 Thread Starter
Junior Member
 
A.Marra's Avatar
 
Join Date: May 2014
Location: Macomb, Michigan
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
Aftermarker Radio

I have a 2004 Impala (Base)

I have searched and read several topics about this but I haven't found exactly what I'm looking for. I know i lose the door chimes if i don't get the adapter piece for the radio, what I'm wondering is what else exactly will I lose?

My second question is if i keep the stock radio, and at some point wish to put it back in, will it function just as it did before?

I am about to install the radio, and i have all the parts(Dash Kit etc.) and I'm about to install it.

Thank you for the help!
A.Marra is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 06-07-2014
Go Get It

 
RYD SLO's Avatar
 
Join Date: Aug 2012
Location: MD
Posts: 15,017
Mentioned: 21 Post(s)
Tagged: 0 Thread(s)
Quoted: 99 Post(s)
Thanks: 2,053
Thanked 3,178 Times in 2,458 Posts
If you get the harness, the stock radio will work just as it does when you plug it back in. I got the "relocation harness" which keeps the stock radio in the trunk/under the seat (wherever you want to put it really) and keeps all the chimes, etc. It was ~$25

~Jeff
*2001 Impala Ls - 134k
Precision 6262 Turbo, ZZP Z3, CXRacing intercooler, ZZP 3" Cat-back, Muffler delete, Bosch 42.5# Injectors, Bosch fuel pump, CTS-V Brembos, Stainless lines, CM GP springs, Dorman solid sway bar, SPEC-D LED headlights, LED heads and fogs, Quad tails, C5 reverse lights, All LED interior, LED 6 gauge cluster retrofit, LED puddle lights, LED underglow, Debadged, Dipped emblems, Color-matched trim, Kenwood DDX271, Polk Audio dxi6500 components, Polk Audio db690, Hifonics GLX100.4, 2x Polk Audio db1240 in custom box, Hifonics ZRX1800.1D, KMC District, Nitto NT555G2, SS tail covers, SS spoiler, SS Lip, 20% tint, Black mesh grille

*1999 Escalade - 150k
Winter daily on 22s

*2005 GTO - 72k
LS2/6SPD FOR SALE

*2014 Impala LT Limited - 35k
"Dad's ride"

*1992 Caprice Wagon - Sold @ 195k
RYD SLO is offline  
The Following User Says Thank You to RYD SLO For This Useful Post:
A.Marra (06-07-2014)
post #3 of (permalink) Old 06-07-2014 Thread Starter
Junior Member
 
A.Marra's Avatar
 
Join Date: May 2014
Location: Macomb, Michigan
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by RYD SLO View Post
If you get the harness, the stock radio will work just as it does when you plug it back in. I got the "relocation harness" which keeps the stock radio in the trunk/under the seat (wherever you want to put it really) and keeps all the chimes, etc. It was ~$25
thanks for the reply. The relocation harness.. is it a lot of wires that you have to run? or is it just like a power wire or something?
A.Marra is offline  
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 06-07-2014
Go Get It

 
RYD SLO's Avatar
 
Join Date: Aug 2012
Location: MD
Posts: 15,017
Mentioned: 21 Post(s)
Tagged: 0 Thread(s)
Quoted: 99 Post(s)
Thanks: 2,053
Thanked 3,178 Times in 2,458 Posts
You have to run the wires from the back of the aftermarket headunit to wherever you relocate the factory unit, and you'll have to run the power wire to the fuse box (at the RAP relay for switched power). Then all you have to do is connect the wires from the harness from the aftermarket headunit to the relocation harness, and you're good.

~Jeff
*2001 Impala Ls - 134k
Precision 6262 Turbo, ZZP Z3, CXRacing intercooler, ZZP 3" Cat-back, Muffler delete, Bosch 42.5# Injectors, Bosch fuel pump, CTS-V Brembos, Stainless lines, CM GP springs, Dorman solid sway bar, SPEC-D LED headlights, LED heads and fogs, Quad tails, C5 reverse lights, All LED interior, LED 6 gauge cluster retrofit, LED puddle lights, LED underglow, Debadged, Dipped emblems, Color-matched trim, Kenwood DDX271, Polk Audio dxi6500 components, Polk Audio db690, Hifonics GLX100.4, 2x Polk Audio db1240 in custom box, Hifonics ZRX1800.1D, KMC District, Nitto NT555G2, SS tail covers, SS spoiler, SS Lip, 20% tint, Black mesh grille

*1999 Escalade - 150k
Winter daily on 22s

*2005 GTO - 72k
LS2/6SPD FOR SALE

*2014 Impala LT Limited - 35k
"Dad's ride"

*1992 Caprice Wagon - Sold @ 195k
RYD SLO is offline  
post #5 of (permalink) Old 06-11-2014
Senior Member
 
snitsky999's Avatar
 
Join Date: Mar 2013
Posts: 455
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 3
Thanked 26 Times in 24 Posts
The stock radio should work fine if you ever put it back in. It has the original car VIN number or something in it to only use in that specific vehicle. Its called a Theft Lock radio. So if you sold this radio or wanted to use it in another GM vehicle (w/the same radio) it would have to be unlocked. The dealer can do it. I found instructions online how to do it yourself if they work. How to Unlock a Chevy Radio | eHow

Read this question from a question asked on this forum about a 2000-2005 Impala factory radio to be replaced with and aftermarket one.
https://www.impalaforums.com/audio-vi...et-stereo.html
Read the answer from 2004 Indy SS (the 2nd answer) however as you know this person is wrong. You don't need to keep the factory radio in your car. All you need is some kit to bypass it. Since you can mess up your cars computer w/out proper installation please research this first. You best to have a professional do it just for piece of mind. I had an aftermarket radio installed at Best Buy in my former 2004 Impala and the installation cost more than the radio. I had an aftermarket radio installed in my 2010 Impala (still have) and that too costed more than the radio. However it was well worth the money because I got better sound and my iPod syncs with the radio.

Last edited by snitsky999; 06-11-2014 at 03:28 PM. Reason: add a link
snitsky999 is offline  
post #6 of (permalink) Old 06-11-2014 Thread Starter
Junior Member
 
A.Marra's Avatar
 
Join Date: May 2014
Location: Macomb, Michigan
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
thanks guys, got it all hooked up the other night. Trying to run my sub cables under the carpet to the trunk now. Should be a lot of fun. lol
A.Marra is offline  
post #7 of (permalink) Old 06-12-2014
Senior Member
 
darkeyce02's Avatar
 
Join Date: Dec 2012
Location: West Virginia
Posts: 1,209
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 180
Thanked 236 Times in 160 Posts
Quote:
Originally Posted by A.Marra View Post
thanks guys, got it all hooked up the other night. Trying to run my sub cables under the carpet to the trunk now. Should be a lot of fun. lol
run it under the trim along the bottom of the doors. plenty of room. you don't even need to pull any of it up to stuff it under.


2005 Impala SS
darkeyce02 is offline  
The Following User Says Thank You to darkeyce02 For This Useful Post:
RYD SLO (06-12-2014)
post #8 of (permalink) Old 06-12-2014
Go Get It

 
RYD SLO's Avatar
 
Join Date: Aug 2012
Location: MD
Posts: 15,017
Mentioned: 21 Post(s)
Tagged: 0 Thread(s)
Quoted: 99 Post(s)
Thanks: 2,053
Thanked 3,178 Times in 2,458 Posts
x2 Trying to run it under the carpet is just a PITA unless you're doing a full build and pull the whole interior out. Even with a full build, I used the trim along the bottom. 3 sets of RCAs through one side, and 8awg amp wiring, the wiring for the relocation harness, and some assorted other wired through the other. Plenty of space to stuff the wiring in, but now I'm pretty much out of room on both sides

~Jeff
*2001 Impala Ls - 134k
Precision 6262 Turbo, ZZP Z3, CXRacing intercooler, ZZP 3" Cat-back, Muffler delete, Bosch 42.5# Injectors, Bosch fuel pump, CTS-V Brembos, Stainless lines, CM GP springs, Dorman solid sway bar, SPEC-D LED headlights, LED heads and fogs, Quad tails, C5 reverse lights, All LED interior, LED 6 gauge cluster retrofit, LED puddle lights, LED underglow, Debadged, Dipped emblems, Color-matched trim, Kenwood DDX271, Polk Audio dxi6500 components, Polk Audio db690, Hifonics GLX100.4, 2x Polk Audio db1240 in custom box, Hifonics ZRX1800.1D, KMC District, Nitto NT555G2, SS tail covers, SS spoiler, SS Lip, 20% tint, Black mesh grille

*1999 Escalade - 150k
Winter daily on 22s

*2005 GTO - 72k
LS2/6SPD FOR SALE

*2014 Impala LT Limited - 35k
"Dad's ride"

*1992 Caprice Wagon - Sold @ 195k
RYD SLO is offline  
post #9 of (permalink) Old 07-08-2014
Senior Member
 
2002impalaLS's Avatar
 
Join Date: Jun 2014
Location: Alberta Canada
Posts: 198
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 28
Thanked 26 Times in 21 Posts
i used the gm035 harness cut the one connector off that was not needed and ran a 12v ign wire from the rap relay everything works great and it cost me $12 and im running a pioneer 8400bh, and there are ways around resetting lights besides the stock radio, and if you do need to program a new fob just plug the stock stereo in for that, also dont run the power and remote wire with the rcas as interference may occur
2002impalaLS is offline  
post #10 of (permalink) Old 05-07-2015
Junior Member
 
sonny62's Avatar
 
Join Date: May 2015
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 2
Thanked 0 Times in 0 Posts
2005 Impala Radio

I just picked up a new Radio to put in my Impala. I was stupid and in a rush to install so I cut the Radio harness and went to install it. I matched up all the wires correctly and the radio comes on with no error messages from the radio but i get no sound what so ever. I know the wires are wired up correctly. My big question do i need to somehow hook up the Amp in the trunk to get sound out of them. I have no extra wires on the after market radio harness. ANy help would be appriciated.
sonny62 is offline  
post #11 of (permalink) Old 05-07-2015
Go Get It

 
RYD SLO's Avatar
 
Join Date: Aug 2012
Location: MD
Posts: 15,017
Mentioned: 21 Post(s)
Tagged: 0 Thread(s)
Quoted: 99 Post(s)
Thanks: 2,053
Thanked 3,178 Times in 2,458 Posts
Yes, the amp needs to see power. Try hooking up the amp turn-on wire to your switched power source.

~Jeff
*2001 Impala Ls - 134k
Precision 6262 Turbo, ZZP Z3, CXRacing intercooler, ZZP 3" Cat-back, Muffler delete, Bosch 42.5# Injectors, Bosch fuel pump, CTS-V Brembos, Stainless lines, CM GP springs, Dorman solid sway bar, SPEC-D LED headlights, LED heads and fogs, Quad tails, C5 reverse lights, All LED interior, LED 6 gauge cluster retrofit, LED puddle lights, LED underglow, Debadged, Dipped emblems, Color-matched trim, Kenwood DDX271, Polk Audio dxi6500 components, Polk Audio db690, Hifonics GLX100.4, 2x Polk Audio db1240 in custom box, Hifonics ZRX1800.1D, KMC District, Nitto NT555G2, SS tail covers, SS spoiler, SS Lip, 20% tint, Black mesh grille

*1999 Escalade - 150k
Winter daily on 22s

*2005 GTO - 72k
LS2/6SPD FOR SALE

*2014 Impala LT Limited - 35k
"Dad's ride"

*1992 Caprice Wagon - Sold @ 195k
RYD SLO is offline  
The Following User Says Thank You to RYD SLO For This Useful Post:
sonny62 (05-08-2015)
post #12 of (permalink) Old 05-08-2015
Junior Member
 
sonny62's Avatar
 
Join Date: May 2015
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 2
Thanked 0 Times in 0 Posts
Would that be the other connector off the stock radio that has only 2 wires?
sonny62 is offline  
post #13 of (permalink) Old 05-08-2015
Go Get It

 
RYD SLO's Avatar
 
Join Date: Aug 2012
Location: MD
Posts: 15,017
Mentioned: 21 Post(s)
Tagged: 0 Thread(s)
Quoted: 99 Post(s)
Thanks: 2,053
Thanked 3,178 Times in 2,458 Posts
Unsure. I used a harness and bypassed my factory amp. My entire stereo is aftermarket, so I never bothered with trying to figure out which wire did what.

~Jeff
*2001 Impala Ls - 134k
Precision 6262 Turbo, ZZP Z3, CXRacing intercooler, ZZP 3" Cat-back, Muffler delete, Bosch 42.5# Injectors, Bosch fuel pump, CTS-V Brembos, Stainless lines, CM GP springs, Dorman solid sway bar, SPEC-D LED headlights, LED heads and fogs, Quad tails, C5 reverse lights, All LED interior, LED 6 gauge cluster retrofit, LED puddle lights, LED underglow, Debadged, Dipped emblems, Color-matched trim, Kenwood DDX271, Polk Audio dxi6500 components, Polk Audio db690, Hifonics GLX100.4, 2x Polk Audio db1240 in custom box, Hifonics ZRX1800.1D, KMC District, Nitto NT555G2, SS tail covers, SS spoiler, SS Lip, 20% tint, Black mesh grille

*1999 Escalade - 150k
Winter daily on 22s

*2005 GTO - 72k
LS2/6SPD FOR SALE

*2014 Impala LT Limited - 35k
"Dad's ride"

*1992 Caprice Wagon - Sold @ 195k
RYD SLO is offline  
The Following User Says Thank You to RYD SLO For This Useful Post:
sonny62 (05-08-2015)
post #14 of (permalink) Old 05-08-2015
Junior Member
 
sonny62's Avatar
 
Join Date: May 2015
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 2
Thanked 0 Times in 0 Posts
I will see if I can find out what wire that is. Thanks for the help
sonny62 is offline  
post #15 of (permalink) Old 05-08-2015
Junior Member
 
sonny62's Avatar
 
Join Date: May 2015
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 2
Thanked 0 Times in 0 Posts
I went on line and I saw a video and hooked it up the way it showed and everything works perfect now. Just have to put everything back together and hide the wire I had to run.
sonny62 is offline  
Sponsored Links
Advertisement
 
Reply

Related Threads
Thread Thread Starter Forum Replies Last Post
Ideas for turning car radio into portable stereo jtrosky Off-Topic Discussion 56 04-25-2019 10:12 AM
car won't start after radio change stovebolt6 Chevy Impala 7th Gen Discussion 1 03-09-2019 11:11 AM
2014 Impala Limited Radio Issues rmkrueger Chevy Impala 8th Gen Discussion 5 06-30-2018 07:58 AM
Features gone after aftermarket radio install lindauer99 Audio, Video, and Electronics 4 11-10-2017 09:14 AM
Radio won't work RoyalzDemize Audio, Video, and Electronics 0 08-21-2017 07:56 PM


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome