Turn signal problems - Chevy Impala Forums
Audio, Video, and Electronics All audio, video, alarms, and all other electronics.

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 08-31-2019 Thread Starter
Junior Member
 
Jordan.wagoner814's Avatar
 
Join Date: Feb 2019
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Turn signal problems

Hey all, not sure if this is the right place for this post but anyways. Got a 06 impala lt and im having some issues with the right side turn signal. I did full LED's in the rear and installed load equalizers to combat the hyper flash. However when i drove up to Pittsburgh last week my right signal began to hyperflash again. So i checked everything thinking i had a light out. No light out but with the right turn signal on, the front blinker wouldnt blink it just stayed solid yellow. So i gave the headlight the old tap tap with my hand and it went back to normal. But today it started doing it again and i couldnt get it to work again. I pulled the headlight out and checked the wires, gave them a wiggle but still nothing, pulled the taillight, made sure everything was still hooked up and it was. Went back around the front and it was blinking fine. Closed the hood and went to check it again and it was hyperflashing and not blinking again! Anyone have any insight? Its driving me mad. Sorry for the run on post. Any help is appreciated.
Jordan.wagoner814 is offline  
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome