Installing an aftermarket stereo in an '04 Impala - Chevy Impala Forums
Audio, Video, and Electronics All audio, video, alarms, and all other electronics.

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 2 Weeks Ago Thread Starter
Junior Member
 
Kilgore Trout's Avatar
 
Join Date: Aug 2019
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Installing an aftermarket stereo in an '04 Impala

Hi! So my girlfriend has a 2004 Impala and she has the radio with the Delphi AM/FM CD only, no aux in and no cassette (also no steering wheel controls, if that's relevant to my questions). In her words, "Who even uses CD's anymore?" She's big on the podcasts and really wishes she could use her phone with her car stereo. I've replaced head units before and my '95 Sonoma and my '86 Cutlass were pieces of cake, even without a harness adapter, but I didn't realize what a headache these Theftlock radios can be.

So I have a few questions. First, I've seen some advice online saying you have to relocate the factory radio to the trunk to preserve the functionality of the little message center in the gauge cluster and this T-harness on Amazon seems to be the way to go (with a slight modification to allow the aftermarket unit to work with the Impala's RAP system). But some people in the original post said you can still reset those lights with a sequence of key-turning and pedal-pressing and you don't actually need to keep the original radio at all. Is this true?

My second question is about the second, small plug in the back of the factory radio. Whether we go with the relocation adapter or just hack directly into the wiring without keeping the original (if that's even possible), I have no idea what those two plugs in that second plug are for and I haven't been able to find out any information about them at all. It's only got two wires going into it -- a green and a black one. What do they do and what should I do about them while installing the new radio?

And, for some reason, my embedded links weren't displaying properly (I'm new to the Impala forums and guess I haven't quite figured out its little foibles), but I got most of my information (and the link to the T-harness adpater) from this post here on the Impala forums from like 10 years ago: https://www.impalaforums.com/audio-v...et-stereo.html
Attached Images
 

Last edited by Kilgore Trout; 2 Weeks Ago at 09:08 PM.
Kilgore Trout is offline  
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome