2009 Impala Police Audio/Turn Signal/Wiring Issue??? - Chevy Impala Forums
Audio, Video, and Electronics All audio, video, alarms, and all other electronics.

User Tag List

 1Likes
  • 1 Post By DK20
 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 05-19-2018 Thread Starter
Junior Member
 
DK20's Avatar
 
Join Date: May 2018
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
2009 Impala Police Audio/Turn Signal/Wiring Issue???

Recently I got a 09’ Police Impala and as usual they completely cut the entire wire harness under the dash on the passenger side. No audio, horn, nothing. I got the audio working and it’s been fine for month. I just got around to finding the tan wire for the horn and connected that. Everything works fine except when my left turn signal is on it pauses the radio?? Same thing when I apply the brakes. Doesn’t do it if I use my right turn signal. Also noticed that my left brake light will stay on for about a minute after I turn the car off. I’m convinced there’s some wires touching under the glove box because that’s the last thing I messed with before this started happening. I did nothing but connect the wire for the horn so I’m puzzled. I taped all the wires off that aren’t being used. I checked the fuses under the hood as well. I’m completely lost some body please lead me in the right direction.
Timmy207 likes this.
DK20 is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 05-05-2019
Junior Member
 
eliasfite's Avatar
 
Join Date: May 2019
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
I have a similar issue with my 07 police impala. The wiring under steering wheel is scary and there is also a viper alarm. Too many wires cut and modified for my experience level. Brake lights not working now and used to intermittently work when not being used and I'm pretty sure through research that an additional brake light toggle switch was installed for them to manually turn off the brake lights. This may be the same type scenario for you too. Under my console, I'm going to reinstall a toggle switch to two obvious wires leading from the brake switch and viper alarm that are disconnected. Fingers crossed as there are so many wiring mods under there. Good luck

Sent from my SM-G955U using Tapatalk
eliasfite is offline  
Sponsored Links
Advertisement
 
Reply

Related Threads
Thread Thread Starter Forum Replies Last Post
Building a 2011 Impala police car Douglas Willette Introductions & Welcome Forum 2 10-28-2018 02:51 PM
2009 Impala radio disabled vinniemac84 Chevy Impala 8th Gen Discussion 1 07-13-2018 11:14 AM
2009 Chevrolet Impala Police Interceptor RSS Bot eBay Cars For Sale: Impala 0 10-11-2017 03:40 AM
2009 Chevrolet Impala Police Interceptor RSS Bot eBay Cars For Sale: Impala 0 09-22-2017 03:00 PM
2009 Chevrolet Impala Police Interceptor RSS Bot eBay Cars For Sale: Impala 0 09-13-2017 02:30 PM


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome