Using E-85 fuel possible issue coded P228C - Chevy Impala Forums
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 08-25-2017 Thread Starter
Junior Member
 
Michigan1's Avatar
 
Join Date: Aug 2017
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Using E-85 fuel possible issue coded P228C

I just put my first tank of E85 in my 2015 Impala Limited (old style) 48000 miles. Gas gauge was almost on Empty when it threw code P228C, Service Stabilitrak, Etc. Engine power reduced...... After looking up online every site says "Fuel Pressure Regulator 1 Exceeded Control Limits - Pressure Too Low..." I found this interesting also. http://www.revbase.com/BBBMotor/TSb/...dPdf?id=195546 check it out! . So filled tank with premium gas and reset MIL code. 2 days now, no codes! I am blaming the E85, either contaminated or just shiitty fuel. no more E85 for me
Michigan1 is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 08-25-2017
Junior Member
 
Replacement's Avatar
 
Join Date: Feb 2016
Location: Twin Cities
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
I tried a tank of e85, that was all it took for me, I'll never put it in again.

Hermes: Sorry, I spent all day putting my office in order. Now I got to go home and relax the traditional Jamaican way: A glass of warm milk and good night sleep.
Fry: Jamaican? I thought you were some kinda outer-space potato man.
Replacement is offline  
The Following User Says Thank You to Replacement For This Useful Post:
TSS (08-25-2017)
post #3 of (permalink) Old 08-31-2017
Junior Member
 
njzehr's Avatar
 
Join Date: Aug 2017
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
See TSB #PIP5385C
As far as I know GM has identified concerns of repeat codes P228C, P0171 and P0174 (see TSB #05-06-04-035E )
I think as of now they are running pressure tests from low side to high side hoping either a high pressure fuel pump inlet is somehow clogged or that the gas supplied is overly mixed/contaminated at the pump.
Rarely do I see fuel pump inlets actually clogged, usually the supplied gas is either overly mixed running too rich ethanol but more common than that the gas is heavily contaminated with mineral water at the storage tank. my two cents.
http://www.revbase.com/BBBMotor/TSb/...dPdf?id=198008
njzehr is offline  
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 09-06-2017
Senior Member
 
etb4u's Avatar
 
Join Date: Nov 2016
Posts: 109
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 17 Post(s)
Thanks: 11
Thanked 5 Times in 5 Posts
Quote:
Originally Posted by Michigan1 View Post
I just put my first tank of E85 in my 2015 Impala Limited (old style) 48000 miles. Gas gauge was almost on Empty when it threw code P228C, Service Stabilitrak, Etc. Engine power reduced...... After looking up online every site says "Fuel Pressure Regulator 1 Exceeded Control Limits - Pressure Too Low..." I found this interesting also. http://www.revbase.com/BBBMotor/TSb/...dPdf?id=195546 check it out! . So filled tank with premium gas and reset MIL code. 2 days now, no codes! I am blaming the E85, either contaminated or just shiitty fuel. no more E85 for me
Probably due to it being low on fuel + e85. e85 makes the pump work harder. Running the tank too low gave it fuel pressure issues. I don't think it's the e85 itself. See my thread about a little trial and error with it: https://www.impalaforums.com/#/topics/1659754
etb4u is offline  
post #5 of (permalink) Old 11-07-2018
Junior Member
 
Digs's Avatar
 
Join Date: Sep 2018
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Had this exact same problem. Dealership replaced the high pressure fuel pump under warranty at 29,000 miles.
Digs is offline  
Sponsored Links
Advertisement
 
Reply

Related Threads
Thread Thread Starter Forum Replies Last Post
Jumping/Bypassing Fuel Pump Relay on 2013 LS 2013LS Chevy Impala 8th Gen Discussion 1 04-23-2019 06:23 AM
Car wont start, fuel pump replaced, filter just replaced... tonydaman04 Chevy Impala 7th Gen Discussion 10 10-13-2018 05:12 PM
2012 Impala LTZ Fuel Pump Failure SAAN Chevy Impala 8th Gen Discussion 9 02-13-2018 11:31 AM
Fuel line repair on Impala but no space to use Tubing cutter john5246 Chevy Impala 7th Gen Discussion 4 08-23-2017 06:55 AM


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome