Idol issue - Chevy Impala Forums
User Tag List

 1Likes
  • 1 Post By Revo2Maxx2016
 
LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 02-23-2017 Thread Starter
Junior Member
 
Jl1ne's Avatar
 
Join Date: Jun 2016
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Idol issue

Hey guys i have 2008 Impala Police Package no engine code or nothing serious wrong with the car but when i am idoling i feel the car shaking a little nothing crazy but im very anal with my cars and id like to know what the cause COULD be. Thanks in advance!
Jl1ne is offline  
Sponsored Links
Advertisement
 
post #2 of (permalink) Old 02-23-2017
Senior Member
 
Revo2Maxx2016's Avatar
 
Join Date: Aug 2016
Location: Northwest USA
Posts: 588
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 82 Post(s)
Thanks: 5
Thanked 95 Times in 93 Posts
It is hard to say really what it could be without being there with the car... A place I would look if it was my car is how is the Motor mounts, Also Sub Frame mounts. When was the last turn up done? If none since you bought the car. Get a Tune up, (Fuel Filter, Air Filter, Plugs, and wires.) Check over Struts/Shocks. Test with a Good OBD II reader looking for Pending Codes.

Not that you have to do anything I just said, Just something that I would look over/do if I had your car with what you describe

James
Jl1ne likes this.

It isn't what you Drive that matters, It is how you drive it.

James
Revo2Maxx2016 is offline  
post #3 of (permalink) Old 04-17-2017
Z71
Senior Member
 
Z71's Avatar
 
Join Date: May 2010
Posts: 414
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 18 Post(s)
Thanks: 4
Thanked 26 Times in 22 Posts
Police cars lead a hard life. They often idle for hours in hot weather with A/C and emergency lights on. Maybe the car needs a set of new plug wires? And they are also driven hard if used as patrol cars.
Z71 is offline  
Sponsored Links
Advertisement
 
post #4 of (permalink) Old 04-18-2017
Senior Member
 
Joes74challenger's Avatar
 
Join Date: Apr 2016
Location: Fort Wayne
Posts: 1,308
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 254 Post(s)
Thanks: 30
Thanked 122 Times in 118 Posts
Garage
@Revo, the fuel filter is in the tank on my 2010..autozone wouldn't even sell me one a few years ago...i was quite upset about that one...
Joes74challenger is offline  
post #5 of (permalink) Old 04-18-2017
Senior Member
 
Revo2Maxx2016's Avatar
 
Join Date: Aug 2016
Location: Northwest USA
Posts: 588
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 82 Post(s)
Thanks: 5
Thanked 95 Times in 93 Posts
@Joes74challenger Thank you for the correction. Keep forgetting the 06 up are non serviceable as standard. Guess tune up everything besides the Fuel Filter..

Again thanks for the Reminder

James

It isn't what you Drive that matters, It is how you drive it.

James
Revo2Maxx2016 is offline  
Sponsored Links
Advertisement
 
Reply

Related Threads
Thread Thread Starter Forum Replies Last Post
Check Gauge light issue. TJ3 Automotive Discussion 4 07-19-2019 03:20 PM
2008 Impala Cooling fan issue jaredw60 Chevy Impala 8th Gen Discussion 1 12-07-2018 03:14 PM
Weird issue with door locks - ignition? RYD SLO Chevy Impala 7th Gen Discussion 0 05-15-2018 01:31 PM
2003 Impala Ls startup issue juskii Chevy Impala 8th Gen Discussion 0 08-24-2017 06:56 PM


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy Impala Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome