Chevy Impala Forums

Chevy Impala Forums (https://www.impalaforums.com/forum.php)
-   8th Gen Drivetrain (https://www.impalaforums.com/8th-gen-drivetrain/)
-   -   P0024 2012 impala (https://www.impalaforums.com/8th-gen-drivetrain/1871785-p0024-2012-impala.html)

Dfelt75 07-02-2019 04:10 PM

I am at wits end with this code.

Vehicle was purchased afew months ago, has 150k on it. Runs fine

So far i have cleaned/swapped both ocv solenoids. Changed oil and filter. Even installed new solenoid...code still returns after about 40 miles.

Oil is full and clean...code comes back faster if i mash on it. 40 or so miles if i baby it.

I have looked for obvious wire shorts/breaks..did not pull back any of the wire loom cover as it seemed very brittle.

Was debating using amsoil engine flush and another oil change but am kind of scared to use the flush.

Any helpful suggestions?

I also have torque pro app and watch the timing advance.

It seem to move by large numbers..ex 35 down to 15..not 34,33,32,31..not sure if suppose to move in those increments or not, i have never used that feature before

sheila 07-02-2019 08:10 PM

Search p0024 top right.

Dfelt75 07-03-2019 06:03 PM

I will ckeck on desk top tommrow...but i have ran into the same problem of past/post user just searching on my mobile...limited results on here and Google.

Another detail i forgot to mention in original post is slight shudder around 1400 to 1600 rpm

sheila 07-03-2019 07:49 PM

Did you search p zero zero 2 4? I get 6 pages of threads/posts. Some people mistakenly think the 2nd character is the letter "O".

kbz1960 07-04-2019 12:00 PM

Quote:

Originally Posted by sheila (Post 3687401)
Did you search p zero zero 2 4? I get 6 pages of threads/posts. Some people mistakenly think the 2nd character is the letter "O".

On tapatalk this is all I get. https://uploads.tapatalk-cdn.com/201...a0a716372b.jpg

jtrosky 07-04-2019 12:29 PM

Quote:

Originally Posted by kbz1960 (Post 3687457)
On tapatalk this is all I get.

For whatever reason, I've found the best way to search the site is to go into chrome/google and type "impalaforums.com p0024" - this will return like 6 pages of results... The search function using Googles search engine just works better than the forums search function....

Dfelt75 07-04-2019 05:00 PM

UPDATE

Car is fixed. No more cel/pending codes or shudder at lower rpm.

So I feel rather embarrassed on this one.

When the code first popped up I watched a video on you tube about it...the guy was replacing the rear ones..and this just stuck in my head.

Bank 1 = rear of engine/near firewall

Bank 2 = front side near radiator

In my mind i was just hearing "exhaust ocv"...Totally disregarding bank1 bank2

Hopefully my aggravation helps somone out

sheila 07-04-2019 06:43 PM

So, what'd you do/replace???

Dfelt75 07-04-2019 07:14 PM

Quote:

Originally Posted by sheila (Post 3687537)
So, what'd you do/replace???

Just the ocv. Good thing about being a tard and cleaning the wrong bank..new seals and super cleaned solenoids

And to help future guest of this problem...the following will be helpful

When you pull the solenoid out..the seal/OR PART OF IT does not come out with it, if it does it broken in two pieces. The seal stays in the head. If part of it come out /black circle ring stuck on solenoid/ , take a utility knife and cut one or two slices carefully to the seal left in the head. Get a new one p#12593717. Best and fastest way is dealership chevy or gmc..my chevy one didnt have it, only like 10$...not a part store around had one...buy in advance. I used a sturdy flat head screwdriver to pop it out of the head after cutting it. Be careful not to drop anything in the head while doing this...it was a pain in the ass.

I guess i could also suggest to maybe spray the solenoid area with some penetrating oil before attempting to remove them to keep them from breaking. I didnt even think of it while i was working on it...could have possibly saved a few bucks

jtrosky 07-05-2019 01:46 AM

Interesting. I've personally never ever heard of an "ocv" (had to look it up - "Oil Control Valve").

Where are they located and how hard were they to replace?

Jonathan Nicholes 07-09-2019 07:40 AM

the code is for "Exhaust Camshaft Position System Performance Bank 2". Their is a TSB out for changing the Exhaust Camshaft Position solenoid valve with a longer service part depending on the engine code on the EUN sticker. If the numbers do not match up on the sticker to what's noted in the TSB then it could still be the solenoid valve or the mechanical camshaft position actuator, or low oil level. Will need a tech2 to actuate the solenoid valve to find out if it's working right. Good thing your still under the bumper to bumper warranty.


Sent from my iPhone using Tapatalk

Dfelt75 07-09-2019 05:50 PM

UPDATE TO MY UPDATE

So the p0024 is long gong..yet i still do have the shudder..at 40mph and 60 mph..light load.

I replaced the old spark plugs. .toast...gap was like .50....ideals better but still shit for the shudder...

Read and read...sounds like its the torque converter. Im going to cheap out/smart out and do the drain and fill three times over about the next 2000 miles.

Will keep you all updated

SAAN 07-11-2019 04:06 PM

Quote:

Originally Posted by Dfelt75 (Post 3688221)
UPDATE TO MY UPDATE

So the p0024 is long gong..yet i still do have the shudder..at 40mph and 60 mph..light load.

I replaced the old spark plugs. .toast...gap was like .50....ideals better but still shit for the shudder...

Read and read...sounds like its the torque converter. Im going to cheap out/smart out and do the drain and fill three times over about the next 2000 miles.

Will keep you all updated


Have you tried to do a Valve Spray cleaning and run some fuel system cleaner as well to rule out dirty fuel system or dirty intake valves?

Dfelt75 08-03-2019 01:15 AM

SAAN you were correct.

Just did a coolant flush and also picked up some crc gdi cleaner...half through throttle body and other through brake booster line.

The shudder is gone.

Long live my 3.6


All times are GMT -7. The time now is 10:38 AM.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
This site is not affiliated nor endorsed by General Motors Corp. Chevy Impala and related trademarks are the property of General Motors Corp.

 
For the best viewing experience please update your browser to Google Chrome